aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-02-19 03:48:05 +0800
committertcberner <tcberner@FreeBSD.org>2017-02-19 03:48:05 +0800
commit3b326c79a89e9fb337c48a00eeb7f6124bb59e42 (patch)
tree4d04227f02c7fda007ad74be01e1393168277b0b /net
parent2f44a1d12d3882f9ebf589518bf7052e233f22e8 (diff)
downloadfreebsd-ports-gnome-3b326c79a89e9fb337c48a00eeb7f6124bb59e42.tar.gz
freebsd-ports-gnome-3b326c79a89e9fb337c48a00eeb7f6124bb59e42.tar.zst
freebsd-ports-gnome-3b326c79a89e9fb337c48a00eeb7f6124bb59e42.zip
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more
* Update Qt5 to 5.7.1 * Move Qt4 binaries to lib/qt4/bin * Move Qt5 libraries to lib/qt5/lib By moving the libraries we should finally be able to get rid of the inplace upgrade bug (see ports bugs 194088, 195105 and 198720): when Qt5's libraries were lying in /usr/local/lib, which would often get added by pkgconfig to the linker paths via dependencies, the already installed libraries were linked against, instead of the ones that were being built. This forced us to make sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the linker flags. With this change this should no longer be the case. * Rename some ports to match the rest (foo-qtX -> qtX-foo) * Depend on new port misc/qtchooser [see UPDATING & CHANGES] There are several new Qt5 ports which all have been created by Marie Loise Nolden <nolden@kde.org>. Thanks again. PR: 216797 Exp-Run by: antoine Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9213
Diffstat (limited to 'net')
-rw-r--r--net/qt4-network/Makefile1
-rw-r--r--net/qt5-network/pkg-plist7
-rw-r--r--net/rsplib/files/patch-configure10
-rw-r--r--net/wireshark/Makefile1
-rw-r--r--net/wireshark/files/extrapatch-configure-qt537
5 files changed, 53 insertions, 3 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 2d558f3b7c8d..aad22f0c4f2b 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -3,6 +3,7 @@
PORTNAME= network
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt4-
diff --git a/net/qt5-network/pkg-plist b/net/qt5-network/pkg-plist
index 01ffd0a0011c..60541f03172b 100644
--- a/net/qt5-network/pkg-plist
+++ b/net/qt5-network/pkg-plist
@@ -36,6 +36,7 @@
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkconfiguration_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkcookie_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkcookiejar_p.h
+%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkdatagram_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkdiskcache_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkinterface_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qnetworkproxy_p.h
@@ -148,9 +149,9 @@
%%QT_INCDIR%%/QtNetwork/qtcpsocket.h
%%QT_INCDIR%%/QtNetwork/qtnetworkversion.h
%%QT_INCDIR%%/QtNetwork/qudpsocket.h
-%%QT_LIBDIR%%/cmake/Qt5Network/Qt5NetworkConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5Network/Qt5NetworkConfigVersion.cmake
-%%QT_LIBDIR%%/cmake/Qt5Network/Qt5Network_QGenericEnginePlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Network/Qt5NetworkConfig.cmake
+%%QT_CMAKEDIR%%/Qt5Network/Qt5NetworkConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5Network/Qt5Network_QGenericEnginePlugin.cmake
%%QT_LIBDIR%%/libQt5Network.prl
%%QT_LIBDIR%%/libQt5Network.so
%%QT_LIBDIR%%/libQt5Network.so.5
diff --git a/net/rsplib/files/patch-configure b/net/rsplib/files/patch-configure
new file mode 100644
index 000000000000..60d83dac188c
--- /dev/null
+++ b/net/rsplib/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2017-01-18 19:43:22 UTC
++++ configure
+@@ -16692,7 +16692,6 @@ QT_REQUIRED_COMPONENTS="QtCore QtGui QtX
+ QT_DEFAULT_INCLUDE_PATHS="/usr/share/qt4/include /usr/local/include/qt4 /usr/include/qt4 /usr/include"
+ QT_DEFAULT_LIBRARY_PATHS="/usr/lib /usr/local/lib /usr/local/qt4/lib /usr/local/lib/qt4 /usr/share/qt4/lib `cat 2>/dev/null /etc/ld.so.conf.d/*.conf | sed -e "/# /d"` /usr/lib64"
+ QT_DEFAULT_BINARY_PATHS="/usr/bin /usr/local/bin /usr/local/qt4/bin /usr/share/qt4/bin"
+-QTPOSTFIX="-qt4"
+
+ QTEXTRAINC=""
+ QTEXTRALIB=""
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index a161ac651055..e825dc8a689a 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -116,6 +116,7 @@ ANDROIDDUMP_CONFIGURE_OFF=--enable-androiddump=no
LUA_CPPFLAGS= -I${LUA_INCDIR}
QT5_CONFIGURE_ENV= PATH="${PATH}:${QT_BINDIR}"
+QT5_EXTRA_PATCHES= ${FILESDIR}/extrapatch-configure-qt5
QT5_MAKE_ENV= PATH="${PATH}:${QT_BINDIR}"
QT5_VARS= PKGNAMESUFFIX=-qt5
QT5_PLIST_SUB= GUI_GTK="@comment "
diff --git a/net/wireshark/files/extrapatch-configure-qt5 b/net/wireshark/files/extrapatch-configure-qt5
new file mode 100644
index 000000000000..cfe84de16313
--- /dev/null
+++ b/net/wireshark/files/extrapatch-configure-qt5
@@ -0,0 +1,37 @@
+Work around the buggy detection of the Qt tools via qtchooser, which adds the -qt=foo
+flag even though the found tool is not qtchooser.
+
+--- configure.orig 2017-02-09 18:02:53 UTC
++++ configure
+@@ -47562,7 +47562,6 @@ fi
+ #
+ # Add the -qt={version} argument to it.
+ #
+- UIC="$UIC -qt=$qt_version"
+ else
+ #
+ # Annoyingly, on some Linux distros (e.g. Debian)
+@@ -47740,7 +47739,6 @@ fi
+ #
+ # Add the -qt={version} argument to it.
+ #
+- MOC="$MOC -qt=$qt_version"
+ else
+ #
+ # Annoyingly, on some Linux distros (e.g. Debian)
+@@ -47918,7 +47916,6 @@ fi
+ #
+ # Add the -qt={version} argument to it.
+ #
+- RCC="$RCC -qt=$qt_version"
+ else
+ #
+ # Annoyingly, on some Linux distros (e.g. Debian)
+@@ -48097,7 +48094,6 @@ fi
+ #
+ # Add the -qt={version} argument to it.
+ #
+- LRELEASE="$LRELEASE -qt=$qt_version"
+ else
+ #
+ # Annoyingly, on some Linux distros (e.g. Debian)