aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-04-13 00:45:41 +0800
committerlofi <lofi@FreeBSD.org>2004-04-13 00:45:41 +0800
commit40d00e89f470d7eef3cf1dd7906d930f326c548d (patch)
treea11b15673f97e4ccc4a3e0a824f178f8bf3ff7b0 /net
parent13dce98745d898104aa4f6454d9a9ecaa98997f0 (diff)
downloadfreebsd-ports-gnome-40d00e89f470d7eef3cf1dd7906d930f326c548d.tar.gz
freebsd-ports-gnome-40d00e89f470d7eef3cf1dd7906d930f326c548d.tar.zst
freebsd-ports-gnome-40d00e89f470d7eef3cf1dd7906d930f326c548d.zip
Change krb detection and dependencies again.
Submitted by: Maintainer
Diffstat (limited to 'net')
-rw-r--r--net/samba-devel/Makefile15
-rw-r--r--net/samba3/Makefile15
2 files changed, 16 insertions, 14 deletions
diff --git a/net/samba-devel/Makefile b/net/samba-devel/Makefile
index 341bfa23920e..e242fd1bfbbd 100644
--- a/net/samba-devel/Makefile
+++ b/net/samba-devel/Makefile
@@ -195,19 +195,20 @@ CONFIGURE_ARGS+= --with-expsam=${WANT_EXPSAM_MODULES}
# Kerberos5 is necessary for ADS
.if defined(WANT_KRB5)
-# Relay on PATH
-KRB5_PREFIX!= krb5-config --prefix
-.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
-CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
-.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME}
.elif ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr
.else
-#BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
-LIB_DEPENDS+= krb5.19:${PORTSDIR}/security/heimdal
+BUILD_DEPENDS+= krb5-config:${PORTSDIR}/security/heimdal
+KRB5_PREFIX!= krb5-config --prefix 2>/dev/null || true
+.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
+.else
+BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
+.endif
.endif
.else
CONFIGURE_ARGS+= --without-krb5
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 341bfa23920e..e242fd1bfbbd 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -195,19 +195,20 @@ CONFIGURE_ARGS+= --with-expsam=${WANT_EXPSAM_MODULES}
# Kerberos5 is necessary for ADS
.if defined(WANT_KRB5)
-# Relay on PATH
-KRB5_PREFIX!= krb5-config --prefix
-.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
-CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
-.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME}
.elif ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr
.else
-#BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
-LIB_DEPENDS+= krb5.19:${PORTSDIR}/security/heimdal
+BUILD_DEPENDS+= krb5-config:${PORTSDIR}/security/heimdal
+KRB5_PREFIX!= krb5-config --prefix 2>/dev/null || true
+.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
+.else
+BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
+.endif
.endif
.else
CONFIGURE_ARGS+= --without-krb5