aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-07-07 18:20:32 +0800
committerkoobs <koobs@FreeBSD.org>2015-07-07 18:20:32 +0800
commit4b86461a90130360315467177c809c832c32c80a (patch)
tree0a2da1e1c5b330dcfdafe63644222b4ce12a7d38 /net
parentc001fb382f37901339ca4fa01c81c49be082e37a (diff)
downloadfreebsd-ports-gnome-4b86461a90130360315467177c809c832c32c80a.tar.gz
freebsd-ports-gnome-4b86461a90130360315467177c809c832c32c80a.tar.zst
freebsd-ports-gnome-4b86461a90130360315467177c809c832c32c80a.zip
net/py-tweepy: Update to 3.3.0, Enable Python 3
- Update to 3.3.0 - Take MAINTAINER'ship - Switch to GITHUB to get access to the tests & test suite - Allow building with Python 3 (now supported) - Update BUILD_DEPENDS and RUN_DEPENDS - Sort USE_PYTHON values - Patch setup.py to correctly set test dependencies and hook in the setuptools test command - Patch out unnecessary (tox) test dependency. Changes: https://github.com/tweepy/tweepy/blob/v3.3.0/CHANGELOG.md First part of: PR: 200621 Reported by: Patrick P. <freebsdbug patpro net>
Diffstat (limited to 'net')
-rw-r--r--net/py-tweepy/Makefile16
-rw-r--r--net/py-tweepy/distinfo4
-rw-r--r--net/py-tweepy/files/patch-setup.py22
-rw-r--r--net/py-tweepy/files/patch-test__requirements.txt7
4 files changed, 42 insertions, 7 deletions
diff --git a/net/py-tweepy/Makefile b/net/py-tweepy/Makefile
index 1bccdc8ff2bf..4e46b6dacec9 100644
--- a/net/py-tweepy/Makefile
+++ b/net/py-tweepy/Makefile
@@ -2,17 +2,23 @@
# $FreeBSD$
PORTNAME= tweepy
-PORTVERSION= 2.3.0
+PORTVERSION= 3.3.0
CATEGORIES= net python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTVERSIONPREFIX= v
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= koobs@FreeBSD.org
COMMENT= Twitter API library for Python!
LICENSE= MIT
-USES= python:2
-USE_PYTHON= distutils autoplist
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:${PORTSDIR}/devel/py-pip
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.4.1:${PORTSDIR}/www/py-requests-oauthlib \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.7.3:${PORTSDIR}/devel/py-six
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/net/py-tweepy/distinfo b/net/py-tweepy/distinfo
index 82f31f812819..3cb4eb400272 100644
--- a/net/py-tweepy/distinfo
+++ b/net/py-tweepy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tweepy-2.3.0.tar.gz) = f7672fcfe9e17361adc7293ca6c98ad1517174267e917a5ec898e515c42b9271
-SIZE (tweepy-2.3.0.tar.gz) = 25273
+SHA256 (tweepy-tweepy-v3.3.0_GH0.tar.gz) = 96ac826401dafd30b1b05137cccd7e36d075a71869b64656075feaebb4e1536d
+SIZE (tweepy-tweepy-v3.3.0_GH0.tar.gz) = 599995
diff --git a/net/py-tweepy/files/patch-setup.py b/net/py-tweepy/files/patch-setup.py
new file mode 100644
index 000000000000..6a7f90eda2c2
--- /dev/null
+++ b/net/py-tweepy/files/patch-setup.py
@@ -0,0 +1,22 @@
+--- setup.py.orig 2015-02-21 19:28:08 UTC
++++ setup.py
+@@ -15,7 +15,10 @@ else:
+ raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
+
+ install_reqs = parse_requirements('requirements.txt', session=uuid.uuid1())
++test_reqs = parse_requirements('test_requirements.txt', session=uuid.uuid1())
++
+ reqs = [str(req.req) for req in install_reqs]
++treqs = [str(req.req) for req in test_reqs]
+
+ setup(name="tweepy",
+ version=version,
+@@ -26,6 +29,8 @@ setup(name="tweepy",
+ url="http://github.com/tweepy/tweepy",
+ packages=find_packages(exclude=['tests']),
+ install_requires=reqs,
++ tests_require=treqs,
++ test_suite='nose.collector',
+ keywords="twitter library",
+ classifiers=[
+ 'Development Status :: 4 - Beta',
diff --git a/net/py-tweepy/files/patch-test__requirements.txt b/net/py-tweepy/files/patch-test__requirements.txt
new file mode 100644
index 000000000000..ffe0ff724815
--- /dev/null
+++ b/net/py-tweepy/files/patch-test__requirements.txt
@@ -0,0 +1,7 @@
+--- test_requirements.txt.orig 2015-07-05 15:09:04 UTC
++++ test_requirements.txt
+@@ -1,4 +1,3 @@
+-tox>=1.7.2
+ vcrpy==1.1.2
+ mock==1.0.1
+ unittest2 # Comment this line out if using Python 3.