aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-03-06 04:01:41 +0800
committertobik <tobik@FreeBSD.org>2017-03-06 04:01:41 +0800
commit4ee5020726d76c09ebad9cf0d3479e0ec606f9a4 (patch)
treef5662e913eb4adc4755c989755d3db8bb551bd79 /net
parentad695e884bc81eef6e9be5a1956b3e0187a49f77 (diff)
downloadfreebsd-ports-gnome-4ee5020726d76c09ebad9cf0d3479e0ec606f9a4.tar.gz
freebsd-ports-gnome-4ee5020726d76c09ebad9cf0d3479e0ec606f9a4.tar.zst
freebsd-ports-gnome-4ee5020726d76c09ebad9cf0d3479e0ec606f9a4.zip
New port: net/nethogs
NetHogs is a small 'net top' tool. Instead of breaking the traffic down per protocol or per subnet, like most tools do, it groups bandwidth by process. WWW: https://github.com/raboof/nethogs PR: 213109 Submitted by: anastasios@mageirias.com Approved by: lme (mentor) Differential Revision: https://reviews.freebsd.org/D9892
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/nethogs/Makefile28
-rw-r--r--net/nethogs/distinfo3
-rw-r--r--net/nethogs/pkg-descr5
-rw-r--r--net/nethogs/pkg-message10
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1488583cf5e4..a64575eeb15a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -448,6 +448,7 @@
SUBDIR += netcat
SUBDIR += netdude
SUBDIR += netembryo
+ SUBDIR += nethogs
SUBDIR += netmap
SUBDIR += netpipes
SUBDIR += netscript
diff --git a/net/nethogs/Makefile b/net/nethogs/Makefile
new file mode 100644
index 000000000000..ac97421a3f8e
--- /dev/null
+++ b/net/nethogs/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= nethogs
+PORTVERSION= 0.8.5
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= anastasios@mageirias.com
+COMMENT= Small net top tool
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= raboof
+
+USES= gmake shebangfix
+
+SHEBANG_FILES= determineVersion.sh
+bash_CMD= ${SH}
+
+PLIST_FILES= man/man8/nethogs.8.gz \
+ sbin/nethogs
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/nethogs
+
+.include <bsd.port.mk>
diff --git a/net/nethogs/distinfo b/net/nethogs/distinfo
new file mode 100644
index 000000000000..b3e21916547e
--- /dev/null
+++ b/net/nethogs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488685002
+SHA256 (raboof-nethogs-v0.8.5_GH0.tar.gz) = 6a9392726feca43228b3f0265379154946ef0544c2ca2cac59ec35a24f469dcc
+SIZE (raboof-nethogs-v0.8.5_GH0.tar.gz) = 112385
diff --git a/net/nethogs/pkg-descr b/net/nethogs/pkg-descr
new file mode 100644
index 000000000000..334112f41c29
--- /dev/null
+++ b/net/nethogs/pkg-descr
@@ -0,0 +1,5 @@
+NetHogs is a small 'net top' tool. Instead of breaking the traffic down
+per protocol or per subnet, like most tools do, it groups bandwidth by
+process.
+
+WWW: https://github.com/raboof/nethogs
diff --git a/net/nethogs/pkg-message b/net/nethogs/pkg-message
new file mode 100644
index 000000000000..d20e30123493
--- /dev/null
+++ b/net/nethogs/pkg-message
@@ -0,0 +1,10 @@
+In order for nethogs to work properly add the following entry to
+/etc/fstab:
+
+proc /proc procfs rw,noauto 0 0
+
+noauto prevents /proc from being automatically mounted at boot.
+
+To mount the file system without rebooting:
+
+# mount /proc