aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-05-04 04:39:58 +0800
committerantoine <antoine@FreeBSD.org>2013-05-04 04:39:58 +0800
commit51f20e5738965b52aee7cb3e0b35435ea939fab9 (patch)
tree7560957d638727c2370fdde080c3c20bb174d25a /net
parentc1c7490db8f4a79c86ea03332053f0635c6dda23 (diff)
downloadfreebsd-ports-gnome-51f20e5738965b52aee7cb3e0b35435ea939fab9.tar.gz
freebsd-ports-gnome-51f20e5738965b52aee7cb3e0b35435ea939fab9.tar.zst
freebsd-ports-gnome-51f20e5738965b52aee7cb3e0b35435ea939fab9.zip
New port: tcpsplit
Breaks a libpcap trace along TCP connection boundaries WWW: http://www.icir.org/mallman/software/tcpsplit/ PR: ports/177441 Submitted by: Lars Eggert Approved by: eadler (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tcpsplit/Makefile29
-rw-r--r--net/tcpsplit/distinfo2
-rw-r--r--net/tcpsplit/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ad4c37358379..f8fb23192ad8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1149,6 +1149,7 @@
SUBDIR += tcpsg
SUBDIR += tcpshow
SUBDIR += tcpslice
+ SUBDIR += tcpsplit
SUBDIR += tcpstat
SUBDIR += tcptrace
SUBDIR += tcptraceroute
diff --git a/net/tcpsplit/Makefile b/net/tcpsplit/Makefile
new file mode 100644
index 000000000000..f6df060f3a35
--- /dev/null
+++ b/net/tcpsplit/Makefile
@@ -0,0 +1,29 @@
+# Created by: Lars Eggert <lars@eggert.org>
+# $FreeBSD$
+
+PORTNAME= tcpsplit
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://www.icir.org/mallman/software/tcpsplit/
+
+MAINTAINER= lars@eggert.org
+COMMENT= Breaks a libpcap trace along TCP connection boundaries
+
+LICENSE= MIT
+
+PLIST_FILES= bin/tcpsplit
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(CC|CFLAGS|INC|LD)/d' ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpsplit ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcpsplit/distinfo b/net/tcpsplit/distinfo
new file mode 100644
index 000000000000..e8d9d961e919
--- /dev/null
+++ b/net/tcpsplit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tcpsplit-0.2.tar.gz) = 885a6609d04eb35f31f1c6f06a0b9afd88776d85dec0caa33a86cef3f3c09d1d
+SIZE (tcpsplit-0.2.tar.gz) = 6685
diff --git a/net/tcpsplit/pkg-descr b/net/tcpsplit/pkg-descr
new file mode 100644
index 000000000000..017bcdf1c18a
--- /dev/null
+++ b/net/tcpsplit/pkg-descr
@@ -0,0 +1,7 @@
+The tcpsplit utility breaks a single libpcap packet trace into some number
+of sub-traces, breaking the trace along TCP connection boundaries so that
+a TCP connection doesn't end up split across two sub-traces. This is useful
+for making large trace files tractable for in-depth analysis and for
+subsetting a trace for developing analysis on only part of a trace.
+
+WWW: http://www.icir.org/mallman/software/tcpsplit/