aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-09-25 14:34:10 +0800
committerlioux <lioux@FreeBSD.org>2005-09-25 14:34:10 +0800
commit54bb3f70ec752d6fab2a4347728ec8622393b1de (patch)
tree47143714d969556e8e19006096a48b876ab2253a /net
parent717a3c1be3108a95ba61b3e60b5e23a9819342d5 (diff)
downloadfreebsd-ports-gnome-54bb3f70ec752d6fab2a4347728ec8622393b1de.tar.gz
freebsd-ports-gnome-54bb3f70ec752d6fab2a4347728ec8622393b1de.tar.zst
freebsd-ports-gnome-54bb3f70ec752d6fab2a4347728ec8622393b1de.zip
Update to 1.2
Diffstat (limited to 'net')
-rw-r--r--net/minder/Makefile10
-rw-r--r--net/minder/distinfo4
-rw-r--r--net/minder/files/patch-Makefile14
-rw-r--r--net/minder/files/patch-MyTcpSocket.cpp11
4 files changed, 11 insertions, 28 deletions
diff --git a/net/minder/Makefile b/net/minder/Makefile
index 24517c0398c8..cc4f4bd89026 100644
--- a/net/minder/Makefile
+++ b/net/minder/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= minder
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= net
MASTER_SITES= http://www.alhem.net/project/minder/
@@ -25,11 +24,8 @@ USE_REINPLACE= yes
# ssl support
CFLAGS+= ${PTHREAD_CFLAGS} -DHAVE_OPENSSL
-PLIST_DIRS= \
- %%EXAMPLESDIR%%
PLIST_FILES= \
- bin/${PORTNAME} \
- %%EXAMPLESDIR%%/minder.cfg
+ bin/${PORTNAME}
post-patch:
# CXX safeness
@@ -47,8 +43,6 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/minder.cfg ${EXAMPLESDIR}
.include <bsd.port.pre.mk>
diff --git a/net/minder/distinfo b/net/minder/distinfo
index 370d5e7df823..5d3af71f0d50 100644
--- a/net/minder/distinfo
+++ b/net/minder/distinfo
@@ -1,2 +1,2 @@
-MD5 (minder-1.1.tar.gz) = acc19c86e65fb48b98cb8863b53a0297
-SIZE (minder-1.1.tar.gz) = 5772
+MD5 (minder-1.2.tar.gz) = d82b1a0646889e93003f1964bd5a38e3
+SIZE (minder-1.2.tar.gz) = 12228
diff --git a/net/minder/files/patch-Makefile b/net/minder/files/patch-Makefile
index 3092f680b7d7..4139caf9d998 100644
--- a/net/minder/files/patch-Makefile
+++ b/net/minder/files/patch-Makefile
@@ -1,15 +1,15 @@
---- Makefile.orig Sat Jan 15 23:23:22 2005
-+++ Makefile Sat Jan 15 23:27:38 2005
-@@ -4,7 +4,7 @@
- CFLAGS = -Wall -g -O2 $(INCLUDE) -MD
+--- Makefile.orig Sun Sep 25 02:56:46 2005
++++ Makefile Sun Sep 25 02:57:16 2005
+@@ -6,7 +6,7 @@
CPPFLAGS = $(CFLAGS)
- LIBS = -L/usr/devel/lib -lSockets \
+
+ LIBS = -L/usr/local/lib -lSockets \
- -lssl -lcrypto -luuid -lpthread
-+ -lSockets -lssl -lcrypto
++ -lssl -lcrypto -lSockets
PROGS = minder
all: $(PROGS)
-@@ -19,7 +19,7 @@
+@@ -21,7 +21,7 @@
rm -f *.o *~ *.d slask $(PROGS)
install: all
diff --git a/net/minder/files/patch-MyTcpSocket.cpp b/net/minder/files/patch-MyTcpSocket.cpp
deleted file mode 100644
index 3acce5a73dcd..000000000000
--- a/net/minder/files/patch-MyTcpSocket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- MyTcpSocket.cpp.orig Sun Jan 16 01:07:56 2005
-+++ MyTcpSocket.cpp Sun Jan 16 01:09:39 2005
-@@ -85,7 +85,7 @@
-
- // we ignore whatever ip the minion sends us
- // we only use the ip from the connection endpoint
-- ipaddr_t ip2 = GetRemoteIP();
-+ ipaddr_t ip2 = GetRemoteIP4();
- DEB( printf("Incoming: id '%s' %s:%d cmd '%s'\n",id.c_str(),GetRemoteAddress().c_str(),port,cmd.c_str());)
- if (cmd == "Goodbye")
- {