aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-01-09 22:11:16 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-01-09 22:11:16 +0800
commit6396aa55ca13160049a88ecfaa7b30a7b4d46f1f (patch)
treedc9dccb3944f9616edcdcf2c0dd987ec7ae3dabd /net
parent668db706a785a75283bd078d47896924d08d1b36 (diff)
downloadfreebsd-ports-gnome-6396aa55ca13160049a88ecfaa7b30a7b4d46f1f.tar.gz
freebsd-ports-gnome-6396aa55ca13160049a88ecfaa7b30a7b4d46f1f.tar.zst
freebsd-ports-gnome-6396aa55ca13160049a88ecfaa7b30a7b4d46f1f.zip
Add tcpick. A text-based TCP stream sniffer.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tcpick/Makefile29
-rw-r--r--net/tcpick/distinfo2
-rw-r--r--net/tcpick/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aec24ab790e9..57e87d068db7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -714,6 +714,7 @@
SUBDIR += tcpdstat
SUBDIR += tcpdump
SUBDIR += tcpflow
+ SUBDIR += tcpick
SUBDIR += tcpillust
SUBDIR += tcping
SUBDIR += tcpmssd
diff --git a/net/tcpick/Makefile b/net/tcpick/Makefile
new file mode 100644
index 000000000000..a8dde441cb5d
--- /dev/null
+++ b/net/tcpick/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tcpick
+# Date created: 09 January 2005
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpick
+PORTVERSION= 0.2.0.r6
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
+
+MAINTAINER= nobutaka@FreeBSD.org
+COMMENT= A text-based TCP stream sniffer
+
+GNU_CONFIGURE= yes
+
+MANLANG= "" it
+MAN8= tcpick.8
+
+PLIST_FILES= bin/tcpick
+
+post-install:
+ ${MKDIR} ${PREFIX}/man/it/man8
+ ${MV} ${PREFIX}/man/man8/tcpick_italian.8 ${PREFIX}/man/it/man8/tcpick.8
+
+.include <bsd.port.mk>
diff --git a/net/tcpick/distinfo b/net/tcpick/distinfo
new file mode 100644
index 000000000000..0686f398f9fc
--- /dev/null
+++ b/net/tcpick/distinfo
@@ -0,0 +1,2 @@
+MD5 (tcpick-0.2.0-rc6.tar.gz) = 1400aca4f6076de2427a6c35312b99b6
+SIZE (tcpick-0.2.0-rc6.tar.gz) = 169345
diff --git a/net/tcpick/pkg-descr b/net/tcpick/pkg-descr
new file mode 100644
index 000000000000..f27f74606ede
--- /dev/null
+++ b/net/tcpick/pkg-descr
@@ -0,0 +1,6 @@
+tcpick is a textmode sniffer libpcap-based that can track, reassemble and
+reorder tcp streams. Tcpick is able to save the captured flows in different
+files or displays them in the terminal, and so it is useful to sniff files
+that are transmitted via ftp or http.
+
+WWW: http://tcpick.sourceforge.net/