aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-02-02 01:45:31 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-02-02 01:45:31 +0800
commit64e8973183bc672d6193c31f6f7562019c375ddf (patch)
tree548aa5eddc74828390c83d8e2153fb4f52d5b515 /net
parent37ee42b7bef96dbd3d9b527cedc6b7f35308e57b (diff)
downloadfreebsd-ports-gnome-64e8973183bc672d6193c31f6f7562019c375ddf.tar.gz
freebsd-ports-gnome-64e8973183bc672d6193c31f6f7562019c375ddf.tar.zst
freebsd-ports-gnome-64e8973183bc672d6193c31f6f7562019c375ddf.zip
- Fix the return value of the rc.d script
PR: ports/143086 Submitted by: Emil Smolenski <am@raisa.eu.org> Approved by: Boris Kovalenko <boris@tagnet.ru> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/quagga.sh.in5
2 files changed, 5 insertions, 2 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index fa3a7cfe8551..8ea7f3b02ce2 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/quagga.sh.in b/net/quagga/files/quagga.sh.in
index 747cabcdbb42..ceb3ceeac63b 100644
--- a/net/quagga/files/quagga.sh.in
+++ b/net/quagga/files/quagga.sh.in
@@ -54,6 +54,8 @@ stop_postcmd()
do_cmd()
{
+ local ret
+ ret=0
for daemon in ${quagga_daemons}; do
command=%%PREFIX%%/sbin/${daemon}
required_files=%%SYSCONF_DIR%%/${daemon}.conf
@@ -66,9 +68,10 @@ do_cmd()
fi
eval flags=\$\{${daemon}_flags:-\"${quagga_flags}\"\}
name=${daemon}
- run_rc_command "$1"
_rc_restart_done=false
+ run_rc_command "$1" || ret=1
done
+ return ${ret}
}
# set defaults