aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
committertz <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
commit6848976140b7b23bae6554e8e69c63d54ff6ef33 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /net
parent8890d0606a504e6c6016614e5077c8d36dc54d8c (diff)
downloadfreebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.tar.gz
freebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.tar.zst
freebsd-ports-gnome-6848976140b7b23bae6554e8e69c63d54ff6ef33.zip
Add PHP 7.1
Thanks to: mat, pi, ale, martin@waschbuesch.de and franco@opnsense.org
Diffstat (limited to 'net')
-rw-r--r--net/php71-ldap/Makefile9
-rw-r--r--net/php71-soap/Makefile9
-rw-r--r--net/php71-sockets/Makefile9
-rw-r--r--net/php71-xmlrpc/Makefile9
-rw-r--r--net/php71-xmlrpc/files/patch-config.m423
5 files changed, 59 insertions, 0 deletions
diff --git a/net/php71-ldap/Makefile b/net/php71-ldap/Makefile
new file mode 100644
index 000000000000..1edcb04d0de5
--- /dev/null
+++ b/net/php71-ldap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -ldap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-soap/Makefile b/net/php71-soap/Makefile
new file mode 100644
index 000000000000..8f0142f7d728
--- /dev/null
+++ b/net/php71-soap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -soap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-sockets/Makefile b/net/php71-sockets/Makefile
new file mode 100644
index 000000000000..9284f2d9c7ae
--- /dev/null
+++ b/net/php71-sockets/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -sockets
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-xmlrpc/Makefile b/net/php71-xmlrpc/Makefile
new file mode 100644
index 000000000000..961bb83a703c
--- /dev/null
+++ b/net/php71-xmlrpc/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xmlrpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-xmlrpc/files/patch-config.m4 b/net/php71-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php71-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then