aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-21 18:23:19 +0800
commit6a2c8adf9eab2d622b7805a3cb7990c8c9454251 (patch)
treee2529c5247b78282bbb3a3cc3aaaad34e48baf86 /net
parentc9983b6ed69b31349559fe4008e6b2e88fe191c7 (diff)
downloadfreebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.gz
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.tar.zst
freebsd-ports-gnome-6a2c8adf9eab2d622b7805a3cb7990c8c9454251.zip
Try to bring some consistency to ports that have x86-specific pieces.
- in general, if we think that the code is not architecture-specific, and instead just enables x86 assembler by default, those should use BROKEN rather than IGNORE. This will allow them to be attempted with TRYBROKEN. - spell i386 as x86. - spell asm as assembler. - pet portlint. These changes should have no effect on tier-1 builds. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net')
-rw-r--r--net/tcpkali/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/tcpkali/Makefile b/net/tcpkali/Makefile
index b5cf83bf6f6d..28845f9ca9d0 100644
--- a/net/tcpkali/Makefile
+++ b/net/tcpkali/Makefile
@@ -11,8 +11,13 @@ COMMENT= High performance load generator for TCP and WebSocket servers
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= uses x86 assembler
+BROKEN_aarch64= invokes x86 assembler
+BROKEN_armv6= invokes x86 assembler
+BROKEN_armv7= invokes x86 assembler
+BROKEN_mips= invokes x86 assembler
+BROKEN_mips64= invokes x86 assembler
+BROKEN_sparc64= invokes x86 assembler
+BROKEN_powerpc64= invokes x86 assembler
GNU_CONFIGURE= yes
USES= autoreconf libtool gmake ncurses