aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2003-09-29 01:19:14 +0800
committersumikawa <sumikawa@FreeBSD.org>2003-09-29 01:19:14 +0800
commit6a3e6a9dac361ec86e6209762cc30bc189bbf9ce (patch)
tree482e78614db658f41d020e9d9302667d5c9ab7bf /net
parent60954222ec8b000b02401b561229fdac8b84e806 (diff)
downloadfreebsd-ports-gnome-6a3e6a9dac361ec86e6209762cc30bc189bbf9ce.tar.gz
freebsd-ports-gnome-6a3e6a9dac361ec86e6209762cc30bc189bbf9ce.tar.zst
freebsd-ports-gnome-6a3e6a9dac361ec86e6209762cc30bc189bbf9ce.zip
Zebra-pj was renamed to quagga.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/zebra-pj/Makefile56
-rw-r--r--net/zebra-pj/distinfo1
-rw-r--r--net/zebra-pj/files/zebractl.sh57
-rw-r--r--net/zebra-pj/pkg-descr6
-rw-r--r--net/zebra-pj/pkg-plist29
-rw-r--r--net/zebra-pj/scripts/configure61
7 files changed, 0 insertions, 211 deletions
diff --git a/net/Makefile b/net/Makefile
index 77473b0fa753..d4561fb7de4d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -721,7 +721,6 @@
SUBDIR += zabbix-agent
SUBDIR += zebra
SUBDIR += zebra-devel
- SUBDIR += zebra-pj
SUBDIR += zebra-server
SUBDIR += ztelnet
diff --git a/net/zebra-pj/Makefile b/net/zebra-pj/Makefile
deleted file mode 100644
index d1e4730f7fdc..000000000000
--- a/net/zebra-pj/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# New ports collection makefile for: zebra-pj
-# Date created: Tue May 13 12:12:11 CEST 2003
-# Whom: sumikawa
-#
-# $FreeBSD$
-#
-
-PORTNAME= zebra-pj
-PORTVERSION= 20030810
-PORTREVISION= 1
-CATEGORIES= net ipv6
-MASTER_SITES= http://www.quagga.net/snapshots/cvs/
-DISTNAME= ${PORTNAME}-${ZEBRAVER}-${PORTVERSION}
-
-MAINTAINER= sumikawa@FreeBSD.org
-COMMENT= Patched Zebra
-
-USE_SUBMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/zebra --enable-vtysh
-SCRIPTS_ENV= WRKDIRPREFIX=${WRKDIRPREFIX}
-WRKSRC= ${WRKDIR}/zebra-${ZEBRAVER}
-
-ZEBRAVER= 0.94
-
-MAN1= vtysh.1
-MAN8= bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8
-INFO= zebra
-
-.if !defined(BATCH)
-pre-configure:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-post-clean:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
-.endif
-.endif
-
-post-install:
- @( cd ${WRKSRC}/doc; rm -f zebra*info*; ${MAKE} zebra.info install )
- @${ECHO} "===> installing zebra startup file..."
- @${SED} -e "s=!!PREFIX!!=${PREFIX}=" \
- < ${FILESDIR}/zebractl.sh \
- > ${PREFIX}/sbin/zebractl
- @${CHMOD} 555 ${PREFIX}/sbin/zebractl
- @${ECHO} "Make these entries in /etc/rc.conf to start zebra:"
- @${ECHO} "defaultrouter=\"NO\""
- @${ECHO} "router_enable=\"YES\""
- @${ECHO} "router=\"${PREFIX}/sbin/zebractl\""
- @${ECHO} "router_flags=\"start\""
- @${ECHO} "done."
-
-.include <bsd.port.mk>
diff --git a/net/zebra-pj/distinfo b/net/zebra-pj/distinfo
deleted file mode 100644
index 9a0b17735690..000000000000
--- a/net/zebra-pj/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (zebra-pj-0.94-20030810.tar.gz) = 19f7fbb2274152207a62106327970a82
diff --git a/net/zebra-pj/files/zebractl.sh b/net/zebra-pj/files/zebractl.sh
deleted file mode 100644
index 741df5ae75b7..000000000000
--- a/net/zebra-pj/files/zebractl.sh
+++ /dev/null
@@ -1,57 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD: /tmp/pcvs/ports/net/zebra-pj/files/Attic/zebractl.sh,v 1.9 2003-06-13 23:05:15 sumikawa Exp $
-#
-# zebra start/stop script by "Andreas Klemm <andreas@FreeBSD.ORG>"
-#
-
-usage()
-{
- echo "$0: usage: $0 [ start | stop | restart ]"
- exit 1
-}
-
-if [ $# -lt 1 ]; then
- echo "$0: error: one argument needed"; usage
-elif [ $# -gt 1 ]; then
- echo "$0: error: only one argument needed"; usage
-fi
-
-case $1 in
- start)
- if [ ! -f !!PREFIX!!/etc/zebra/zebra.conf ]; then
- echo "error: zebra.conf config file is mandatory"
- exit 1
- fi
- [ -f !!PREFIX!!/etc/zebra/zebra.conf ] \
- && !!PREFIX!!/sbin/zebra -d && echo -n ' zebra'
- [ -f !!PREFIX!!/etc/zebra/ripd.conf ] \
- && !!PREFIX!!/sbin/ripd -d && echo -n ' ripd'
- [ -f !!PREFIX!!/etc/zebra/ripngd.conf ] \
- && !!PREFIX!!/sbin/ripngd -d && echo -n ' ripngd'
- [ -f !!PREFIX!!/etc/zebra/ospfd.conf ] \
- && !!PREFIX!!/sbin/ospfd -d && echo -n ' ospfd'
- [ -f !!PREFIX!!/etc/zebra/ospf6d.conf ] \
- && !!PREFIX!!/sbin/ospf6d -d && echo -n ' ospf6d'
- [ -f !!PREFIX!!/etc/zebra/bgpd.conf ] \
- && !!PREFIX!!/sbin/bgpd -d && echo -n ' bgpd'
- ;;
-
- stop)
- [ -f !!PREFIX!!/etc/zebra/ripd.conf ] && killall ripd
- [ -f !!PREFIX!!/etc/zebra/ripngd.conf ] && killall ripngd
- [ -f !!PREFIX!!/etc/zebra/ospfd.conf ] && killall ospfd
- [ -f !!PREFIX!!/etc/zebra/ospf6d.conf ] && killall ospf6d
- [ -f !!PREFIX!!/etc/zebra/bgpd.conf ] && killall bgpd
- [ -f !!PREFIX!!/etc/zebra/zebra.conf ] && killall zebra
- ;;
- restart)
- $0 stop
- $0 start
- ;;
-
- *) echo "$0: error: unknown option $1"
- usage
- ;;
-esac
-exit 0
diff --git a/net/zebra-pj/pkg-descr b/net/zebra-pj/pkg-descr
deleted file mode 100644
index 4ed18e58fcf0..000000000000
--- a/net/zebra-pj/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-GNU Zebra is a free software (distributed under GNU Generic Public
-License) which manages TCP/IP based routing protocols.
-
-This port is zebra with several patches
-
-WWW: http://www.quagga.net/
diff --git a/net/zebra-pj/pkg-plist b/net/zebra-pj/pkg-plist
deleted file mode 100644
index c643e5913987..000000000000
--- a/net/zebra-pj/pkg-plist
+++ /dev/null
@@ -1,29 +0,0 @@
-bin/vtysh
-etc/zebra/bgpd.conf.sample
-etc/zebra/bgpd.conf.sample2
-etc/zebra/ospf6d.conf.sample
-etc/zebra/ospfd.conf.sample
-etc/zebra/ripd.conf.sample
-etc/zebra/ripngd.conf.sample
-etc/zebra/vtysh.conf.sample
-etc/zebra/zebra.conf.sample
-include/ospfd/ospf_api.h
-include/ospfd/ospf_asbr.h
-include/ospfd/ospf_dump.h
-include/ospfd/ospf_ism.h
-include/ospfd/ospf_lsa.h
-include/ospfd/ospf_lsdb.h
-include/ospfd/ospf_nsm.h
-include/ospfd/ospf_opaque.h
-include/ospfd/ospfd.h
-lib/libospf.a
-lib/libzebra.a
-sbin/bgpd
-sbin/ospf6d
-sbin/ospfd
-sbin/ripd
-sbin/ripngd
-sbin/zebra
-sbin/zebractl
-@dirrm etc/zebra
-@dirrm include/ospfd
diff --git a/net/zebra-pj/scripts/configure b/net/zebra-pj/scripts/configure
deleted file mode 100644
index f2a02dc53a82..000000000000
--- a/net/zebra-pj/scripts/configure
+++ /dev/null
@@ -1,61 +0,0 @@
-#! /bin/sh
-
-# $FreeBSD$
-
-# configure - zebra compile time option configurator
-# by Andreas Klemm <andreas@FreeBSD.org>
-
-if [ "$BATCH" != "yes" -a "$BATCH" != "YES" ]; then
-
-#
-# configure - zebra compile time options
-#
-
-/usr/bin/dialog --title "Zebra Compile Time Options" --clear \
- --checklist "\n\
-Select compile time options for zebra port:" -1 -1 8 \
-LIBPAM "enable PAM authentication for vtysh" OFF \
-OSPF_NSSA "turn on undergoing NSSA feature" OFF \
-SNMP "enable SNMP support" OFF \
-TCP-ZEBRA "enable TCP/IP socket connection" OFF \
-2> /tmp/zebra-checklist.$$
-
-retval=$?
-
-if [ -s /tmp/zebra-checklist.$$ ]; then
- set `cat /tmp/zebra-checklist.$$`
-fi
-rm -f /tmp/zebra-checklist.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
-
-/bin/mkdir -p ${WRKDIRPREFIX}${CURDIR}
-exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
-
-while [ "$1" ]; do
- case $1 in
- \"LIBPAM\")
- echo CONFIGURE_ARGS+=--with-libpam
- ;;
- \"OSPF_NSSA\")
- echo CONFIGURE_ARGS+=--enable-nssa
- ;;
- \"SNMP\")
- echo CONFIGURE_ARGS+=--enable-snmp
- ;;
- \"TCP-ZEBRA\")
- echo CONFIGURE_ARGS+=--enable-tcp-zebra
- ;;
- esac
- shift
-done
-
-fi # if $BATCH