aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-11-01 23:18:55 +0800
committerantoine <antoine@FreeBSD.org>2015-11-01 23:18:55 +0800
commit6d9e16e652b1d871c6406b35a0c4db9eb56730c7 (patch)
treeb50c81f07721bf63b8481aa22e76f4c88f041065 /net
parent0a8408fdd8bbf6d4d7f2e4e03af9a2862fb5761d (diff)
downloadfreebsd-ports-gnome-6d9e16e652b1d871c6406b35a0c4db9eb56730c7.tar.gz
freebsd-ports-gnome-6d9e16e652b1d871c6406b35a0c4db9eb56730c7.tar.zst
freebsd-ports-gnome-6d9e16e652b1d871c6406b35a0c4db9eb56730c7.zip
Ignore on the package builders when default version of python is not 3.4+
Reported by: pkg-fallout
Diffstat (limited to 'net')
-rw-r--r--net/tiny-network-utilities/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/tiny-network-utilities/Makefile b/net/tiny-network-utilities/Makefile
index 711cbd098bc7..f3e1c236ec73 100644
--- a/net/tiny-network-utilities/Makefile
+++ b/net/tiny-network-utilities/Makefile
@@ -25,6 +25,12 @@ FILES_EXEC= tiny-dhcp-server tiny-udp-proxy tiny-udp-anti-nat
FILES_LIB= net_checksums tiny_utils
PLIST_FILES= $(FILES_EXEC:%=bin/%) $(FILES_LIB:%=${PYTHON_SITELIBDIR}/%.py)
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
do-install:
.for file_exec in ${FILES_EXEC}
${INSTALL_SCRIPT} ${WRKSRC}/${file_exec}.py \
@@ -36,4 +42,4 @@ do-install:
${STAGEDIR}${PYTHON_SITELIBDIR}/${file_lib}.py
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>