aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-12-26 18:48:12 +0800
committerlioux <lioux@FreeBSD.org>2004-12-26 18:48:12 +0800
commit6f4fe714ce55d287601b89a1ca35ef1645670466 (patch)
tree1e4199a870bfe5e45754460e3d5f053286ba6daf /net
parent532191ea14e968846b965a51b39d7069c5a2762e (diff)
downloadfreebsd-ports-gnome-6f4fe714ce55d287601b89a1ca35ef1645670466.tar.gz
freebsd-ports-gnome-6f4fe714ce55d287601b89a1ca35ef1645670466.tar.zst
freebsd-ports-gnome-6f4fe714ce55d287601b89a1ca35ef1645670466.zip
o Add dependency on dns/py-dnspython which enable a notification
when there is a newer version of BitTorrent available o Style fix: Remove a extraneous trailing space in Makefile o Change default from disabled to enabled for BitTorrent option --enable_bad_libc_workaround: 'enable workaround for a bug in BSD libc that makes file reads very slow.' This has been verified to be true; the behavior, not the reason o Bump PORTREVISION
Diffstat (limited to 'net')
-rw-r--r--net/py-bittorrent-devel/Makefile5
-rw-r--r--net/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py11
2 files changed, 15 insertions, 1 deletions
diff --git a/net/py-bittorrent-devel/Makefile b/net/py-bittorrent-devel/Makefile
index 8c8466cdabe3..8b3a40481538 100644
--- a/net/py-bittorrent-devel/Makefile
+++ b/net/py-bittorrent-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 3.9.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= http://www.bittorrent.com/
@@ -19,6 +20,8 @@ PKGNAMESUFFIX?= -devel
MAINTAINER= lioux@FreeBSD.org
COMMENT?= A peer-to-peer tool for distributing files written in Python
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
@@ -58,7 +61,7 @@ post-patch:
-e 's|/usr/bin/env python|${LOCALBASE}/bin/python|'
post-install:
-.ifndef(NOPORTDOCS)
+.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/net/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py b/net/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py
new file mode 100644
index 000000000000..d0fa6f8e8052
--- /dev/null
+++ b/net/py-bittorrent-devel/files/patch-BitTorrent::defaultargs.py
@@ -0,0 +1,11 @@
+--- BitTorrent/defaultargs.py.orig Sun Dec 26 08:41:09 2004
++++ BitTorrent/defaultargs.py Sun Dec 26 08:41:16 2004
+@@ -83,7 +83,7 @@
+ 'if nonzero, set the TOS option for peer connections to this value'),
+ ('filesystem_encoding', '',
+ "character encoding used on the local filesystem. If left empty, autodetected. Autodetection doesn't work under python versions older than 2.3"),
+- ('enable_bad_libc_workaround', 0,
++ ('enable_bad_libc_workaround', 1,
+ 'enable workaround for a bug in BSD libc that makes file reads very slow.'),
+ ]
+