aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-07-26 06:57:40 +0800
committerjgh <jgh@FreeBSD.org>2013-07-26 06:57:40 +0800
commit7336a06a910f6b2573ee117ebaf55a7d4473a04f (patch)
tree1b16b2ade03f3cbe0733e2ae01cb995a21606760 /net
parentf59f24b40db709de1ea6427e69c2958177eba2b3 (diff)
downloadfreebsd-ports-gnome-7336a06a910f6b2573ee117ebaf55a7d4473a04f.tar.gz
freebsd-ports-gnome-7336a06a910f6b2573ee117ebaf55a7d4473a04f.tar.zst
freebsd-ports-gnome-7336a06a910f6b2573ee117ebaf55a7d4473a04f.zip
- unbreak package creation
- while here standardize on empty PORT_OPTIONS and convert USE_GMAKE to USES PR: 180850 Reported by: Alfred Bartsch <bartsch@dssgmbh.de>
Diffstat (limited to 'net')
-rw-r--r--net/ssvnc/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
index d04dfc303a48..14c32ee2ea07 100644
--- a/net/ssvnc/Makefile
+++ b/net/ssvnc/Makefile
@@ -20,13 +20,13 @@ RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel \
OPTIONS_DEFINE= ULTRAFTP DOCS
ULTRAFTP_DESC= UltraVNC File Transfer support (Java required)
-USES= imake:env
+USES= imake:env gmake
USE_XORG= xi xmu xt xaw ice xpm xext sm
USE_TK_WRAPPER= yes
USE_PERL5_RUN= yes
-USE_GMAKE= yes
-MAN1= ssvnc-gui.1 ssvncviewer.1
+MAN1= ssvnc.1 ssvncviewer.1
+NO_INSTALL_MANPAGES= yes
.include <bsd.port.options.mk>
@@ -37,7 +37,7 @@ PLIST_SUB+= ULTRAFTP=""
PLIST_SUB+= ULTRAFTP="@comment "
.endif
-.if empty(PORT_OPTIONS:MDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
MAKE_ARGS+= DOCS=""
.endif
@@ -46,7 +46,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|[[:<:]]ssvnc[[:>:]]|ssvnc-gui|' ${WRKSRC}/man/man1/ssvnc.1
@${REINPLACE_CMD} -e 's|/usr/local/bin|${LOCALBASE}/bin|' \
-e 's|^CC =|CC ?=|' ${WRKSRC}/vncstorepw/Makefile
-.if empty(PORT_OPTIONS:MULTRAFTP)
+.if ! ${PORT_OPTIONS:MULTRAFTP}
@${REINPLACE_CMD} -e "s|sh -c 'type javac'|:|" \
-e "s|sh -c 'type jar'|:|" \
-e 's|cd $$(JSRC);|: |' \
@@ -59,5 +59,11 @@ do-configure:
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${MAN1PREFIX}/man/man1
+.for man in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${MAN1PREFIX}/man/man1
+.endfor
+.endif
.include <bsd.port.mk>