aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-11-09 07:59:58 +0800
committeredwin <edwin@FreeBSD.org>2003-11-09 07:59:58 +0800
commit792dd870f688807c5af41599f5e1487f055c9d2a (patch)
treef7ff1988afb647c6981a5dc0d7ca35342fa04da8 /net
parente83e0eb4d173599335c95ddd9b0e357ba43b38f2 (diff)
downloadfreebsd-ports-gnome-792dd870f688807c5af41599f5e1487f055c9d2a.tar.gz
freebsd-ports-gnome-792dd870f688807c5af41599f5e1487f055c9d2a.tar.zst
freebsd-ports-gnome-792dd870f688807c5af41599f5e1487f055c9d2a.zip
Fix build on -current, thanks to a patch from walt <wa1ter@myrealbox.com>
Use PORTDOCS fully.
Diffstat (limited to 'net')
-rw-r--r--net/ngrep/Makefile5
-rw-r--r--net/ngrep/files/patch-configure37
-rw-r--r--net/ngrep/files/patch-ngrep.c10
-rw-r--r--net/ngrep/pkg-plist6
4 files changed, 46 insertions, 12 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index d7d3034f8f91..76dce8229a2c 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ngrep
PORTVERSION= 1.40.1
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +22,12 @@ CONFIGURE_ARGS= --with-pcre --with-restart
ALL_TARGET= ngrep
MAN8= ngrep.8
+PORTDOCS= BUGS CHANGES README README.pcre USAGE
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in BUGS CHANGES README README.pcre USAGE
+.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/net/ngrep/files/patch-configure b/net/ngrep/files/patch-configure
new file mode 100644
index 000000000000..7e1d18edb8ec
--- /dev/null
+++ b/net/ngrep/files/patch-configure
@@ -0,0 +1,37 @@
+--- configure.orig Sat Nov 8 15:49:02 2003
++++ configure Sat Nov 8 15:49:54 2003
+@@ -1978,9 +1978,9 @@
+
+ else
+ echo "$ac_t""no" 1>&6
+-echo $ac_n "checking for pcap_yyrestart in -lpcap""... $ac_c" 1>&6
+-echo "configure:1983: checking for pcap_yyrestart in -lpcap" >&5
+-ac_lib_var=`echo pcap'_'pcap_yyrestart | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for pcapyyrestart in -lpcap""... $ac_c" 1>&6
++echo "configure:1983: checking for pcapyyrestart in -lpcap" >&5
++ac_lib_var=`echo pcap'_'pcapyyrestart | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -1992,10 +1992,10 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char pcap_yyrestart();
++char pcapyyrestart();
+
+ int main() {
+-pcap_yyrestart()
++pcapyyrestart()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:2002: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -2014,7 +2014,7 @@
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ cat >> confdefs.h <<\EOF
+-#define PCAP_RESTART pcap_yyrestart
++#define PCAP_RESTART pcapyyrestart
+ EOF
+
+ else
diff --git a/net/ngrep/files/patch-ngrep.c b/net/ngrep/files/patch-ngrep.c
index 48dc19264ead..44c4a094ee01 100644
--- a/net/ngrep/files/patch-ngrep.c
+++ b/net/ngrep/files/patch-ngrep.c
@@ -1,19 +1,19 @@
---- ngrep.c.orig Wed Aug 8 23:36:09 2001
-+++ ngrep.c Wed Aug 8 23:36:31 2001
+--- ngrep.c.orig Mon Dec 31 14:11:00 2001
++++ ngrep.c Sat Nov 8 15:50:53 2003
@@ -62,6 +62,7 @@
#include "ngrep.h"
-+extern FILE *yyin;
++extern FILE *pcapyyin;
- static char rcsver[] = "$Revision: 1.18 $";
+ static char rcsver[] = "$Revision: 1.23 $";
@@ -232,7 +233,7 @@
filter = get_filter(&argv[optind-1]);
#ifdef NEED_RESTART
- PCAP_RESTART();
-+ PCAP_RESTART(yyin);
++ PCAP_RESTART(pcapyyin);
#endif
if (pcap_compile(pd, &pcapfilter, filter, 0, mask.s_addr)) {
pcap_perror(pd, "pcap compile");
diff --git a/net/ngrep/pkg-plist b/net/ngrep/pkg-plist
index c5ea818110e3..0d52ecd4cf73 100644
--- a/net/ngrep/pkg-plist
+++ b/net/ngrep/pkg-plist
@@ -1,8 +1,2 @@
@comment $FreeBSD$
bin/ngrep
-%%PORTDOCS%%share/doc/ngrep/BUGS
-%%PORTDOCS%%share/doc/ngrep/CHANGES
-%%PORTDOCS%%share/doc/ngrep/README
-%%PORTDOCS%%share/doc/ngrep/README.pcre
-%%PORTDOCS%%share/doc/ngrep/USAGE
-%%PORTDOCS%%@dirrm share/doc/ngrep