aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-31 00:27:01 +0800
committerpav <pav@FreeBSD.org>2004-07-31 00:27:01 +0800
commit7c6e720f15a3c7452d8918debcc3fa33a2e362bf (patch)
treec1143031dcaefeda653dcb1af630649f13882137 /net
parente4fb051bc34a210abeb36542e8e3275f7f568a9f (diff)
downloadfreebsd-ports-gnome-7c6e720f15a3c7452d8918debcc3fa33a2e362bf.tar.gz
freebsd-ports-gnome-7c6e720f15a3c7452d8918debcc3fa33a2e362bf.tar.zst
freebsd-ports-gnome-7c6e720f15a3c7452d8918debcc3fa33a2e362bf.zip
- Recognize gre, gif, esp protocols
PR: ports/69654 Submitted by: Ilya V. Guy <ilya@lisgroup.net> Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/trafshow/Makefile2
-rw-r--r--net/trafshow/files/patch-ag20
-rw-r--r--net/trafshow3/Makefile2
-rw-r--r--net/trafshow3/files/patch-ag20
-rw-r--r--net/trafshow4/Makefile2
-rw-r--r--net/trafshow4/files/patch-ag20
6 files changed, 45 insertions, 21 deletions
diff --git a/net/trafshow/Makefile b/net/trafshow/Makefile
index d5dd5b66d62b..07b9641894a2 100644
--- a/net/trafshow/Makefile
+++ b/net/trafshow/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trafshow
PORTVERSION= 3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ftp://ftp.sasknow.com/pub/trafshow/ \
ftp://ftp.nsk.su/pub/RinetSoftware/
diff --git a/net/trafshow/files/patch-ag b/net/trafshow/files/patch-ag
index b4003dcf9649..959cd5221318 100644
--- a/net/trafshow/files/patch-ag
+++ b/net/trafshow/files/patch-ag
@@ -1,12 +1,20 @@
---- util.c.orig Fri Sep 15 06:51:11 2000
-+++ util.c Thu Sep 21 14:35:33 2000
-@@ -129,6 +129,9 @@
+--- util.c.orig Thu Sep 25 06:37:57 1997
++++ util.c Fri Jul 30 18:20:20 2004
+@@ -123,11 +123,17 @@
+ { "egp", IPPROTO_EGP },
+ { "ospf", IPPROTO_OSPF },
+ { "igmp", IPPROTO_IGMP },
++ { "gre", IPPROTO_GRE },
++ { "gif", IPPROTO_IPIP },
++ { "esp", IPPROTO_ESP },
+ #ifdef IPPROTO_GGP
+ { "ggp", IPPROTO_GGP },
+ #endif
#ifdef IPPROTO_ENCAP
{ "encap",IPPROTO_ENCAP},
- #endif
++#endif
+#ifdef IPPROTO_IPV6
+ { "ipv6", IPPROTO_IPV6},
-+#endif
+ #endif
{ "ip", IPPROTO_IP },
{ "raw", IPPROTO_RAW },
- { NULL, -1 },
diff --git a/net/trafshow3/Makefile b/net/trafshow3/Makefile
index d5dd5b66d62b..07b9641894a2 100644
--- a/net/trafshow3/Makefile
+++ b/net/trafshow3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trafshow
PORTVERSION= 3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ftp://ftp.sasknow.com/pub/trafshow/ \
ftp://ftp.nsk.su/pub/RinetSoftware/
diff --git a/net/trafshow3/files/patch-ag b/net/trafshow3/files/patch-ag
index b4003dcf9649..959cd5221318 100644
--- a/net/trafshow3/files/patch-ag
+++ b/net/trafshow3/files/patch-ag
@@ -1,12 +1,20 @@
---- util.c.orig Fri Sep 15 06:51:11 2000
-+++ util.c Thu Sep 21 14:35:33 2000
-@@ -129,6 +129,9 @@
+--- util.c.orig Thu Sep 25 06:37:57 1997
++++ util.c Fri Jul 30 18:20:20 2004
+@@ -123,11 +123,17 @@
+ { "egp", IPPROTO_EGP },
+ { "ospf", IPPROTO_OSPF },
+ { "igmp", IPPROTO_IGMP },
++ { "gre", IPPROTO_GRE },
++ { "gif", IPPROTO_IPIP },
++ { "esp", IPPROTO_ESP },
+ #ifdef IPPROTO_GGP
+ { "ggp", IPPROTO_GGP },
+ #endif
#ifdef IPPROTO_ENCAP
{ "encap",IPPROTO_ENCAP},
- #endif
++#endif
+#ifdef IPPROTO_IPV6
+ { "ipv6", IPPROTO_IPV6},
-+#endif
+ #endif
{ "ip", IPPROTO_IP },
{ "raw", IPPROTO_RAW },
- { NULL, -1 },
diff --git a/net/trafshow4/Makefile b/net/trafshow4/Makefile
index d5dd5b66d62b..07b9641894a2 100644
--- a/net/trafshow4/Makefile
+++ b/net/trafshow4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trafshow
PORTVERSION= 3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ftp://ftp.sasknow.com/pub/trafshow/ \
ftp://ftp.nsk.su/pub/RinetSoftware/
diff --git a/net/trafshow4/files/patch-ag b/net/trafshow4/files/patch-ag
index b4003dcf9649..959cd5221318 100644
--- a/net/trafshow4/files/patch-ag
+++ b/net/trafshow4/files/patch-ag
@@ -1,12 +1,20 @@
---- util.c.orig Fri Sep 15 06:51:11 2000
-+++ util.c Thu Sep 21 14:35:33 2000
-@@ -129,6 +129,9 @@
+--- util.c.orig Thu Sep 25 06:37:57 1997
++++ util.c Fri Jul 30 18:20:20 2004
+@@ -123,11 +123,17 @@
+ { "egp", IPPROTO_EGP },
+ { "ospf", IPPROTO_OSPF },
+ { "igmp", IPPROTO_IGMP },
++ { "gre", IPPROTO_GRE },
++ { "gif", IPPROTO_IPIP },
++ { "esp", IPPROTO_ESP },
+ #ifdef IPPROTO_GGP
+ { "ggp", IPPROTO_GGP },
+ #endif
#ifdef IPPROTO_ENCAP
{ "encap",IPPROTO_ENCAP},
- #endif
++#endif
+#ifdef IPPROTO_IPV6
+ { "ipv6", IPPROTO_IPV6},
-+#endif
+ #endif
{ "ip", IPPROTO_IP },
{ "raw", IPPROTO_RAW },
- { NULL, -1 },