aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
committernetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
commit8725235f35a03fb0dd1da17304424701f84e15dd (patch)
tree5205db7c3150c2000d8091bebe7ce6fc273be03c /net
parentb3c031084f5535608ae04c365e4eea69d5c7ad16 (diff)
downloadfreebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.gz
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.zst
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.zip
Re-commit of
64 bit linuxulator support (not activated by default): - most of the work was done by Alan Jude - all errors are mine - 64bit (may) have rough edges - I validated * that the 32bit part doesn't has deinstall regressions (incl. EXP runs by antoine) * 29 of 72 64bit ports ports don't have deinstall leftovers (more validation later, when I dare to activate the 64bit linuxulator in the kernel) - the infrastructure part looks mature enough to let more test-bunnies get some experience with the new 64 bit parts - to use it you shall have no linux ports installed and have to specify (on your own risk) the following in make.conf before installing the ports: OVERRIDE_LINUX_BASE_PORT=c6_64 OVERRIDE_LINUX_NONBASE_PORTS=c6_64 This is on top of the exiting c6 linux ports. Given that CentOS 7 is 64bits only, we decided to have it as an "overlay" instead of new ports. The 64bit part only installs 64bit executables, the 32bit ports can not be installed at the same time (if needed we can think of letting the 64bit overlay install the 32bit parts too, but given the CentOS 7 comment above...). Differential Revision: https://reviews.freebsd.org/D174 Submitted by: alanjude Sponsored by: Essen FreeBSD Hackathon 2015 Reviewed by: xmj, eadler (earlier versions) Approved by: portmgr (antoine after some EXP-runs)
Diffstat (limited to 'net')
-rw-r--r--net/linux-c6-avahi-libs/Makefile7
-rw-r--r--net/linux-c6-avahi-libs/distinfo.x86_644
-rw-r--r--net/linux-c6-avahi-libs/pkg-plist.i6864
-rw-r--r--net/linux-c6-avahi-libs/pkg-plist.x86_644
-rw-r--r--net/linux-c6-openldap/distinfo.x86_644
-rw-r--r--net/linux-c6-openldap/pkg-plist.i686 (renamed from net/linux-c6-openldap/pkg-plist)0
-rw-r--r--net/linux-c6-openldap/pkg-plist.x86_6412
-rw-r--r--net/linux-c6-tcp_wrappers-libs/Makefile2
-rw-r--r--net/linux-c6-tcp_wrappers-libs/distinfo.x86_644
-rw-r--r--net/linux-c6-tcp_wrappers-libs/pkg-plist.i686 (renamed from net/linux-c6-tcp_wrappers-libs/pkg-plist)1
-rw-r--r--net/linux-c6-tcp_wrappers-libs/pkg-plist.x86_6414
11 files changed, 50 insertions, 6 deletions
diff --git a/net/linux-c6-avahi-libs/Makefile b/net/linux-c6-avahi-libs/Makefile
index 80ee8f30cf31..bdb687c1cb53 100644
--- a/net/linux-c6-avahi-libs/Makefile
+++ b/net/linux-c6-avahi-libs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= avahi-libs
PORTVERSION= 0.6.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net linux
MAINTAINER= emulation@FreeBSD.org
@@ -14,10 +14,7 @@ USE_LINUX_RPM= yes
RPMVERSION= 15.el6
USE_LDCONFIG= yes
-SRC_DISTFILES= ${PORTNAME:S/-libs//}-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
+SRC_DISTFILES= ${PORTNAME:S/-libs//}-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
DESCR= ${.CURDIR}/../avahi/pkg-descr
-PLIST_FILES= usr/lib/libavahi-client.so.3 usr/lib/libavahi-client.so.3.2.5 \
- usr/lib/libavahi-common.so.3 usr/lib/libavahi-common.so.3.5.1
-
.include <bsd.port.mk>
diff --git a/net/linux-c6-avahi-libs/distinfo.x86_64 b/net/linux-c6-avahi-libs/distinfo.x86_64
new file mode 100644
index 000000000000..572d0aa4d768
--- /dev/null
+++ b/net/linux-c6-avahi-libs/distinfo.x86_64
@@ -0,0 +1,4 @@
+SHA256 (rpm/x86_64/centos/6.6/avahi-libs-0.6.25-15.el6.x86_64.rpm) = a8ef064f4c382bf39ee2c17f646ef01afc17067eb7a0d3a591130da90e6eefb6
+SIZE (rpm/x86_64/centos/6.6/avahi-libs-0.6.25-15.el6.x86_64.rpm) = 55948
+SHA256 (rpm/x86_64/centos/6.6/avahi-0.6.25-15.el6.src.rpm) = d274512f9456da9742d38ee3fbfbc483719cfc9f9918987d385c8ee89179263b
+SIZE (rpm/x86_64/centos/6.6/avahi-0.6.25-15.el6.src.rpm) = 1138822
diff --git a/net/linux-c6-avahi-libs/pkg-plist.i686 b/net/linux-c6-avahi-libs/pkg-plist.i686
new file mode 100644
index 000000000000..5b55ef27d34c
--- /dev/null
+++ b/net/linux-c6-avahi-libs/pkg-plist.i686
@@ -0,0 +1,4 @@
+usr/lib/libavahi-client.so.3
+usr/lib/libavahi-client.so.3.2.5
+usr/lib/libavahi-common.so.3
+usr/lib/libavahi-common.so.3.5.1
diff --git a/net/linux-c6-avahi-libs/pkg-plist.x86_64 b/net/linux-c6-avahi-libs/pkg-plist.x86_64
new file mode 100644
index 000000000000..6c52a8cad466
--- /dev/null
+++ b/net/linux-c6-avahi-libs/pkg-plist.x86_64
@@ -0,0 +1,4 @@
+usr/lib64/libavahi-client.so.3
+usr/lib64/libavahi-client.so.3.2.5
+usr/lib64/libavahi-common.so.3
+usr/lib64/libavahi-common.so.3.5.1
diff --git a/net/linux-c6-openldap/distinfo.x86_64 b/net/linux-c6-openldap/distinfo.x86_64
new file mode 100644
index 000000000000..b69614ba57c4
--- /dev/null
+++ b/net/linux-c6-openldap/distinfo.x86_64
@@ -0,0 +1,4 @@
+SHA256 (rpm/x86_64/centos/6.6/openldap-2.4.39-8.el6.x86_64.rpm) = f38696f6b963cd702bf77a902a2e5c1297e697b168226156f1a5ae5e24ea070d
+SIZE (rpm/x86_64/centos/6.6/openldap-2.4.39-8.el6.x86_64.rpm) = 286208
+SHA256 (rpm/x86_64/centos/6.6/openldap-2.4.39-8.el6.src.rpm) = 067844ffeb73854d5fbd25760e38f02617a06b54ecbd8c1df4a4066dbb0115f1
+SIZE (rpm/x86_64/centos/6.6/openldap-2.4.39-8.el6.src.rpm) = 5577657
diff --git a/net/linux-c6-openldap/pkg-plist b/net/linux-c6-openldap/pkg-plist.i686
index c9655c2ddf11..c9655c2ddf11 100644
--- a/net/linux-c6-openldap/pkg-plist
+++ b/net/linux-c6-openldap/pkg-plist.i686
diff --git a/net/linux-c6-openldap/pkg-plist.x86_64 b/net/linux-c6-openldap/pkg-plist.x86_64
new file mode 100644
index 000000000000..e06057431f6b
--- /dev/null
+++ b/net/linux-c6-openldap/pkg-plist.x86_64
@@ -0,0 +1,12 @@
+%%ETCDIR%%
+lib64/liblber-2.4.so.2
+lib64/liblber-2.4.so.2.10.2
+lib64/libldap-2.4.so.2
+lib64/libldap-2.4.so.2.10.2
+lib64/libldap_r-2.4.so.2
+lib64/libldap_r-2.4.so.2.10.2
+lib64/libldif-2.4.so.2
+lib64/libldif-2.4.so.2.10.2
+usr/libexec/openldap/create-certdb.sh
+usr/share/man/man5/ldap.conf.5.gz
+usr/share/man/man5/ldif.5.gz
diff --git a/net/linux-c6-tcp_wrappers-libs/Makefile b/net/linux-c6-tcp_wrappers-libs/Makefile
index ea95360e87c3..468ca4916e8f 100644
--- a/net/linux-c6-tcp_wrappers-libs/Makefile
+++ b/net/linux-c6-tcp_wrappers-libs/Makefile
@@ -18,6 +18,6 @@ USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/usr/share/doc/tcp_wrappers-${PORTVERSION}
-SRC_DISTFILES= tcp_wrappers-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
+SRC_DISTFILES= tcp_wrappers-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
.include <bsd.port.mk>
diff --git a/net/linux-c6-tcp_wrappers-libs/distinfo.x86_64 b/net/linux-c6-tcp_wrappers-libs/distinfo.x86_64
new file mode 100644
index 000000000000..577d1e432399
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/distinfo.x86_64
@@ -0,0 +1,4 @@
+SHA256 (rpm/x86_64/centos/6.6/tcp_wrappers-libs-7.6-57.el6.x86_64.rpm) = a76713ff2e476970a507e2491369b92424b59e6e1418ea47f1a754cd8b63f144
+SIZE (rpm/x86_64/centos/6.6/tcp_wrappers-libs-7.6-57.el6.x86_64.rpm) = 63484
+SHA256 (rpm/x86_64/centos/6.6/tcp_wrappers-7.6-57.el6.src.rpm) = b5dc9f2893acf4fbbe7e727273793d21cfdd932c66ddb18ef4d0394f13b12988
+SIZE (rpm/x86_64/centos/6.6/tcp_wrappers-7.6-57.el6.src.rpm) = 140453
diff --git a/net/linux-c6-tcp_wrappers-libs/pkg-plist b/net/linux-c6-tcp_wrappers-libs/pkg-plist.i686
index 70b742e57c30..cfed659aa554 100644
--- a/net/linux-c6-tcp_wrappers-libs/pkg-plist
+++ b/net/linux-c6-tcp_wrappers-libs/pkg-plist.i686
@@ -11,3 +11,4 @@ usr/share/man/man5/hosts.allow.5.gz
usr/share/man/man5/hosts.deny.5.gz
usr/share/man/man5/hosts_access.5.gz
usr/share/man/man5/hosts_options.5.gz
+@dirrmtry usr/share/doc/tcp_wrappers-libs-7.6
diff --git a/net/linux-c6-tcp_wrappers-libs/pkg-plist.x86_64 b/net/linux-c6-tcp_wrappers-libs/pkg-plist.x86_64
new file mode 100644
index 000000000000..988b6eeaeb66
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/pkg-plist.x86_64
@@ -0,0 +1,14 @@
+lib64/libwrap.so.0
+lib64/libwrap.so.0.7.6
+usr/share/doc/tcp_wrappers-libs-7.6/BLURB
+usr/share/doc/tcp_wrappers-libs-7.6/Banners.Makefile
+usr/share/doc/tcp_wrappers-libs-7.6/CHANGES
+usr/share/doc/tcp_wrappers-libs-7.6/DISCLAIMER
+usr/share/doc/tcp_wrappers-libs-7.6/README
+usr/share/doc/tcp_wrappers-libs-7.6/README.IRIX
+usr/share/doc/tcp_wrappers-libs-7.6/README.NIS
+usr/share/man/man5/hosts.allow.5.gz
+usr/share/man/man5/hosts.deny.5.gz
+usr/share/man/man5/hosts_access.5.gz
+usr/share/man/man5/hosts_options.5.gz
+@dirrmtry usr/share/doc/tcp_wrappers-libs-7.6