aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2003-03-04 22:53:27 +0800
committerroger <roger@FreeBSD.org>2003-03-04 22:53:27 +0800
commit92b697b29f12147ebc932eb41768cba2578874d5 (patch)
treec5a92b66f0d39279d1ad10a99ce7d6869e068c6d /net
parent53076ac48a9ab6f45c7f186221709037f14cc5aa (diff)
downloadfreebsd-ports-gnome-92b697b29f12147ebc932eb41768cba2578874d5.tar.gz
freebsd-ports-gnome-92b697b29f12147ebc932eb41768cba2578874d5.tar.zst
freebsd-ports-gnome-92b697b29f12147ebc932eb41768cba2578874d5.zip
build and install the addpasswd program.
Diffstat (limited to 'net')
-rw-r--r--net/gatekeeper/Makefile3
-rw-r--r--net/gatekeeper/files/patch-makefile19
-rw-r--r--net/gatekeeper/pkg-plist1
3 files changed, 22 insertions, 1 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index 133e910d028f..38542def4b4d 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -22,7 +22,7 @@ NOCLEANDEPENDS= yes
USE_BISON= yes
USE_GMAKE= yes
-ALL_TARGET= optnoshared
+ALL_TARGET= optnoshared addpasswd
MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
THE_MACHTYPE= ${ARCH:S/i386/x86/}
@@ -30,5 +30,6 @@ MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/gnugk ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/addpasswd ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net/gatekeeper/files/patch-makefile b/net/gatekeeper/files/patch-makefile
new file mode 100644
index 000000000000..e5e8b3e9a9d1
--- /dev/null
+++ b/net/gatekeeper/files/patch-makefile
@@ -0,0 +1,19 @@
+*** Makefile.orig Mon Mar 3 19:52:50 2003
+--- Makefile Mon Mar 3 19:59:55 2003
+*************** endif
+*** 162,168 ****
+
+ # extra targets
+ addpasswd: $(OBJDIR)/addpasswd.o
+! $(CXX) -o $(OBJDIR)/addpasswd $(OBJDIR)/addpasswd.o $(LDFLAGS) -l$(PTLIB_BASE)$(LIB_TYPE) -lpthread -lssl -lexpat
+
+ doc: docs/manual.sgml
+ cd docs; sgml2html manual.sgml; \
+--- 162,168 ----
+
+ # extra targets
+ addpasswd: $(OBJDIR)/addpasswd.o
+! $(CXX) -o $(OBJDIR)/addpasswd $(OBJDIR)/addpasswd.o $(LDFLAGS) -l$(PTLIB_BASE)$(LIB_TYPE)_s -pthread -lssl -lcrypto -lexpat
+
+ doc: docs/manual.sgml
+ cd docs; sgml2html manual.sgml; \
diff --git a/net/gatekeeper/pkg-plist b/net/gatekeeper/pkg-plist
index aa8bc9902733..2e7e1904a073 100644
--- a/net/gatekeeper/pkg-plist
+++ b/net/gatekeeper/pkg-plist
@@ -1 +1,2 @@
bin/gnugk
+bin/addpasswd