aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2015-12-17 01:10:22 +0800
committerbofh <bofh@FreeBSD.org>2015-12-17 01:10:22 +0800
commit9590df689cdeec27d76d4879f359c8786e848daf (patch)
tree467fda4323ca58c675108872755f9573f61966a5 /net
parent72014306bc867dc4bcca7029a74ccda8b7c9cacf (diff)
downloadfreebsd-ports-gnome-9590df689cdeec27d76d4879f359c8786e848daf.tar.gz
freebsd-ports-gnome-9590df689cdeec27d76d4879f359c8786e848daf.tar.zst
freebsd-ports-gnome-9590df689cdeec27d76d4879f359c8786e848daf.zip
net/usbredir: Update version 0.6=>0.7.1
- Take MAINTAINERSHIP
Diffstat (limited to 'net')
-rw-r--r--net/usbredir/Makefile12
-rw-r--r--net/usbredir/distinfo4
-rw-r--r--net/usbredir/files/patch-usbredirserver-usbredirserver.c12
-rw-r--r--net/usbredir/files/patch-usbredirtestclient-usbredirtestclient.c12
4 files changed, 9 insertions, 31 deletions
diff --git a/net/usbredir/Makefile b/net/usbredir/Makefile
index 904508e11865..0a9894034843 100644
--- a/net/usbredir/Makefile
+++ b/net/usbredir/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= usbredir
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7.1
CATEGORIES= net devel
MASTER_SITES= http://spice-space.org/download/usbredir/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= protocol for redirection of USB traffic
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Protocol for redirection of USB traffic
+
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= dual
USES= gmake libtool pathfix pkgconfig tar:bzip2
-PATCH_STRIP= -p1
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
CONFIGURE_ENV= LIBUSB_CFLAGS=-DLIBUSB_CALL= LIBUSB_LIBS=-lusb
diff --git a/net/usbredir/distinfo b/net/usbredir/distinfo
index 6fa275a1a67e..725450771ce1 100644
--- a/net/usbredir/distinfo
+++ b/net/usbredir/distinfo
@@ -1,2 +1,2 @@
-SHA256 (usbredir-0.6.tar.bz2) = 028184960044ea4124030000b3c55a35c3238835116e3a0fbcaff449df2c8edf
-SIZE (usbredir-0.6.tar.bz2) = 305887
+SHA256 (usbredir-0.7.1.tar.bz2) = 407e9e27a1369f01264d5501ffbe88935ddd7d5de675f5835db05dc9c9ac56f3
+SIZE (usbredir-0.7.1.tar.bz2) = 329895
diff --git a/net/usbredir/files/patch-usbredirserver-usbredirserver.c b/net/usbredir/files/patch-usbredirserver-usbredirserver.c
deleted file mode 100644
index de387f8b7e93..000000000000
--- a/net/usbredir/files/patch-usbredirserver-usbredirserver.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/usbredirserver/usbredirserver.c
-+++ b/usbredirserver/usbredirserver.c
-@@ -33,6 +33,9 @@
- #include <sys/types.h>
- #include <sys/time.h>
- #include <netdb.h>
-+#ifdef __FreeBSD__
-+#include <netinet/in.h>
-+#endif
- #include "usbredirhost.h"
-
- #define VERSION "usbredirserver " USBREDIR_VERSION
diff --git a/net/usbredir/files/patch-usbredirtestclient-usbredirtestclient.c b/net/usbredir/files/patch-usbredirtestclient-usbredirtestclient.c
deleted file mode 100644
index 5dc291c1041c..000000000000
--- a/net/usbredir/files/patch-usbredirtestclient-usbredirtestclient.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/usbredirtestclient/usbredirtestclient.c
-+++ b/usbredirtestclient/usbredirtestclient.c
-@@ -33,6 +33,9 @@
- #include <sys/types.h>
- #include <sys/time.h>
- #include <netdb.h>
-+#ifdef __FreeBSD__
-+#include <netinet/in.h>
-+#endif
- #include "usbredirparser.h"
-
- /* Macros to go from an endpoint address to an index for our ep array */