aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-10-13 14:58:21 +0800
committermarcus <marcus@FreeBSD.org>2002-10-13 14:58:21 +0800
commit994b8bee5e5090820a56afaf816c0e11ccb4f348 (patch)
tree95233dd3eb82f6477efdbd8b74c3213923228373 /net
parent978a6fe489f30876fc530d014bd60cda30cdcc40 (diff)
downloadfreebsd-ports-gnome-994b8bee5e5090820a56afaf816c0e11ccb4f348.tar.gz
freebsd-ports-gnome-994b8bee5e5090820a56afaf816c0e11ccb4f348.tar.zst
freebsd-ports-gnome-994b8bee5e5090820a56afaf816c0e11ccb4f348.zip
Fix a segfault in the Yahoo! module.
Reported by: Kenneth W Cochran <kwc@TheWorld.com> Obtained from: gaim CVS
Diffstat (limited to 'net')
-rw-r--r--net/gaim-snapshot/Makefile2
-rw-r--r--net/gaim-snapshot/files/patch-temp12
-rw-r--r--net/gaim/Makefile2
-rw-r--r--net/gaim/files/patch-temp12
4 files changed, 26 insertions, 2 deletions
diff --git a/net/gaim-snapshot/Makefile b/net/gaim-snapshot/Makefile
index 5fb47908dde0..f7adace4035d 100644
--- a/net/gaim-snapshot/Makefile
+++ b/net/gaim-snapshot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim-snapshot/files/patch-temp b/net/gaim-snapshot/files/patch-temp
new file mode 100644
index 000000000000..39073683ae61
--- /dev/null
+++ b/net/gaim-snapshot/files/patch-temp
@@ -0,0 +1,12 @@
+--- src/protocols/yahoo/yahoo.c.orig Sun Oct 13 02:50:25 2002
++++ src/protocols/yahoo/yahoo.c Sun Oct 13 02:50:58 2002
+@@ -525,6 +525,9 @@
+ l = l->next;
+ }
+
++ if (!msg)
++ return;
++
+ if (!g_strncasecmp(msg, "TYPING", strlen("TYPING"))) {
+ if (*stat == '1')
+ serv_got_typing(gc, from, 0);
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 5fb47908dde0..f7adace4035d 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-temp b/net/gaim/files/patch-temp
new file mode 100644
index 000000000000..39073683ae61
--- /dev/null
+++ b/net/gaim/files/patch-temp
@@ -0,0 +1,12 @@
+--- src/protocols/yahoo/yahoo.c.orig Sun Oct 13 02:50:25 2002
++++ src/protocols/yahoo/yahoo.c Sun Oct 13 02:50:58 2002
+@@ -525,6 +525,9 @@
+ l = l->next;
+ }
+
++ if (!msg)
++ return;
++
+ if (!g_strncasecmp(msg, "TYPING", strlen("TYPING"))) {
+ if (*stat == '1')
+ serv_got_typing(gc, from, 0);