aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
committertijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
commit9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net
parent6af0c041428d493f447a328f9e81efe5b6d72273 (diff)
downloadfreebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.gz
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.zst
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.zip
Install net/libnet headers and libraries back in the location where other
ports expect it. The files were put in a different location to avoid a conflict with net/libnet10 but this port has been removed a while ago now. PR: 208122 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/arp-sk/Makefile14
-rw-r--r--net/arping/Makefile7
-rw-r--r--net/arprelease/Makefile2
-rw-r--r--net/fonulator/Makefile17
-rw-r--r--net/gspoof/Makefile8
-rw-r--r--net/gspoof/files/patch-configure30
-rw-r--r--net/libfb/Makefile10
-rw-r--r--net/libnet/Makefile23
-rw-r--r--net/libnet/files/patch-Makefile.in10
-rw-r--r--net/libnet/pkg-plist26
-rw-r--r--net/libnids-libnet11/Makefile17
-rw-r--r--net/libnids-libnet11/pkg-descr13
-rw-r--r--net/libnids/Makefile10
-rw-r--r--net/nast/Makefile11
-rw-r--r--net/nast/files/patch-configure85
-rw-r--r--net/netwib/Makefile17
-rw-r--r--net/py-libnet/Makefile3
-rw-r--r--net/py-libnet/files/patch-setup.py13
-rw-r--r--net/pynids/Makefile22
-rw-r--r--net/rtpbreak/Makefile4
-rw-r--r--net/tcptraceroute-devel/Makefile4
-rw-r--r--net/tcptraceroute-devel/files/patch-configure46
-rw-r--r--net/tcptraceroute/Makefile1
-rw-r--r--net/tcptraceroute/files/patch-configure73
-rw-r--r--net/vortex/Makefile6
26 files changed, 81 insertions, 392 deletions
diff --git a/net/Makefile b/net/Makefile
index a62257df89ac..12a561f0c0ff 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -327,7 +327,6 @@
SUBDIR += libnetdude
SUBDIR += libnfs
SUBDIR += libnids
- SUBDIR += libnids-libnet11
SUBDIR += libnss-cache
SUBDIR += libnss-mysql
SUBDIR += liboauth
diff --git a/net/arp-sk/Makefile b/net/arp-sk/Makefile
index 4d8b0277bb8e..7c6143003a58 100644
--- a/net/arp-sk/Makefile
+++ b/net/arp-sk/Makefile
@@ -14,22 +14,10 @@ COMMENT= Tool designed to manipulate ARP tables of all kinds of equipment
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-
-CFLAGS+= `${LIBNET_CONFIG} --cflags`
+CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
PLIST_FILES= sbin/arp-sk man/man1/arp-sk.1.gz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-post-patch:
- @${REINPLACE_CMD} -Ee \
- 's| -pedantic -g||; \
- s|test -f \$${prefix}/include/libnet\.h|${TRUE}|; \
- s|\$$NETINC/libnet\.h|libnet.h|; \
- s|(NETINC=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
- s|(NETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/arp-sk ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/man/arp-sk.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/net/arping/Makefile b/net/arping/Makefile
index f489761bbb13..95841fe50216 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -15,11 +15,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include \
- `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
-LIBS+= -L${LOCALBASE}/lib `${LIBNET_CONFIG} --libs` -lpcap
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= sbin/arping man/man8/arping.8.gz
diff --git a/net/arprelease/Makefile b/net/arprelease/Makefile
index 3613cbe27927..038fb5d6826e 100644
--- a/net/arprelease/Makefile
+++ b/net/arprelease/Makefile
@@ -16,7 +16,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/arprelease
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
do-build:
(cd ${WRKSRC} && \
diff --git a/net/fonulator/Makefile b/net/fonulator/Makefile
index 01f00d9c99b7..92e383164f7b 100644
--- a/net/fonulator/Makefile
+++ b/net/fonulator/Makefile
@@ -15,30 +15,19 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libargtable2.a:${PORTSDIR}/devel/argtable\
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${LIBNET_CPPFLAGS}
-LDFLAGS+= ${LIBNET_LIBS:N-l*}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-shared
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
-
PLIST_FILES= bin/fonulator \
man/man1/fonulator.1.gz
post-patch:
@${REINPLACE_CMD}\
-e 's,/usr/lib/libargtable2.a,${LOCALBASE}/lib/libargtable2.a,'\
- -e 's,/usr/lib/libnet.a,${LIBNET_LIBS:N-l*:S,-L,,}/libnet.a,'\
+ -e 's,/usr/lib/libnet.a,${LOCALBASE}/lib/libnet.a,'\
${WRKSRC}/Makefile.in ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,/etc/redfone.conf,${LOCALBASE}/etc/redfone.conf,'\
${WRKSRC}/fonulator.c ${WRKSRC}/fonulator.1
-.if 0
-# this does not work when LIBNET_CONFIG does not exist prior to building this port
-LIBNET_CPPFLAGS!= ${LIBNET_CONFIG} --cflags --defines
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.else
-LIBNET_CPPFLAGS= -I${LOCALBASE}/include/libnet11
-LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11
-.endif
-
.include <bsd.port.mk>
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
index fe107c493b86..90124803330e 100644
--- a/net/gspoof/Makefile
+++ b/net/gspoof/Makefile
@@ -14,17 +14,13 @@ LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libnet-prefix=${LOCALBASE}
USES= gmake
OPTIONS_DEFINE= DOCS
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-Wall -O2|$${CFLAGS}|g; \
- s|libnet-config|${LIBNET_CONFIG}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} 's|-Wall -O2|$${CFLAGS}|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-Wall -O2|@CFLAGS@|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|g ; \
s|/usr/share|${LOCALBASE}/share|g' ${WRKSRC}/gtk.c
diff --git a/net/gspoof/files/patch-configure b/net/gspoof/files/patch-configure
deleted file mode 100644
index 9721ae803bb6..000000000000
--- a/net/gspoof/files/patch-configure
+++ /dev/null
@@ -1,30 +0,0 @@
---- ./configure.orig Tue Dec 23 07:54:42 2003
-+++ ./configure Wed Sep 27 18:23:26 2006
-@@ -2505,24 +2505,12 @@
- as_ac_File=`echo "ac_cv_file_$LIBNET_PREFIX/lib/libnet.a" | $as_tr_sh`
- echo "$as_me:$LINENO: checking for $LIBNET_PREFIX/lib/libnet.a" >&5
- echo $ECHO_N "checking for $LIBNET_PREFIX/lib/libnet.a... $ECHO_C" >&6
--if eval "test \"\${$as_ac_File+set}\" = set"; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- test "$cross_compiling" = yes &&
-- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-- { (exit 1); exit 1; }; }
--if test -r "$LIBNET_PREFIX/lib/libnet.a"; then
-- eval "$as_ac_File=yes"
--else
-- eval "$as_ac_File=no"
--fi
--fi
-+eval "$as_ac_File=yes"
- echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
- echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
- if test `eval echo '${'$as_ac_File'}'` = yes; then
-- LDFLAGS="-L$LIBNET_PREFIX/lib"
-- CPPFLAGS="-I$LIBNET_PREFIX/include"
-+ LDFLAGS="`libnet-config --libs`"
-+ CPPFLAGS="`libnet-config --cflags`"
- else
- { { echo "$as_me:$LINENO: error:
- Libnet-1.1.1 Packet Shaping Library is required!
diff --git a/net/libfb/Makefile b/net/libfb/Makefile
index 762583cb19dd..3505473c80f0 100644
--- a/net/libfb/Makefile
+++ b/net/libfb/Makefile
@@ -14,15 +14,9 @@ LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-shared
-CPPFLAGS+= ${LIBNET_CPPFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
USES= libtool
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
-LIBNET_CPPFLAGS=`${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
-LIBNET_LIBS= `${LIBNET_CONFIG} --libs`
-
-post-patch:
- @${REINPLACE_CMD} 's,-lnet,${LIBNET_LIBS},' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net/libnet/Makefile b/net/libnet/Makefile
index ed0be52a87e8..da6c118eedb2 100644
--- a/net/libnet/Makefile
+++ b/net/libnet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libnet
PORTVERSION= 1.1.6
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/libnet-dev
@@ -12,6 +12,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library for creating IP packets
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/doc/COPYING
OPTIONS_DEFINE= BPF DOCS EXAMPLES
OPTIONS_DEFAULT=BPF
@@ -23,13 +24,9 @@ USE_CSTD= gnu89
USE_LDCONFIG= yes
USES= libtool
-SHORT_NAME= ${PORTNAME}11
-DOCSDIR= ${PREFIX}/share/doc/${SHORT_NAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${SHORT_NAME}
-USE_LDCONFIG= ${PREFIX}/lib/${SHORT_NAME}
-PLIST_SUB= SNAME=${SHORT_NAME} VERSION=${PORTVERSION}
+PLIST_SUB= VERSION=${PORTVERSION}
-DOCS= README doc/CHANGELOG doc/CONTRIB doc/COPYING \
+DOCS= README doc/CHANGELOG doc/CONTRIB \
doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
EXAMPLES= sample/*.c
@@ -39,19 +36,11 @@ BPF_CONFIGURE_ON= --with-link-layer=bpf
post-patch:
@${REINPLACE_CMD} \
- -e 's|@LIBNET_CONFIG_LIBS@|@LIBNET_CONFIG_LIBS@ -L@prefix@/lib/${SHORT_NAME}|' \
- -e 's|@LIBNET_CONFIG_CFLAGS@|@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include/${SHORT_NAME}|' \
+ -e 's|@LIBNET_CONFIG_LIBS@|@LIBNET_CONFIG_LIBS@ -L@prefix@/lib|' \
+ -e 's|@LIBNET_CONFIG_CFLAGS@|@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include|' \
${WRKSRC}/libnet-config.in
- @${REINPLACE_CMD} -e 's|^includedir =.*|includedir = @includedir@/${SHORT_NAME}|' \
- ${WRKSRC}/include/Makefile.in \
- ${WRKSRC}/include/libnet/Makefile.in
- @${REINPLACE_CMD} -e 's|^libdir =.*|libdir = @libdir@/${SHORT_NAME}|' \
- -e 's|^libnet_la_LDFLAGS =\(.*\)|libnet_la_LDFLAGS =\1 -soname=libnet-${SHORT_NAME}.so.1|' \
- ${WRKSRC}/src/Makefile.in
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${STAGEDIR}${PREFIX}/bin/${SHORT_NAME}-config
- ${LN} -fs ${SHORT_NAME}/libnet.so.1 ${STAGEDIR}${PREFIX}/lib/libnet-${PORTVERSION}.so.1
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
diff --git a/net/libnet/files/patch-Makefile.in b/net/libnet/files/patch-Makefile.in
deleted file mode 100644
index 59863e03e93c..000000000000
--- a/net/libnet/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Makefile.in.orig Thu Dec 2 21:27:39 2004
-+++ ./Makefile.in Sat Jan 20 14:10:35 2007
-@@ -208,7 +208,6 @@
- DISTCLEANFILES = *~
- SUBDIRS = include src sample
- EXTRA_DIST = Makefile.am.common
--bin_SCRIPTS = libnet-config
- all: all-recursive
-
- .SUFFIXES:
diff --git a/net/libnet/pkg-plist b/net/libnet/pkg-plist
index 843d06087115..1e12623458c9 100644
--- a/net/libnet/pkg-plist
+++ b/net/libnet/pkg-plist
@@ -1,22 +1,20 @@
-bin/%%SNAME%%-config
-include/%%SNAME%%/libnet.h
-include/%%SNAME%%/libnet/libnet-asn1.h
-include/%%SNAME%%/libnet/libnet-functions.h
-include/%%SNAME%%/libnet/libnet-headers.h
-include/%%SNAME%%/libnet/libnet-macros.h
-include/%%SNAME%%/libnet/libnet-structures.h
-include/%%SNAME%%/libnet/libnet-types.h
-lib/%%SNAME%%/libnet.a
-lib/%%SNAME%%/libnet.so
-lib/%%SNAME%%/libnet.so.1
-lib/%%SNAME%%/libnet.so.1.7.0
-lib/libnet-%%VERSION%%.so.1
+bin/libnet-config
+include/libnet.h
+include/libnet/libnet-asn1.h
+include/libnet/libnet-functions.h
+include/libnet/libnet-headers.h
+include/libnet/libnet-macros.h
+include/libnet/libnet-structures.h
+include/libnet/libnet-types.h
+lib/libnet.a
+lib/libnet.so
+lib/libnet.so.1
+lib/libnet.so.1.7.0
man/man3/libnet-functions.h.3.gz
man/man3/libnet-macros.h.3.gz
man/man3/libnet.h.3.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/DESIGN_NOTES
%%PORTDOCS%%%%DOCSDIR%%/MIGRATION
%%PORTDOCS%%%%DOCSDIR%%/PACKET_BUILDING
diff --git a/net/libnids-libnet11/Makefile b/net/libnids-libnet11/Makefile
deleted file mode 100644
index 30a92b7871d7..000000000000
--- a/net/libnids-libnet11/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PKGNAMESUFFIX= -libnet11
-
-COMMENT= Network monitoring library with TCP/IP reassembly using libnet11
-
-MASTERDIR= ${.CURDIR}/../libnids
-
-DESCR= ${.CURDIR}/pkg-descr
-
-WITH_LIBNET11= yes
-
-CONFLICTS?= libnids-[0-9]*
-
-DISTINFO_FILE= ${MASTERDIR}/distinfo
-
-.include "${MASTERDIR}/Makefile"
diff --git a/net/libnids-libnet11/pkg-descr b/net/libnids-libnet11/pkg-descr
deleted file mode 100644
index d82ad8ad56e0..000000000000
--- a/net/libnids-libnet11/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-Libnids is a library that provides the function of one of the NIDS
-(Network Intrusion Detection System) components, namely E-component. The
-libnids code watches all local network traffic, processes received
-datagrams a bit, and provides convenient information on them to analyzing
-modules. Libnids performs:
-
-a) assembly of TCP segments into TCP streams
-b) IP defragmentation
-c) TCP port scan detection
-
-This slave port builds with libnet11 by default.
-
-WWW: http://libnids.sf.net
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index e8ee0399d5c4..6439876b3516 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -14,8 +14,6 @@ LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
LICENSE= GPLv2
-CONFLICTS?= libnids-libnet11-[0-9]*
-
OPTIONS_DEFINE= GLIB2 DOCS
OPTIONS_DEFAULT=GLIB2
GLIB2_DESC= Use GLIB2 for multiprocessing support
@@ -27,14 +25,6 @@ GLIB2_CONFIGURE_ENABLE= libglib
USES= pkgconfig
GNU_CONFIGURE= yes
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-post-patch:
- @${REINPLACE_CMD} -Ee \
- 's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
- s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
do-install:
${INSTALL_DATA} ${WRKSRC}/src/nids.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/src/libnids.a ${STAGEDIR}${PREFIX}/lib
diff --git a/net/nast/Makefile b/net/nast/Makefile
index 3227e8ddfc79..350476b49ae6 100644
--- a/net/nast/Makefile
+++ b/net/nast/Makefile
@@ -20,18 +20,11 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/nast man/man8/nast.8.gz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-.include <bsd.port.pre.mk>
-
post-patch:
- @${REINPLACE_CMD} -e \
- 's|libnet-config|${LIBNET_CONFIG}|; \
- s|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/nast/files/patch-configure b/net/nast/files/patch-configure
index 65a061a223c8..8eb0e27eb7cd 100644
--- a/net/nast/files/patch-configure
+++ b/net/nast/files/patch-configure
@@ -1,61 +1,42 @@
--- configure.orig 2004-01-20 18:54:58 UTC
+++ configure
-@@ -2337,52 +2337,8 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
- #
+@@ -2379,7 +2379,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libnet_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libnet_a" >&6
+ if test $ac_cv_file__usr_local_lib_libnet_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
+
+ fi
+@@ -2530,7 +2530,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libpcap_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libpcap_a" >&6
+ if test $ac_cv_file__usr_local_lib_libpcap_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
- filechk="yes"
--echo "$as_me:$LINENO: checking for /usr/lib/libnet.a" >&5
--echo $ECHO_N "checking for /usr/lib/libnet.a... $ECHO_C" >&6
--if test "${ac_cv_file__usr_lib_libnet_a+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- test "$cross_compiling" = yes &&
-- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-- { (exit 1); exit 1; }; }
--if test -r "/usr/lib/libnet.a"; then
-- ac_cv_file__usr_lib_libnet_a=yes
--else
-- ac_cv_file__usr_lib_libnet_a=no
--fi
--fi
--echo "$as_me:$LINENO: result: $ac_cv_file__usr_lib_libnet_a" >&5
--echo "${ECHO_T}$ac_cv_file__usr_lib_libnet_a" >&6
--if test $ac_cv_file__usr_lib_libnet_a = yes; then
-- :
--else
-- filechk="no"
--fi
--
--if test "$filechk" = "no"; then
-- echo "$as_me:$LINENO: checking for /usr/local/lib/libnet.a" >&5
--echo $ECHO_N "checking for /usr/local/lib/libnet.a... $ECHO_C" >&6
--if test "${ac_cv_file__usr_local_lib_libnet_a+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- test "$cross_compiling" = yes &&
-- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-- { (exit 1); exit 1; }; }
--if test -r "/usr/local/lib/libnet.a"; then
-- ac_cv_file__usr_local_lib_libnet_a=yes
--else
-- ac_cv_file__usr_local_lib_libnet_a=no
--fi
--fi
--echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libnet_a" >&5
--echo "${ECHO_T}$ac_cv_file__usr_local_lib_libnet_a" >&6
--if test $ac_cv_file__usr_local_lib_libnet_a = yes; then
+ fi
+@@ -2680,7 +2680,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libncurses_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libncurses_a" >&6
+ if test $ac_cv_file__usr_local_lib_libncurses_a = yes; then
- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
--fi
--
--fi
-+CPPFLAGS="${CPPFLAGS} `libnet-config --cflags`"
-+LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
- if test "$filechk" = "no"; then { { echo "$as_me:$LINENO: error:
+ fi
+@@ -2840,7 +2840,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libmenu_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libmenu_a" >&6
+ if test $ac_cv_file__usr_local_lib_libmenu_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
-@@ -3045,8 +3001,8 @@ fi
+ fi
+@@ -3045,8 +3045,8 @@ fi
CFLAGS="-Wall -O2"
;;
diff --git a/net/netwib/Makefile b/net/netwib/Makefile
index 50637e9263e0..5a8046c6962f 100644
--- a/net/netwib/Makefile
+++ b/net/netwib/Makefile
@@ -21,21 +21,16 @@ SHORTPORTVERSION=${PORTVERSION:C/([0-9]*)\.([0-9]*)\.[0-9]*/\1\2/}
PLIST_SUB+= SHORTPORTVERSION=${SHORTPORTVERSION}
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
post-patch:
- @${REINPLACE_CMD} -Ee \
- 's|libnet-config|${LIBNET_CONFIG}|; \
- s|-lnet|`${LIBNET_CONFIG} --libs`|; \
- s|^(gccIncLnet=).*|\1"`${LIBNET_CONFIG} --cflags`"|' \
- ${WRKSRC}/genemake
-
-do-configure:
- @${REINPLACE_CMD} \
+ @${REINPLACE_CMD} '/^gccIncLnet=/s/=""/=`libnet-config --cflags`/' \
+ ${WRKSRC}/genemake
+ @${REINPLACE_CMD} \
-e 's|%%PREFIX%%|${PREFIX}|' \
-e 's|%%CFLAGS%%|${CFLAGS}|' \
-e 's|gcc|${CC}|' \
${WRKSRC}/config.dat
- (cd ${WRKSRC} ; ${SH} ${WRKSRC}/genemake )
+
+do-configure:
+ (cd ${WRKSRC} && ${SH} genemake)
.include <bsd.port.mk>
diff --git a/net/py-libnet/Makefile b/net/py-libnet/Makefile
index 91dfcaa3f65a..33787320f076 100644
--- a/net/py-libnet/Makefile
+++ b/net/py-libnet/Makefile
@@ -28,6 +28,9 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE= EXAMPLES
OSVER= uname -r
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/setup.py
+
do-install:
${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
${INSTALL_LIB} \
diff --git a/net/py-libnet/files/patch-setup.py b/net/py-libnet/files/patch-setup.py
deleted file mode 100644
index e4d8d0fc4963..000000000000
--- a/net/py-libnet/files/patch-setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./setup.py.orig 2011-08-02 17:53:25.000000000 +0200
-+++ ./setup.py 2014-05-30 12:55:01.000000000 +0200
-@@ -5,8 +5,8 @@
- import os
- import sys
-
--include_dir = None
--lib_dir = None
-+include_dir = '/usr/local/include/libnet11/'
-+lib_dir = '/usr/local/lib/libnet11'
-
-
- package_version = '3.0-beta-rc1'
diff --git a/net/pynids/Makefile b/net/pynids/Makefile
index 6169510af204..d612932d7288 100644
--- a/net/pynids/Makefile
+++ b/net/pynids/Makefile
@@ -12,22 +12,12 @@ DIST_SUBDIR= python
MAINTAINER= corsmith@gmail.com
COMMENT= Python interface to libnids
-PATCH_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USES= pkgconfig python
USE_GNOME= glib20
USE_PYTHON= distutils autoplist pythonprefix
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-.include <bsd.port.pre.mk>
-
-.if exists(${LIBNET_CONFIG})
-LIBNET_CFLAGS!= ${LIBNET_CONFIG} --cflags
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.endif
-
post-extract:
@cd ${WRKSRC} && ${TAR} xzf libnids-1.24.tar.gz
@@ -36,14 +26,6 @@ post-patch:
@${CHMOD} a+rx ${WRKSRC}/config.guess
@${CP} -f ${TEMPLATES}/config.sub ${WRKSRC}
@${CHMOD} a+rx ${WRKSRC}/config.sub
- @${REINPLACE_CMD} -e \
- "s|/usr/local/include|${PREFIX}/include', '${LIBNET_CFLAGS:S/-I//}|; \
- s|/usr/local/lib|${PREFIX}/lib', '${LIBNET_LIBS:N-l*:S/-L//}|" \
- ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -Ee \
- 's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` ${LIBNET_CFLAGS}"|; \
- s|(LNETLIB=).*|\1"${LIBNET_LIBS} -L${LOCALBASE}/lib"|; \
- s|gcc|${CC}|' \
- ${WRKSRC}/libnids-1.24/configure
+ @${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/setup.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/rtpbreak/Makefile b/net/rtpbreak/Makefile
index e75245e6faf0..4c745b098a40 100644
--- a/net/rtpbreak/Makefile
+++ b/net/rtpbreak/Makefile
@@ -13,8 +13,8 @@ COMMENT= Detects, reconstructs, and analyzes any RTP session
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-CFLAGS+= -I${LOCALBASE}/include/libnet11
-LIBS+= -L${LOCALBASE}/lib/libnet11 -lpcap -lnet
+CFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lpcap -lnet
MAKE_ARGS= CFLAGS="${CFLAGS}" LIBS="${LIBS}"
diff --git a/net/tcptraceroute-devel/Makefile b/net/tcptraceroute-devel/Makefile
index f541a1189f49..9925f2297051 100644
--- a/net/tcptraceroute-devel/Makefile
+++ b/net/tcptraceroute-devel/Makefile
@@ -25,9 +25,7 @@ OPTIONS_DEFINE= DOCS
USES= gmake
GNU_CONFIGURE= yes
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-CONFIGURE_ARGS= --with-libpcap=/usr --bindir=${PREFIX}/sbin
+CONFIGURE_ARGS= --with-libnet=${LOCALBASE} --with-libpcap=/usr --bindir=${PREFIX}/sbin
post-install:
@${CHMOD} u+s ${STAGEDIR}${PREFIX}/sbin/tcptraceroute
diff --git a/net/tcptraceroute-devel/files/patch-configure b/net/tcptraceroute-devel/files/patch-configure
deleted file mode 100644
index 9fe536ac4aa0..000000000000
--- a/net/tcptraceroute-devel/files/patch-configure
+++ /dev/null
@@ -1,46 +0,0 @@
---- configure.old 2006-03-28 20:49:55.000000000 -0500
-+++ configure 2007-12-13 13:57:42.000000000 -0500
-@@ -3713,38 +3713,11 @@
-
- fi;
-
--LIBNET_CONFIG="libnet-config" # relative, using $PATH
--
--# Check whether --with-libnet or --without-libnet was given.
--if test "${with_libnet+set}" = set; then
-- withval="$with_libnet"
--
-- LIBNETCC=""
-- LIBNETLD=""
--
-- test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
-- test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
--
-- test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
-- test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
--
-- test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
-- test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
--
-- if test -z "$LIBNETCC" -o -z "$LIBNETLD"
-- then
-- { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
--echo "$as_me: error: No valid libnet library found in $withval" >&2;}
-- { (exit 1); exit 1; }; }
-- else
-- CPPFLAGS="$CPPFLAGS $LIBNETCC"
-- LDFLAGS="$LDFLAGS $LIBNETLD"
-- { echo "$as_me:$LINENO: using libnet in $withval" >&5
--echo "$as_me: using libnet in $withval" >&6;}
-- fi
--
--fi;
--
-+LIBNET_CONFIG="libnet11-config" # relative, using $PATH
-+LIBNETCC=`$LIBNET_CONFIG --cflags`
-+LIBNETLD=`$LIBNET_CONFIG --libs`
-+CPPFLAGS="$CPPFLAGS $LIBNETCC"
-+LDFLAGS="$LDFLAGS $LIBNETLD"
-
- echo "$as_me:$LINENO: checking for pcap_open_live in -lpcap" >&5
- echo $ECHO_N "checking for pcap_open_live in -lpcap... $ECHO_C" >&6
diff --git a/net/tcptraceroute/Makefile b/net/tcptraceroute/Makefile
index f8e1f706c478..5c27ea44806c 100644
--- a/net/tcptraceroute/Makefile
+++ b/net/tcptraceroute/Makefile
@@ -19,6 +19,7 @@ OPTIONS_DEFINE= DOCS
PORTSCOUT= limit:^[0-9]
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
USES= gmake
PORTDOCS= *
diff --git a/net/tcptraceroute/files/patch-configure b/net/tcptraceroute/files/patch-configure
deleted file mode 100644
index c37e709d1063..000000000000
--- a/net/tcptraceroute/files/patch-configure
+++ /dev/null
@@ -1,73 +0,0 @@
---- configure.orig 2006-03-28 13:00:00.000000000 +0800
-+++ configure 2014-09-10 00:44:22.750008451 +0800
-@@ -3713,37 +3713,39 @@
-
- fi;
-
--LIBNET_CONFIG="libnet-config" # relative, using $PATH
--
--# Check whether --with-libnet or --without-libnet was given.
--if test "${with_libnet+set}" = set; then
-- withval="$with_libnet"
--
-- LIBNETCC=""
-- LIBNETLD=""
--
-- test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
-- test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
--
-- test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
-- test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
--
-- test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
-- test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
--
-- if test -z "$LIBNETCC" -o -z "$LIBNETLD"
-- then
-- { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
--echo "$as_me: error: No valid libnet library found in $withval" >&2;}
-- { (exit 1); exit 1; }; }
-- else
-- CPPFLAGS="$CPPFLAGS $LIBNETCC"
-- LDFLAGS="$LDFLAGS $LIBNETLD"
-- { echo "$as_me:$LINENO: using libnet in $withval" >&5
--echo "$as_me: using libnet in $withval" >&6;}
-- fi
--
--fi;
-+LIBNET_CONFIG="libnet11-config" # relative, using $PATH
-+CPPFLAGS="$CPPFLAGS $(${LIBNET_CONFIG} --cflags)"
-+LDFLAGS="$LDFLAGS $(${LIBNET_CONFIG} --libs)"
-+
-+## Check whether --with-libnet or --without-libnet was given.
-+#if test "${with_libnet+set}" = set; then
-+# withval="$with_libnet"
-+#
-+# LIBNETCC=""
-+# LIBNETLD=""
-+#
-+# test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
-+# test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
-+#
-+# test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
-+# test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
-+#
-+# test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
-+# test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
-+#
-+# if test -z "$LIBNETCC" -o -z "$LIBNETLD"
-+# then
-+# { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
-+#echo "$as_me: error: No valid libnet library found in $withval" >&2;}
-+# { (exit 1); exit 1; }; }
-+# else
-+# CPPFLAGS="$CPPFLAGS $LIBNETCC"
-+# LDFLAGS="$LDFLAGS $LIBNETLD"
-+# { echo "$as_me:$LINENO: using libnet in $withval" >&5
-+#echo "$as_me: using libnet in $withval" >&6;}
-+# fi
-+#
-+#fi;
-
-
- echo "$as_me:$LINENO: checking for pcap_open_live in -lpcap" >&5
diff --git a/net/vortex/Makefile b/net/vortex/Makefile
index d6eff948cf7e..2865fd9d33a3 100644
--- a/net/vortex/Makefile
+++ b/net/vortex/Makefile
@@ -12,17 +12,15 @@ COMMENT= Network surveillance engine
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids-libnet11
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
-
WRKSRC= ${WRKDIR}/${PORTNAME}-2.9.0
USE_GNOME= glib20
do-build:
cd ${WRKSRC} && ${CC} -c vortex.c -I${LOCALBASE}/include
- cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a `${LIBNET_CONFIG} --libs` -lglib-2.0 -lgthread-2.0 -lpcap -pthread
+ cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a -lnet -lglib-2.0 -lgthread-2.0 -lpcap -pthread
cd ${WRKSRC} && ${CC} -o xpipes xpipes.c -pthread
do-install: