aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-03-06 00:17:53 +0800
committernetchild <netchild@FreeBSD.org>2006-03-06 00:17:53 +0800
commita2f0dd988a5d70c6063a9c669bcb50a0399301e3 (patch)
treecf2525bd60b3a643d0217ce14f1355aaeac159aa /net
parent5155634d2f20f47960d920d7007922d3a798f559 (diff)
downloadfreebsd-ports-gnome-a2f0dd988a5d70c6063a9c669bcb50a0399301e3.tar.gz
freebsd-ports-gnome-a2f0dd988a5d70c6063a9c669bcb50a0399301e3.tar.zst
freebsd-ports-gnome-a2f0dd988a5d70c6063a9c669bcb50a0399301e3.zip
Fix the amd64 build (and perhaps other arches which need -fPIC).
Maintainer informed. Tested on: amd64 tinderbox Approved by: portmgr (linnimon)
Diffstat (limited to 'net')
-rw-r--r--net/opal/Makefile10
-rw-r--r--net/opal3/Makefile10
-rw-r--r--net/openh323/Makefile10
3 files changed, 24 insertions, 6 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 6dafd32d2e6d..10517f59056f 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -27,9 +27,15 @@ USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
NO_FILTER_SHLIBS= yes
ALL_TARGET= optshared
MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 6dafd32d2e6d..10517f59056f 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -27,9 +27,15 @@ USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
NO_FILTER_SHLIBS= yes
ALL_TARGET= optshared
MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index 6dafd32d2e6d..10517f59056f 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -27,9 +27,15 @@ USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
NO_FILTER_SHLIBS= yes
ALL_TARGET= optshared
MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>