aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-02 06:30:35 +0800
committermiwi <miwi@FreeBSD.org>2007-02-02 06:30:35 +0800
commita6199ef37d70d6b0d63abee3733339137a03d3cc (patch)
treec272bc1c360e0c714ff6effdb9f40c429d1624b1 /net
parentd14be5c8a1004eb35c07ea6b6fbcc626baf8c74b (diff)
downloadfreebsd-ports-gnome-a6199ef37d70d6b0d63abee3733339137a03d3cc.tar.gz
freebsd-ports-gnome-a6199ef37d70d6b0d63abee3733339137a03d3cc.tar.zst
freebsd-ports-gnome-a6199ef37d70d6b0d63abee3733339137a03d3cc.zip
sipXconfig is the web based configuration system for sipX.
WWW: http://sipx-wiki.calivia.com/index.php/Main_Page PR: ports/107931 Submitted by: Michael Durian <durian at shadetreesoftware.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sipxconfig/Makefile51
-rw-r--r--net/sipxconfig/distinfo3
-rw-r--r--net/sipxconfig/files/patch-build.properties.in11
-rw-r--r--net/sipxconfig/files/patch-configure38
-rw-r--r--net/sipxconfig/files/patch-meta_hibernate.properties8
-rw-r--r--net/sipxconfig/files/patch-neoconf_build.xml10
-rw-r--r--net/sipxconfig/files/patch-neoconf_etc_database_database.xml11
-rw-r--r--net/sipxconfig/files/patch-neoconf_src_org_sipfoundry_sipxconfig_system.beans.xml11
-rw-r--r--net/sipxconfig/files/patch-web_bin_create-ssl-keystore.sh.in22
-rw-r--r--net/sipxconfig/files/patch-web_bin_create-ssl-truststore.sh.in16
-rw-r--r--net/sipxconfig/files/patch-web_bin_sipxconfig-testsuite13
-rw-r--r--net/sipxconfig/files/patch-web_bin_sipxconfig.sh.in98
-rw-r--r--net/sipxconfig/files/pkg-deinstall.in19
-rw-r--r--net/sipxconfig/pkg-descr3
-rw-r--r--net/sipxconfig/pkg-plist186
16 files changed, 501 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a27e3bcca900..f91bbc6c5bc1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -745,6 +745,7 @@
SUBDIR += siproxd
SUBDIR += sipsak
SUBDIR += sipxcommserverlib
+ SUBDIR += sipxconfig
SUBDIR += sipxportlib
SUBDIR += sipxtacklib
SUBDIR += sixxs-aiccu
diff --git a/net/sipxconfig/Makefile b/net/sipxconfig/Makefile
new file mode 100644
index 000000000000..43f1264bf10f
--- /dev/null
+++ b/net/sipxconfig/Makefile
@@ -0,0 +1,51 @@
+# Ports collection makefile for: sipxconfig
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxconfig
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for configuring sipX via a web interface
+
+BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant \
+ ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
+ gem:${PORTSDIR}/devel/ruby-gems \
+ rake:${PORTSDIR}/devel/rubygem-rake \
+ zip:${PORTSDIR}/archivers/zip \
+ ginstall:${PORTSDIR}/sysutils/coreutils
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXcommserver:${PORTSDIR}/net/sipxcommserverlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ psql:${PORTSDIR}/databases/postgresql81-client
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+USE_JAVA= 1.4+
+USE_APACHE= 2.0+
+USE_RUBY= yes
+GNU_CONFIGURE= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME} \
+ wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR} \
+ --enable-ruby-bindings
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/web/bin/sipxconfig.sh.in
+ @${REINPLACE_CMD} -e "s,@PREFIX@,${PREFIX}," ${WRKSRC}/web/bin/sipxconfig.sh.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxconfig/distinfo b/net/sipxconfig/distinfo
new file mode 100644
index 000000000000..26cf8d24859f
--- /dev/null
+++ b/net/sipxconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxconfig-3.6.0.tar.bz2) = 389182f2760c20af7dfa5795e306e412
+SHA256 (sipxconfig-3.6.0.tar.bz2) = 1b7339b6d25e60a5a3e62902ddd5135458a1079bb38d595cfc60adca25e87621
+SIZE (sipxconfig-3.6.0.tar.bz2) = 22530876
diff --git a/net/sipxconfig/files/patch-build.properties.in b/net/sipxconfig/files/patch-build.properties.in
new file mode 100644
index 000000000000..a5cf535db7af
--- /dev/null
+++ b/net/sipxconfig/files/patch-build.properties.in
@@ -0,0 +1,11 @@
+--- ./build.properties.in.orig Wed Jan 3 13:45:59 2007
++++ ./build.properties.in Wed Jan 3 13:46:08 2007
+@@ -28,7 +28,7 @@
+ sipxpbx.user=@SIPXPBXUSER@
+
+ sipxconfig.db.pds=SIPXCONFIG_TEST
+-sipxconfig.db.user=postgres
++sipxconfig.db.user=pgsql
+ sipxpbx.log.dir=@SIPX_LOGDIR@
+ sipxpbx.run.dir=@SIPX_RUNDIR@
+ sipxpbx.tmp.dir=@SIPX_TMPDIR@
diff --git a/net/sipxconfig/files/patch-configure b/net/sipxconfig/files/patch-configure
new file mode 100644
index 000000000000..72bf56b101ef
--- /dev/null
+++ b/net/sipxconfig/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig Tue Jan 9 15:13:38 2007
++++ configure Tue Jan 9 15:14:11 2007
+@@ -2976,7 +2976,7 @@
+ fi
+
+
+- if test "x$RUBY" == "x" ; then
++ if test "x$RUBY" = "x" ; then
+ { { echo "$as_me:$LINENO: error: ruby is required" >&5
+ echo "$as_me: error: ruby is required" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -3085,7 +3085,7 @@
+
+
+ minGemVersion=0.8.11
+- if test "x$GEM" == "x" ; then
++ if test "x$GEM" = "x" ; then
+ echo "$as_me:$LINENO: result: * to install ruby gems follow your distro instructions, " >&5
+ echo "${ECHO_T}* to install ruby gems follow your distro instructions, " >&6
+ echo "$as_me:$LINENO: result: * locate the rpm on pbone or run the following commands: " >&5
+@@ -3186,7 +3186,7 @@
+ fi
+
+
+- if test "x$RAKE" == "x" ; then
++ if test "x$RAKE" = "x" ; then
+ { { echo "$as_me:$LINENO: error: rake is required. type 'gem install rake --no-rdoc'" >&5
+ echo "$as_me: error: rake is required. type 'gem install rake --no-rdoc'" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -3239,7 +3239,7 @@
+ # CHECK_RUBY_GEM([file-tail])
+
+
+-if test x$enable_ruby_binding == xyes ; then
++if test x$enable_ruby_binding = xyes ; then
+ RUBY_BINDINGS_ENABLED="ruby-bindings-enabled="
+
+ abs_srcdir=`cd $srcdir && pwd`
diff --git a/net/sipxconfig/files/patch-meta_hibernate.properties b/net/sipxconfig/files/patch-meta_hibernate.properties
new file mode 100644
index 000000000000..ed23ffa92929
--- /dev/null
+++ b/net/sipxconfig/files/patch-meta_hibernate.properties
@@ -0,0 +1,8 @@
+--- ./meta/hibernate.properties.orig Wed Jan 3 13:48:37 2007
++++ ./meta/hibernate.properties Wed Jan 3 13:48:45 2007
+@@ -3,4 +3,4 @@
+ hibernate.dialect org.hibernate.dialect.PostgreSQLDialect
+ hibernate.connection.url jdbc:postgresql://localhost/SIPXCONFIG
+ hibernate.connection.driver_class org.postgresql.Driver
+-hibernate.connection.username postgres
++hibernate.connection.username pgsql
diff --git a/net/sipxconfig/files/patch-neoconf_build.xml b/net/sipxconfig/files/patch-neoconf_build.xml
new file mode 100644
index 000000000000..e19b8f3c21be
--- /dev/null
+++ b/net/sipxconfig/files/patch-neoconf_build.xml
@@ -0,0 +1,10 @@
+--- ./neoconf/build.xml.orig Wed Jan 3 13:56:01 2007
++++ ./neoconf/build.xml Wed Jan 3 13:56:07 2007
+@@ -1,6 +1,6 @@
+ <project name="neoconf" default="default">
+ <property name="sipxconfig.db.pds" value="SIPXCONFIG_TEST" />
+- <property name="sipxconfig.db.user" value="postgres" />
++ <property name="sipxconfig.db.user" value="pgsql" />
+
+ <property name="test.src.dir" value="test" />
+ <property name="checkstyle.severity" value="error" />
diff --git a/net/sipxconfig/files/patch-neoconf_etc_database_database.xml b/net/sipxconfig/files/patch-neoconf_etc_database_database.xml
new file mode 100644
index 000000000000..d4c15e0f4a1e
--- /dev/null
+++ b/net/sipxconfig/files/patch-neoconf_etc_database_database.xml
@@ -0,0 +1,11 @@
+--- ./neoconf/etc/database/database.xml.orig Mon Jan 1 16:22:08 2007
++++ ./neoconf/etc/database/database.xml Mon Jan 1 16:22:15 2007
+@@ -18,7 +18,7 @@
+ -->
+ <project name="database" basedir=".">
+ <property name="sipxconfig.db.name" value="SIPXCONFIG"/>
+- <property name="sipxconfig.db.user" value="postgres"/>
++ <property name="sipxconfig.db.user" value="pgsql"/>
+ <property name="sipxconfig.db.password" value=""/>
+ <property name="sql.dir" location="${basedir}"/>
+ <property name="sipxpbx.conf.dir" location="${basedir}/.."/>
diff --git a/net/sipxconfig/files/patch-neoconf_src_org_sipfoundry_sipxconfig_system.beans.xml b/net/sipxconfig/files/patch-neoconf_src_org_sipfoundry_sipxconfig_system.beans.xml
new file mode 100644
index 000000000000..21e3b15ef87c
--- /dev/null
+++ b/net/sipxconfig/files/patch-neoconf_src_org_sipfoundry_sipxconfig_system.beans.xml
@@ -0,0 +1,11 @@
+--- ./neoconf/src/org/sipfoundry/sipxconfig/system.beans.xml.orig Wed Jan 3 13:50:37 2007
++++ ./neoconf/src/org/sipfoundry/sipxconfig/system.beans.xml Wed Jan 3 13:50:58 2007
+@@ -47,7 +47,7 @@
+ <value>jdbc:postgresql://localhost/SIPXCONFIG</value>
+ </property>
+ <property name="user">
+- <value>postgres</value>
++ <value>pgsql</value>
+ </property>
+ <!-- Determines how many connections at a time c3p0 will try to acquire when the pool
+ is exhausted. Default: 3.
diff --git a/net/sipxconfig/files/patch-web_bin_create-ssl-keystore.sh.in b/net/sipxconfig/files/patch-web_bin_create-ssl-keystore.sh.in
new file mode 100644
index 000000000000..1cffc3e8454e
--- /dev/null
+++ b/net/sipxconfig/files/patch-web_bin_create-ssl-keystore.sh.in
@@ -0,0 +1,22 @@
+--- ./web/bin/create-ssl-keystore.sh.in.orig Thu Jan 4 16:15:06 2007
++++ ./web/bin/create-ssl-keystore.sh.in Thu Jan 4 16:26:01 2007
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/usr/local/bin/bash
+ ##
+ ## create-ssl-keystore.sh
+ ##
+@@ -21,11 +21,11 @@
+ PreviousChecksum=""
+ openssl="@openssl@"
+
+-Checksum=`cat $Certificate $Key | md5sum | awk '{print $1}'`
++Checksum=`cat $Certificate $Key | /sbin/md5 -r | awk '{print $1}'`
+ if [ -f $KeyStoreFilesChecksum ]; then
+ if [ -f $KeyStore ]; then
+ PreviousChecksum=`cat $KeyStoreFilesChecksum`
+- if [ "$Checksum" == "$PreviousChecksum" ]; then
++ if [ "x$Checksum" = "x$PreviousChecksum" ]; then
+ echo "Creating $KeyStore was skipped, previous checksum of contents matched"
+ exit 0;
+ fi
diff --git a/net/sipxconfig/files/patch-web_bin_create-ssl-truststore.sh.in b/net/sipxconfig/files/patch-web_bin_create-ssl-truststore.sh.in
new file mode 100644
index 000000000000..8cc244ab7015
--- /dev/null
+++ b/net/sipxconfig/files/patch-web_bin_create-ssl-truststore.sh.in
@@ -0,0 +1,16 @@
+--- web/bin/create-ssl-truststore.sh.in.orig Wed Jan 10 16:47:47 2007
++++ web/bin/create-ssl-truststore.sh.in Wed Jan 10 16:48:36 2007
+@@ -83,11 +83,11 @@
+ fi
+
+ if [ "${Action}" = "CHECKSUM" ]; then
+- Checksum=`cat $Certificates | md5sum | awk '{print $1}'`
++ Checksum=`cat $Certificates | md5 -r | awk '{print $1}'`
+ if [ -f $CertificatesChecksum ]; then
+ if [ -f $TrustStore ]; then
+ PreviousChecksum=`cat $CertificatesChecksum`
+- if [ $Checksum == $PreviousChecksum ]; then
++ if [ "x$Checksum" = "x$PreviousChecksum" ]; then
+ echo "Creating $TrustStore was skipped, previous checksum of contents matched"
+ exit 0;
+ fi
diff --git a/net/sipxconfig/files/patch-web_bin_sipxconfig-testsuite b/net/sipxconfig/files/patch-web_bin_sipxconfig-testsuite
new file mode 100644
index 000000000000..44c39eceed2f
--- /dev/null
+++ b/net/sipxconfig/files/patch-web_bin_sipxconfig-testsuite
@@ -0,0 +1,13 @@
+--- ./web/bin/sipxconfig-testsuite.orig Wed Jan 3 13:46:42 2007
++++ ./web/bin/sipxconfig-testsuite Wed Jan 3 13:47:37 2007
+@@ -78,8 +78,8 @@
+ Expected=`cat <<EOF
+ /etc/init.d/postgresql stop
+ su - postgres -c initdb --pgdata=$PGDATA
+-chown postgres:postgres $PGDATA/postgresql.conf
+-chown postgres:postgres $PGDATA/postmaster.opts.default
++chown pgsql:pgsql $PGDATA/postgresql.conf
++chown pgsql:pgsql $PGDATA/postmaster.opts.default
+ /etc/init.d/postgresql start
+ EOF
+ `
diff --git a/net/sipxconfig/files/patch-web_bin_sipxconfig.sh.in b/net/sipxconfig/files/patch-web_bin_sipxconfig.sh.in
new file mode 100644
index 000000000000..0f3d47f4f809
--- /dev/null
+++ b/net/sipxconfig/files/patch-web_bin_sipxconfig.sh.in
@@ -0,0 +1,98 @@
+--- web/bin/sipxconfig.sh.in.orig Mon Jan 1 14:57:05 2007
++++ web/bin/sipxconfig.sh.in Tue Jan 9 14:48:22 2007
+@@ -23,7 +23,7 @@
+ : ${DatabaseProject:=@sipxpbx.conf.dir@/database/database.xml}
+ : ${LibDir:=@sipxconfig.lib.dir@}
+ : ${Psql:=psql}
+-: ${ServiceDir:=/etc/init.d}
++: ${ServiceDir:=/usr/local/etc/rc.d}
+ : ${SubstituteUser:=su}
+ : ${Chown:=chown}
+ : ${LogDir:=@sipxpbx.log.dir@}
+@@ -215,8 +215,8 @@
+ # 2. running but not setup to communicate w/java or ${Psql} command
+ # 3. Database is not created
+ databaseCheck() {
+- ${Psql} --list --field-separator , --no-align --username postgres \
+- | cut --delimiter , --fields 1 \
++ ${Psql} --list --field-separator , --no-align --username pgsql \
++ | cut -d , -f 1 \
+ | grep "${Database}" > /dev/null 2>&1
+ }
+
+@@ -225,7 +225,7 @@
+ databaseVersionCheck() {
+ dbver=`${Psql} --tuples-only --no-align \
+ --command "select max(vh.version) from version_history vh;" \
+- ${Database} postgres`
++ ${Database} pgsql`
+ if [ $? -ne 0 -o "$dbver" = "" ]
+ then
+ echo "Error: could not get the database version. Exiting now."
+@@ -263,7 +263,6 @@
+ then
+ echo "Initializing configuration database..."
+ postgresSetup
+- setPostgresRunlevels
+ databaseCommand create
+ echo -n "Configuration database initialized"
+ fi
+@@ -274,7 +273,7 @@
+ postgresSetup() {
+
+ # Set up the server.
+- Service=`postgresService`
++ Service=postgresql
+
+ # May not by running, so eat up error (ENG-314)
+ ${ServiceDir}/${Service} stop 2>&1 1> /dev/null
+@@ -282,21 +281,16 @@
+ # Custom
+ if test -z $PGDATA
+ then
+- # Debian/Gentoo
+- if test -d /var/lib/postgresql/data
+- then
+- PGDATA=/var/lib/postgresql/data
+- else
+- # Redhat
+- PGDATA=/var/lib/pgsql/data
+- fi
++ PGDATA=~pgsql/data
+ fi
+
+ # Postgres db is initialized on startup on Redhat, but not on other
+ # distros so unless we put a "if distro=rh" we need to init here
+ if [ ! -f $PGDATA/PG_VERSION ] || [ ! -d $PGDATA/base ]
+ then
+- $SubstituteUser - postgres -c "initdb --pgdata=$PGDATA"
++ # XXX only works if user has added postgresql_enable="YES" to
++ # an rc.conf file.
++ sh @PREFIX@/rc.d/postgresql initdb
+ fi
+
+ # Create backup file (possibly) requiring update
+@@ -324,19 +318,20 @@
+ fi
+
+ # Open up TCP/IP connections
+- sed -i-sipx.bak -e 's/\#tcpip_socket\s=\sfalse/tcpip_socket = true/g' \
++ gsed -i-sipx.bak -e 's/\#tcpip_socket\s=\sfalse/tcpip_socket = true/g' \
+ $PGDATA/postgresql.conf
+- ${Chown} postgres:postgres $PGDATA/postgresql.conf
++ ${Chown} pgsql:pgsql $PGDATA/postgresql.conf
+
+ # Postmaster to allow connections
+ echo "-i" > $PGDATA/postmaster.opts.default
+ chmod 664 $PGDATA/postmaster.opts.default
+- ${Chown} postgres:postgres $PGDATA/postmaster.opts.default
++ ${Chown} pgsql:pgsql $PGDATA/postmaster.opts.default
+
+ ${ServiceDir}/$Service start
+ }
+
+ # Have postgres start automatically with system reboot
++# XXX Don't worry, we don't call this under FreeBSD
+ setPostgresRunlevels() {
+ # Arrange for Postgres to be started automatically in runlevels 3
+ # and 5.
diff --git a/net/sipxconfig/files/pkg-deinstall.in b/net/sipxconfig/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a3eb20e33059
--- /dev/null
+++ b/net/sipxconfig/files/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin:/usr/bin:/usr/sbin
+
+LOCALSTATEDIR="%%LOCALSTATEDIR%%"
+
+post-deinstall() {
+ echo "WARNING: If you will *NOT* use this package anymore, please remove
+ the"
+ echo " following file manually:"
+ echo " ${LOCALSTATEDIR}/sipxdata/upgrade/sipxconfig-previous.tgz"
+ echo
+}
+
+case $2 in
+ POST-DEINSTALL)
+ post-deinstall
+ ;;
+esac
diff --git a/net/sipxconfig/pkg-descr b/net/sipxconfig/pkg-descr
new file mode 100644
index 000000000000..d5bc1deed7e6
--- /dev/null
+++ b/net/sipxconfig/pkg-descr
@@ -0,0 +1,3 @@
+sipXconfig is the web based configuration system for sipX.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxconfig/pkg-plist b/net/sipxconfig/pkg-plist
new file mode 100644
index 000000000000..cc5a9ea8627f
--- /dev/null
+++ b/net/sipxconfig/pkg-plist
@@ -0,0 +1,186 @@
+bin/sipxconfig-agent
+bin/sipxconfig-config
+bin/sipxconfig.sh
+bin/ssl-cert/create-ssl-keystore.sh
+bin/ssl-cert/create-ssl-truststore.sh
+etc/sipxpbx/VM_global_library.vm
+etc/sipxpbx/acme/acme-gateway.vm
+etc/sipxpbx/acme/acme-gateway.xml
+etc/sipxpbx/audiocodes/MP108FXOProxy.ini
+etc/sipxpbx/audiocodes/TP260.ini
+etc/sipxpbx/audiocodes/mediant-gateway.xml
+etc/sipxpbx/audiocodes/tp260-gateway.xml
+etc/sipxpbx/ciscoAta/ata-ptag.dat
+etc/sipxpbx/ciscoAta/gk-ptag.dat
+etc/sipxpbx/ciscoAta/ld-ptag.dat
+etc/sipxpbx/ciscoAta/line.xml
+etc/sipxpbx/ciscoAta/phone.xml
+etc/sipxpbx/ciscoAta/types.xml
+etc/sipxpbx/ciscoIp/cisco-ip.vm
+etc/sipxpbx/ciscoIp/line.xml
+etc/sipxpbx/ciscoIp/phone.xml
+etc/sipxpbx/ciscoIp/upload.xml
+etc/sipxpbx/commserver/forwardingrules.vm
+etc/sipxpbx/commserver/server.xml
+etc/sipxpbx/database/attendant_schedule.sql
+etc/sipxpbx/database/attendant_settings.sql
+etc/sipxpbx/database/caller-alias-2.sql
+etc/sipxpbx/database/caller-alias.sql
+etc/sipxpbx/database/database.xml
+etc/sipxpbx/database/database.xml.orig
+etc/sipxpbx/database/domain.sql
+etc/sipxpbx/database/grandstreamV2.sql
+etc/sipxpbx/database/intercom.sql
+etc/sipxpbx/database/ldap.sql
+etc/sipxpbx/database/long-distance-rule.sql
+etc/sipxpbx/database/migrate-2.8.sql
+etc/sipxpbx/database/park-orbit-settings.sql
+etc/sipxpbx/database/permission.sql
+etc/sipxpbx/database/schema-3.0.sql
+etc/sipxpbx/database/schema.sql
+etc/sipxpbx/database/settings-refactoring.sql
+etc/sipxpbx/database/supervisor.sql
+etc/sipxpbx/database/upload.sql
+etc/sipxpbx/database/upload_deployed.sql
+etc/sipxpbx/dialplan/ch.dialrules.beans.xml
+etc/sipxpbx/dialplan/de.dialrules.beans.xml
+etc/sipxpbx/dialplan/dialrules.beans.xml
+etc/sipxpbx/dialplan/pl.dialrules.beans.xml
+etc/sipxpbx/dialplan/us.dialrules.beans.xml
+etc/sipxpbx/grandstream/line.xml
+etc/sipxpbx/grandstream/phone.xml
+etc/sipxpbx/grandstream/types.xml
+etc/sipxpbx/hitachi/line.xml
+etc/sipxpbx/hitachi/loadrun.ini
+etc/sipxpbx/hitachi/phone.xml
+etc/sipxpbx/hitachi/types.xml
+etc/sipxpbx/hitachi/user.ini.vm
+etc/sipxpbx/kphone/kphonerc.vm
+etc/sipxpbx/kphone/line.xml
+etc/sipxpbx/kphone/phone.xml
+etc/sipxpbx/log4j.properties
+etc/sipxpbx/polycom/line.xml
+etc/sipxpbx/polycom/mac-address.cfg.vm
+etc/sipxpbx/polycom/mac-address.d/phone.cfg.vm
+etc/sipxpbx/polycom/mac-address.d/sip-1.6.cfg.vm
+etc/sipxpbx/polycom/mac-address.d/sip-2.0.cfg.vm
+etc/sipxpbx/polycom/phone.xml
+etc/sipxpbx/polycom/types.xml
+etc/sipxpbx/polycom/upload.xml
+etc/sipxpbx/process.d/sipxconfig.process.xml
+etc/sipxpbx/setting.dtd
+etc/sipxpbx/setting.xsl
+etc/sipxpbx/sipxconference/bridge.xml
+etc/sipxpbx/sipxconference/conference.xml
+etc/sipxpbx/sipxconfig-jetty.xml
+etc/sipxpbx/sipxconfig.properties.in
+etc/sipxpbx/sipxpark/park-orbit.xml
+etc/sipxpbx/sipxvxml/autoattendant.vm
+etc/sipxpbx/sipxvxml/autoattendant.xml
+etc/sipxpbx/snom/line.xml
+etc/sipxpbx/snom/phone.xml
+etc/sipxpbx/snom/snom.vm
+etc/sipxpbx/snom/types.xml
+etc/sipxpbx/topology.xml.in
+etc/sipxpbx/unmanagedPhone/line.xml
+etc/sipxpbx/unmanagedPhone/phone.xml
+etc/sipxpbx/unmanagedPhone/upload.xml
+etc/sipxpbx/user-settings.xml
+lib/ruby/gems/1.8/cache/sipXconfig-agent-1.0.0.gem
+lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/bin/sipxconfig-agent.in
+lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/lib/main.rb
+lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/lib/server.rb
+lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/lib/sipxconfig-agent.wsdl
+lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/tests/server_test.rb
+lib/ruby/gems/1.8/specifications/sipXconfig-agent-1.0.0.gemspec
+share/sipxpbx/lib/acegi-security-1.0.0-RC1.jar
+share/sipxpbx/lib/activation-1.0.2.jar
+share/sipxpbx/lib/agent-bindings.jar
+share/sipxpbx/lib/ant-1.6.5.jar
+share/sipxpbx/lib/ant-launcher-1.6.5.jar
+share/sipxpbx/lib/antlr-2.7.5H3.jar
+share/sipxpbx/lib/aopalliance-1.0.jar
+share/sipxpbx/lib/asm-1.5.3.jar
+share/sipxpbx/lib/axis-1.3.jar
+share/sipxpbx/lib/axis-schema-1.3.jar
+share/sipxpbx/lib/bsf-2.3.0.jar
+share/sipxpbx/lib/c3p0-0.9.0.2.jar
+share/sipxpbx/lib/cglib-2.1.2.jar
+share/sipxpbx/lib/commons-beanutils-1.7.0.jar
+share/sipxpbx/lib/commons-codec-1.3.jar
+share/sipxpbx/lib/commons-collections-3.1.jar
+share/sipxpbx/lib/commons-digester-1.7.jar
+share/sipxpbx/lib/commons-discovery-0.2.jar
+share/sipxpbx/lib/commons-fileupload-1.1.1.jar
+share/sipxpbx/lib/commons-io-1.1.jar
+share/sipxpbx/lib/commons-lang-2.1.jar
+share/sipxpbx/lib/commons-logging-1.0.4.jar
+share/sipxpbx/lib/commons-pool-1.2.jar
+share/sipxpbx/lib/dom4j-1.6.1.jar
+share/sipxpbx/lib/ehcache-1.1.jar
+share/sipxpbx/lib/hibernate-3.1.3.jar
+share/sipxpbx/lib/hitachi-phones.jar
+share/sipxpbx/lib/hivemind-1.1.jar
+share/sipxpbx/lib/hivemind-lib-1.1.jar
+share/sipxpbx/lib/jakarta-oro-2.0.8.jar
+share/sipxpbx/lib/jasper-compiler-4.1.31.jar
+share/sipxpbx/lib/jasper-runtime-4.1.31.jar
+share/sipxpbx/lib/javamail-1.3.2.jar
+share/sipxpbx/lib/javassist-3.0.jar
+share/sipxpbx/lib/javax.servlet.jar
+share/sipxpbx/lib/javax.servlet.jsp.jar
+share/sipxpbx/lib/jaxen-full-1.0fcs.jar
+share/sipxpbx/lib/jaxrpc.jar
+share/sipxpbx/lib/jetty-5.1.4.jar
+share/sipxpbx/lib/jta.jar
+share/sipxpbx/lib/log4j-1.2.8.jar
+share/sipxpbx/lib/logkit-1.0.1.jar
+share/sipxpbx/lib/lucene-core-2.0.0.jar
+share/sipxpbx/lib/odmg-3.0.jar
+share/sipxpbx/lib/ognl-2.6.7.jar
+share/sipxpbx/lib/postgresql-8.0.309.jdbc3.jar
+share/sipxpbx/lib/saaj.jar
+share/sipxpbx/lib/saxpath-1.0fcs.jar
+share/sipxpbx/lib/sipxconfig.jar
+share/sipxpbx/lib/sipxconfig.war
+share/sipxpbx/lib/spring-1.2.7.jar
+share/sipxpbx/lib/tacos-4.0.0-lib.jar
+share/sipxpbx/lib/tapestry-4.0.2.jar
+share/sipxpbx/lib/tapestry-contrib-4.0.2.jar
+share/sipxpbx/lib/velocity-1.4.jar
+share/sipxpbx/lib/wsdl4j-1.5.1.jar
+share/sipxpbx/lib/xercesImpl-2.7.0.jar
+share/sipxpbx/lib/xml-apis-1.3.1.jar
+share/sipxpbx/lib/xmlrpc-2.0.jar
+@dirrm bin/ssl-cert
+@dirrm etc/sipxpbx/acme
+@dirrm etc/sipxpbx/audiocodes
+@dirrm etc/sipxpbx/ciscoAta
+@dirrm etc/sipxpbx/ciscoIp
+@dirrm etc/sipxpbx/commserver
+@dirrm etc/sipxpbx/database
+@dirrm etc/sipxpbx/dialplan
+@dirrm etc/sipxpbx/grandstream
+@dirrm etc/sipxpbx/hitachi
+@dirrm etc/sipxpbx/kphone
+@dirrm etc/sipxpbx/polycom/mac-address.d
+@dirrm etc/sipxpbx/polycom
+@dirrm etc/sipxpbx/process.d
+@dirrm etc/sipxpbx/sipxconference
+@dirrm etc/sipxpbx/sipxpark
+@dirrm etc/sipxpbx/sipxvxml
+@dirrm etc/sipxpbx/snom
+@dirrm etc/sipxpbx/unmanagedPhone
+@dirrm etc/sipxpbx
+@dirrm lib/ruby/gems/1.8/cache
+@dirrm lib/ruby/gems/1.8/doc/sipXconfig-agent-1.0.0
+@dirrm lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/bin
+@dirrm lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/lib
+@dirrm lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0/tests
+@dirrm lib/ruby/gems/1.8/gems/sipXconfig-agent-1.0.0
+@dirrm lib/ruby/gems/1.8/gems
+@dirrm lib/ruby/gems/1.8/specifications
+@dirrm lib/ruby/gems/1.8
+@dirrm lib/ruby/gems
+@dirrm lib/ruby
+@dirrm share/sipxpbx/lib