aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 16:30:04 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 16:30:04 +0800
commita74070d18afd87ab57506fffaa37e4a59fe36e7c (patch)
treee0b4bd5ca8307a15d9f30b330774bc721f6d059a /net
parent2bb8846cf9778abc7d38d41270fb9cdae916abc1 (diff)
downloadfreebsd-ports-gnome-a74070d18afd87ab57506fffaa37e4a59fe36e7c.tar.gz
freebsd-ports-gnome-a74070d18afd87ab57506fffaa37e4a59fe36e7c.tar.zst
freebsd-ports-gnome-a74070d18afd87ab57506fffaa37e4a59fe36e7c.zip
sipxproxy should change the ownership, if necessary, of files and directories
it installs. Perviously, the toplevel port, sipxpbx, changed ownership for not only its files, but all the dependant ports too. - Bump PORTREVISION Submitted by: Mike Durian <durian@shadetreesoftware.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/sipxproxy/Makefile14
-rw-r--r--net/sipxproxy/files/pkg-install.in36
2 files changed, 48 insertions, 2 deletions
diff --git a/net/sipxproxy/Makefile b/net/sipxproxy/Makefile
index e18cded9fac0..babefbce5322 100644
--- a/net/sipxproxy/Makefile
+++ b/net/sipxproxy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxproxy
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -36,8 +37,11 @@ CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR}
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxcallresolver.sh.in
@@ -45,4 +49,10 @@ post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipauthproxy.sh.in
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxha-distrib.sh.in
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>
diff --git a/net/sipxproxy/files/pkg-install.in b/net/sipxproxy/files/pkg-install.in
new file mode 100644
index 000000000000..8ac6d67cf34b
--- /dev/null
+++ b/net/sipxproxy/files/pkg-install.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin
+
+USER=sipx
+GROUP=sipx
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2> /dev/null ; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP} ; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Add of group \"${GROUP}\" failed."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2> /dev/null ; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d %%LOCALSTATEDIR%%/sipxdata/configserver/phone/profile/tftproot -s %%PREFIX%%/bin/bash -c "sipX" ; then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Add of user \"${USER}\" failed."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ chown ${USER}:${GROUP} %%PREFIX%%/etc/sipxpbx
+ ;;
+esac