aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2001-09-18 02:49:50 +0800
committersada <sada@FreeBSD.org>2001-09-18 02:49:50 +0800
commitb416a22f6cfc4164b7d607284d5d8ee912cccd63 (patch)
tree428603071c69991953db4fed8975091284e15d31 /net
parent3f4ffff96b114333af00c98ee270871d67ab45eb (diff)
downloadfreebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.tar.gz
freebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.tar.zst
freebsd-ports-gnome-b416a22f6cfc4164b7d607284d5d8ee912cccd63.zip
New port: eudc-emacs20
EUDC is a user-friendly e-lisp client interface to directory servers running various protocols: 1) LDAP: Lightweight Directory Protocol 2) CCSO: white pages directory system also known as PH/QI (from its standard client and server names). 3) BBDB: Big Brother's Insiduous Database (BBDB is a local directory database) EUDC lets you query your corporate directory server for information such as phone numbers and office locations. It lets you also query public servers such as Four11 or BigFoot to complete email addresses directly from the server while composing email messages in VM, Gnus, Rmail,... WWW: http://lspwww.epfl.ch/~figueire/Software/eudc/ PR: ports/24991 Submitted by: Ilya Martynov <ilya@martynov.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/eudc-emacs20/Makefile56
-rw-r--r--net/eudc-emacs20/distinfo1
-rw-r--r--net/eudc-emacs20/pkg-comment1
-rw-r--r--net/eudc-emacs20/pkg-descr16
-rw-r--r--net/eudc-emacs20/pkg-message7
-rw-r--r--net/eudc-emacs20/pkg-plist30
7 files changed, 112 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 021a26e0188a..846c27b773e6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -90,6 +90,7 @@
SUBDIR += etherboot
SUBDIR += ethereal
SUBDIR += ettercap
+ SUBDIR += eudc-emacs20
SUBDIR += everybuddy
SUBDIR += fidelio
SUBDIR += firetalk
diff --git a/net/eudc-emacs20/Makefile b/net/eudc-emacs20/Makefile
new file mode 100644
index 000000000000..3dce13d594a0
--- /dev/null
+++ b/net/eudc-emacs20/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: eudc-emacs20
+# Date created: 8 February 2001
+# Whom: ilya
+#
+# $FreeBSD$
+#
+
+PORTNAME= eudc
+PORTVERSION= 1.30b
+CATEGORIES= net mail elisp
+MASTER_SITES= http://lspwww.epfl.ch/~figueire/Software/eudc/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= ilya@martynov.org
+
+RUN_DEPENDS= ldapsearch:${PORTSDIR}/net/openldap
+
+EMACS_PORT_NAME?=emacs20
+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+INFODIR= ${PREFIX}/info
+
+PORTDOCDIR= share/doc/${PORTNAME}-${EMACS_PORT_NAME}
+DOCS= COPYRIGHT ChangeLog INSTALL NEWS README
+SOURCES= eudc-autoloads.el eudc-bob.el eudc-export.el \
+ eudc-hotlist.el eudc-vars.el eudc.el \
+ eudcb-bbdb.el eudcb-ldap.el eudcb-ph.el ldap.el
+ELCS= ${SOURCES:S/.el/.elc/g}
+INFOS= eudc.info
+
+PLIST_SUB= EMACS_PORT_NAME=${EMACS_PORT_NAME} \
+ INFODIR=${INFODIR:S/${PREFIX}\///} \
+ EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+
+INSTALL_TARGET=
+lispdir= ${PREFIX}/${EMACS_SITE_LISPDIR}/eudc
+post-install:
+ ${MKDIR} ${lispdir};
+.for i in ${SOURCES} ${ELCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${lispdir}
+.endfor
+.for i in ${INFOS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${INFODIR}
+ install-info ${INFODIR}/eudc.info ${INFODIR}/dir
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${PORTDOCDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${PORTDOCDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/eudc-emacs20/distinfo b/net/eudc-emacs20/distinfo
new file mode 100644
index 000000000000..4f5895c4a6d8
--- /dev/null
+++ b/net/eudc-emacs20/distinfo
@@ -0,0 +1 @@
+MD5 (eudc-1.30b.tar.gz) = b533615ef01991e4b8ecacbf523caeb0
diff --git a/net/eudc-emacs20/pkg-comment b/net/eudc-emacs20/pkg-comment
new file mode 100644
index 000000000000..485bc1dd9623
--- /dev/null
+++ b/net/eudc-emacs20/pkg-comment
@@ -0,0 +1 @@
+An Emacs client to directory servers
diff --git a/net/eudc-emacs20/pkg-descr b/net/eudc-emacs20/pkg-descr
new file mode 100644
index 000000000000..af1e275e622a
--- /dev/null
+++ b/net/eudc-emacs20/pkg-descr
@@ -0,0 +1,16 @@
+EUDC is a user-friendly e-lisp client interface to directory servers running
+various protocols:
+
+1) LDAP: Lightweight Directory Protocol
+2) CCSO: white pages directory system also known as PH/QI (from its standard
+ client and server names).
+3) BBDB: Big Brother's Insiduous Database (BBDB is a local directory database)
+
+EUDC lets you query your corporate directory server for information such as
+phone numbers and office locations. It lets you also query public servers
+such as Four11 or BigFoot to complete email addresses directly from the
+server while composing email messages in VM, Gnus, Rmail,...
+
+WWW: http://lspwww.epfl.ch/~figueire/Software/eudc/
+
+-- ported by Ilya Martynov <ilya@martynov.org>
diff --git a/net/eudc-emacs20/pkg-message b/net/eudc-emacs20/pkg-message
new file mode 100644
index 000000000000..b04289d55e96
--- /dev/null
+++ b/net/eudc-emacs20/pkg-message
@@ -0,0 +1,7 @@
+*******************************************************************
+
+Add the following to your .emacs init file if you want to use EUDC:
+
+ (require 'eudc-autoloads)
+
+*******************************************************************
diff --git a/net/eudc-emacs20/pkg-plist b/net/eudc-emacs20/pkg-plist
new file mode 100644
index 000000000000..e39c4eaec6f0
--- /dev/null
+++ b/net/eudc-emacs20/pkg-plist
@@ -0,0 +1,30 @@
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-autoloads.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-autoloads.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-bob.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-bob.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-export.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-export.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-hotlist.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-hotlist.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-vars.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc-vars.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudc.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudc.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-bbdb.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-bbdb.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-ldap.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-ldap.elc
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-ph.el
+%%EMACS_SITE_LISPDIR%%/eudc/eudcb-ph.elc
+%%EMACS_SITE_LISPDIR%%/eudc/ldap.el
+%%EMACS_SITE_LISPDIR%%/eudc/ldap.elc
+@unexec install-info --delete %D/%%INFODIR%%/eudc.info %D/%%INFODIR%%/dir
+%%INFODIR%%/eudc.info
+@exec install-info %D/%%INFODIR%%/eudc.info %D/%%INFODIR%%/dir
+share/doc/eudc-%%EMACS_PORT_NAME%%/COPYRIGHT
+share/doc/eudc-%%EMACS_PORT_NAME%%/ChangeLog
+share/doc/eudc-%%EMACS_PORT_NAME%%/INSTALL
+share/doc/eudc-%%EMACS_PORT_NAME%%/NEWS
+share/doc/eudc-%%EMACS_PORT_NAME%%/README
+@dirrm %%EMACS_SITE_LISPDIR%%/eudc
+@dirrm share/doc/eudc-%%EMACS_PORT_NAME%%