aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2015-11-06 09:28:39 +0800
committerdanilo <danilo@FreeBSD.org>2015-11-06 09:28:39 +0800
commitb740c0020f53c9d83fe2b68c641512e4b0bb11aa (patch)
tree067aa678e45452f706db71c601cc6864f55fb7b7 /net
parent8e5b4809c5a92822a328dfcc04727ce1ff44f103 (diff)
downloadfreebsd-ports-gnome-b740c0020f53c9d83fe2b68c641512e4b0bb11aa.tar.gz
freebsd-ports-gnome-b740c0020f53c9d83fe2b68c641512e4b0bb11aa.tar.zst
freebsd-ports-gnome-b740c0020f53c9d83fe2b68c641512e4b0bb11aa.zip
- Fix plist when the default compiler is gcc5
Spotted by: sunpoet Obtained from: DPorts (marino)
Diffstat (limited to 'net')
-rw-r--r--net/openmpi/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 07f4dc1ca908..2404d35a4704 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -31,7 +31,10 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--mandir=${PREFIX}/${MPIDIR}/man \
--program-prefix= \
--with-hwloc=${LOCALBASE} \
- --with-libltdl=${LOCALBASE}
+ --with-libltdl=${LOCALBASE} \
+ --enable-mpi-fortran=usempi \
+ ompi_cv_fortran_ignore_tkr_data=0
+
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= ${PREFIX}/${MPIDIR}/lib \
${PREFIX}/${MPIDIR}/lib/openmpi