aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2005-07-15 20:21:58 +0800
committerfjoe <fjoe@FreeBSD.org>2005-07-15 20:21:58 +0800
commitb85a7c607b3bf73c9206ccee06a368ccb2794eee (patch)
tree8ca287d82d9a39ff5a3814605d420116a9f48118 /net
parent842ea332f0e7aef1047bac0eb6bd5d1824683f2d (diff)
downloadfreebsd-ports-gnome-b85a7c607b3bf73c9206ccee06a368ccb2794eee.tar.gz
freebsd-ports-gnome-b85a7c607b3bf73c9206ccee06a368ccb2794eee.tar.zst
freebsd-ports-gnome-b85a7c607b3bf73c9206ccee06a368ccb2794eee.zip
Fix build on RELENG_4 (fix res_watchdog, do not build fax support).
Bump PORTREVISION. Approved by: MAINTAINER
Diffstat (limited to 'net')
-rw-r--r--net/asterisk-bristuff/Makefile3
-rw-r--r--net/asterisk-bristuff/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk-devel/Makefile3
-rw-r--r--net/asterisk-devel/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk/Makefile3
-rw-r--r--net/asterisk/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk10/Makefile3
-rw-r--r--net/asterisk10/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk12/Makefile3
-rw-r--r--net/asterisk12/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk14/Makefile3
-rw-r--r--net/asterisk14/files/patch-res-res_watchdog.c13
-rw-r--r--net/asterisk16/Makefile3
-rw-r--r--net/asterisk16/files/patch-res-res_watchdog.c13
14 files changed, 105 insertions, 7 deletions
diff --git a/net/asterisk-bristuff/Makefile b/net/asterisk-bristuff/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk-bristuff/Makefile
+++ b/net/asterisk-bristuff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk-bristuff/files/patch-res-res_watchdog.c b/net/asterisk-bristuff/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk-bristuff/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk-devel/Makefile b/net/asterisk-devel/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk-devel/Makefile
+++ b/net/asterisk-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk-devel/files/patch-res-res_watchdog.c b/net/asterisk-devel/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk-devel/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk/files/patch-res-res_watchdog.c b/net/asterisk/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk10/files/patch-res-res_watchdog.c b/net/asterisk10/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk10/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk12/files/patch-res-res_watchdog.c b/net/asterisk12/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk12/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk14/files/patch-res-res_watchdog.c b/net/asterisk14/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk14/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 1ea4517f1202..c422a6454243 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -73,7 +74,7 @@ PLIST_SUB+= WITH_ZAPTEL=""
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_FAX)
+.if !defined(WITHOUT_FAX) && ${OSVERSION} >= 500000
MAKE_ENV+= WITH_FAX=1
LIB_DEPENDS+= spandsp.0:${PORTSDIR}/comms/spandsp
PLIST_SUB+= WITH_FAX=""
diff --git a/net/asterisk16/files/patch-res-res_watchdog.c b/net/asterisk16/files/patch-res-res_watchdog.c
new file mode 100644
index 000000000000..51e4b0ae6c71
--- /dev/null
+++ b/net/asterisk16/files/patch-res-res_watchdog.c
@@ -0,0 +1,13 @@
+--- res/res_watchdog.c.orig Fri Jul 15 13:24:24 2005
++++ res/res_watchdog.c Fri Jul 15 13:24:42 2005
+@@ -40,6 +40,10 @@
+
+ /* Registrar for operations */
+
++#ifndef O_SYNC
++#define O_SYNC O_FSYNC
++#endif
++
+ static struct watchdog_pvt *watchdogs = NULL;
+
+ STANDARD_LOCAL_USER;