aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /net
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/bittwist/Makefile3
-rw-r--r--net/bittwist/files/patch-Makefile56
-rw-r--r--net/hlmaster/Makefile2
-rw-r--r--net/hlmaster/files/patch-src_HLServerList.cpp (renamed from net/hlmaster/files/patch-HLServerList.cpp)40
-rw-r--r--net/rtptools/Makefile2
-rw-r--r--net/rtptools/files/patch-rtp.h6
-rw-r--r--net/rtptools/files/patch-rtpdump.c8
-rw-r--r--net/rtptools/files/patch-rtpsend.c12
8 files changed, 67 insertions, 62 deletions
diff --git a/net/bittwist/Makefile b/net/bittwist/Makefile
index 7ea14a6142f2..39260ef14fb6 100644
--- a/net/bittwist/Makefile
+++ b/net/bittwist/Makefile
@@ -10,7 +10,8 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT= Libpcap-based Ethernet packet generator, with PCAP editor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_FILES= Makefile
PLIST_FILES= bin/bittwist bin/bittwistb bin/bittwiste \
man/man1/bittwist.1.gz \
diff --git a/net/bittwist/files/patch-Makefile b/net/bittwist/files/patch-Makefile
index f58c9ccc1f8b..346daa8b558a 100644
--- a/net/bittwist/files/patch-Makefile
+++ b/net/bittwist/files/patch-Makefile
@@ -1,29 +1,29 @@
---- Makefile.orig 2011-02-24 23:23:42.000000000 +0800
-+++ Makefile 2014-06-23 10:40:19.186220280 +0800
+--- Makefile.orig 2016-06-20 15:56:31 UTC
++++ Makefile
@@ -1,6 +1,6 @@
- SHELL = /bin/sh
-
--prefix = /usr/local
-+prefix = ${PREFIX}
- exec_prefix = ${prefix}
- bindir = ${exec_prefix}/bin
- mandir = ${prefix}/man/man1
-@@ -31,12 +31,12 @@ clean:
- rm -f $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste
-
- install:
-- mkdir -p $(bindir)
-- chmod 755 $(bindir)
-- $(INSTALL_PROGRAM) $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste $(bindir)
-- mkdir -p $(mandir)
-- chmod 755 $(mandir)
-- $(INSTALL_DATA) $(DOC)/bittwist.1 $(DOC)/bittwistb.1 $(DOC)/bittwiste.1 $(mandir)
-+ mkdir -p $(DESTDIR)$(bindir)
-+ chmod 755 $(DESTDIR)$(bindir)
-+ $(INSTALL_PROGRAM) $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste $(DESTDIR)$(bindir)
-+ mkdir -p $(DESTDIR)$(mandir)
-+ chmod 755 $(DESTDIR)$(mandir)
-+ $(INSTALL_DATA) $(DOC)/bittwist.1 $(DOC)/bittwistb.1 $(DOC)/bittwiste.1 $(DESTDIR)$(mandir)
-
- uninstall:
- rm -f $(bindir)/bittwist $(bindir)/bittwistb $(bindir)/bittwiste
+ SHELL = /bin/sh
+
+-prefix = /usr/local
++prefix = ${PREFIX}
+ exec_prefix = ${prefix}
+ bindir = ${exec_prefix}/bin
+ mandir = ${prefix}/man/man1
+@@ -31,12 +31,12 @@ clean:
+ rm -f $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste
+
+ install:
+- mkdir -p $(bindir)
+- chmod 755 $(bindir)
+- $(INSTALL_PROGRAM) $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste $(bindir)
+- mkdir -p $(mandir)
+- chmod 755 $(mandir)
+- $(INSTALL_DATA) $(DOC)/bittwist.1 $(DOC)/bittwistb.1 $(DOC)/bittwiste.1 $(mandir)
++ mkdir -p $(DESTDIR)$(bindir)
++ chmod 755 $(DESTDIR)$(bindir)
++ $(INSTALL_PROGRAM) $(SRC)/bittwist $(SRC)/bittwistb $(SRC)/bittwiste $(DESTDIR)$(bindir)
++ mkdir -p $(DESTDIR)$(mandir)
++ chmod 755 $(DESTDIR)$(mandir)
++ $(INSTALL_DATA) $(DOC)/bittwist.1 $(DOC)/bittwistb.1 $(DOC)/bittwiste.1 $(DESTDIR)$(mandir)
+
+ uninstall:
+ rm -f $(bindir)/bittwist $(bindir)/bittwistb $(bindir)/bittwiste
diff --git a/net/hlmaster/Makefile b/net/hlmaster/Makefile
index a6ff532b32b9..224448d36aa3 100644
--- a/net/hlmaster/Makefile
+++ b/net/hlmaster/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Half-Life game master server daemon
+USES= dos2unix
+DOS2UNIX_GLOB= *.cpp
GNU_CONFIGURE= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/net/hlmaster/files/patch-HLServerList.cpp b/net/hlmaster/files/patch-src_HLServerList.cpp
index 2a652ccc7076..5300fb1e25ec 100644
--- a/net/hlmaster/files/patch-HLServerList.cpp
+++ b/net/hlmaster/files/patch-src_HLServerList.cpp
@@ -1,20 +1,20 @@
---- src/HLServerList.cpp.orig 2007-08-03 13:52:50.000000000 +0200
-+++ src/HLServerList.cpp 2007-08-03 13:53:27.000000000 +0200
-@@ -73,7 +73,7 @@
- m_nSkipRequests = 0;
-
- // initialize challenge number (should be random)
-- m_nChallengeSeed = (int) &m_pHeadDummyItem;
-+ m_nChallengeSeed = (intptr_t) &m_pHeadDummyItem;
- }
-
-
-@@ -604,7 +604,7 @@
- if(pItem != NULL)
- {
- // get a fresh, random id
-- pItem->m_nChallengeId = GetRandomChallenge((int)&pItem, (int)nTimestamp);
-+ pItem->m_nChallengeId = GetRandomChallenge((intptr_t)&pItem, (int)nTimestamp);
- }
- }
-
+--- src/HLServerList.cpp.orig 2016-06-20 15:57:45 UTC
++++ src/HLServerList.cpp
+@@ -73,7 +73,7 @@ HLServerList::HLServerList(int nMaxItems
+ m_nSkipRequests = 0;
+
+ // initialize challenge number (should be random)
+- m_nChallengeSeed = (int) &m_pHeadDummyItem;
++ m_nChallengeSeed = (intptr_t) &m_pHeadDummyItem;
+ }
+
+
+@@ -604,7 +604,7 @@ HLServerListItem* HLServerList::HeartBea
+ if(pItem != NULL)
+ {
+ // get a fresh, random id
+- pItem->m_nChallengeId = GetRandomChallenge((int)&pItem, (int)nTimestamp);
++ pItem->m_nChallengeId = GetRandomChallenge((intptr_t)&pItem, (int)nTimestamp);
+ }
+ }
+
diff --git a/net/rtptools/Makefile b/net/rtptools/Makefile
index 04c651b10ba1..ad129ac5df8d 100644
--- a/net/rtptools/Makefile
+++ b/net/rtptools/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://www.cs.columbia.edu/IRT/software/rtptools/download/
MAINTAINER= cpm@fbsd.es
COMMENT= Set of tools to record, playback, and monitor RTPv2 data streams
+USES= dos2unix
+DOS2UNIX_GLOB= *.c
GNU_CONFIGURE= yes
PLIST_FILES= bin/rtpdump bin/rtpplay bin/rtpsend bin/rtptrans
diff --git a/net/rtptools/files/patch-rtp.h b/net/rtptools/files/patch-rtp.h
index c1d142b4a914..456bb3dce34c 100644
--- a/net/rtptools/files/patch-rtp.h
+++ b/net/rtptools/files/patch-rtp.h
@@ -1,6 +1,6 @@
---- rtp.h.orig Thu Mar 9 07:35:26 2000
-+++ rtp.h Sat Apr 21 21:52:49 2001
-@@ -110,13 +110,18 @@
+--- rtp.h.orig 2001-12-29 12:48:24 UTC
++++ rtp.h
+@@ -112,13 +112,18 @@ typedef struct {
#define RTCP_VALID_MASK (0xc000 | 0x2000 | 0xfe)
#define RTCP_VALID_VALUE ((RTP_VERSION << 14) | RTCP_SR)
diff --git a/net/rtptools/files/patch-rtpdump.c b/net/rtptools/files/patch-rtpdump.c
index 28056951ca69..e353f478436a 100644
--- a/net/rtptools/files/patch-rtpdump.c
+++ b/net/rtptools/files/patch-rtpdump.c
@@ -1,6 +1,6 @@
---- rtpdump.c.orig Sat Apr 7 08:02:13 2001
-+++ rtpdump.c Sat Apr 21 21:54:10 2001
-@@ -429,8 +429,8 @@
+--- rtpdump.c.orig 2016-06-20 15:59:04 UTC
++++ rtpdump.c
+@@ -441,8 +441,8 @@ static int parse_control(FILE *out, char
for (i = 0; i < r->common.count; i++) {
fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
(unsigned long)ntohl(r->r.sr.rr[i].ssrc),
@@ -11,7 +11,7 @@
(unsigned long)ntohl(r->r.sr.rr[i].last_seq),
(unsigned long)ntohl(r->r.sr.rr[i].jitter),
(unsigned long)ntohl(r->r.sr.rr[i].lsr),
-@@ -446,8 +446,8 @@
+@@ -458,8 +458,8 @@ static int parse_control(FILE *out, char
for (i = 0; i < r->common.count; i++) {
fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
(unsigned long)ntohl(r->r.rr.rr[i].ssrc),
diff --git a/net/rtptools/files/patch-rtpsend.c b/net/rtptools/files/patch-rtpsend.c
index 2003e898f0ab..1153d0816ca1 100644
--- a/net/rtptools/files/patch-rtpsend.c
+++ b/net/rtptools/files/patch-rtpsend.c
@@ -1,6 +1,6 @@
---- rtpsend.c.orig Tue Sep 10 13:24:10 2002
-+++ rtpsend.c Sat Aug 16 08:58:12 2003
-@@ -353,9 +353,9 @@
+--- rtpsend.c.orig 2016-06-20 15:59:04 UTC
++++ rtpsend.c
+@@ -354,9 +354,9 @@ static int rtcp_rr(node_t *list, char *p
if (strcmp(n->type, "ssrc") == 0)
rr->ssrc = htonl(n->num);
else if (strcmp(n->type, "fraction") == 0)
@@ -13,9 +13,9 @@
else if (strcmp(n->type, "last_seq") == 0)
rr->last_seq = htonl(n->num);
else if (strcmp(n->type, "jit") == 0)
-@@ -919,6 +919,8 @@
- local = (struct in_addr *)host->h_addr_list[0];
- sin.sin_addr = *local;
+@@ -926,6 +926,8 @@ int main(int argc, char *argv[])
+ local = (struct in_addr *)host->h_addr_list[0];
+ sin.sin_addr = *local;
}
+ } else {
+ usage(argv[0]);