aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-04-27 19:59:28 +0800
committermva <mva@FreeBSD.org>2013-04-27 19:59:28 +0800
commitbed7f8c6b7d24bd79cfb65f528602915a4d25128 (patch)
treee580bb4c66185f6741df23146d4617f207efeeef /net
parentf71dcf6388902f8ecefb751c89c982dad00b0c8d (diff)
downloadfreebsd-ports-gnome-bed7f8c6b7d24bd79cfb65f528602915a4d25128.tar.gz
freebsd-ports-gnome-bed7f8c6b7d24bd79cfb65f528602915a4d25128.tar.zst
freebsd-ports-gnome-bed7f8c6b7d24bd79cfb65f528602915a4d25128.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig while here Reviewed by: zeising
Diffstat (limited to 'net')
-rw-r--r--net/boinc-client/Makefile2
-rw-r--r--net/c3270/Makefile2
-rw-r--r--net/g2ipmsg/Makefile3
-rw-r--r--net/gnetcat/Makefile3
-rw-r--r--net/ldapdiff/Makefile2
-rw-r--r--net/ldapscripts/Makefile2
-rw-r--r--net/libmms/Makefile5
-rw-r--r--net/minisapserver/Makefile2
-rw-r--r--net/miredo/Makefile3
-rw-r--r--net/nc6/Makefile2
-rw-r--r--net/netatalk/Makefile2
-rw-r--r--net/netatalk3/Makefile2
-rw-r--r--net/netdude/Makefile3
-rw-r--r--net/rdesktop/Makefile2
-rw-r--r--net/rsync/Makefile2
-rw-r--r--net/ruby-net-geoip/Makefile2
-rw-r--r--net/samba34/Makefile3
-rw-r--r--net/samba36/Makefile3
-rw-r--r--net/samba4/Makefile3
-rw-r--r--net/samba4wins/Makefile2
-rw-r--r--net/silc-client/Makefile2
-rw-r--r--net/ssltunnel-client/Makefile2
-rw-r--r--net/ulxmlrpcpp/Makefile3
-rw-r--r--net/whois/Makefile2
-rw-r--r--net/wire/Makefile2
-rw-r--r--net/wireshark/Makefile2
-rw-r--r--net/wol/Makefile3
-rw-r--r--net/x11vnc/Makefile2
-rw-r--r--net/xmlrpc-epi/Makefile2
-rw-r--r--net/yaz/Makefile5
-rw-r--r--net/zebra-server/Makefile2
31 files changed, 33 insertions, 44 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 5f7a439b0289..616f7571687b 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -87,7 +87,7 @@ PLIST_SUB+= X11="@comment "
.if ${PORT_OPTIONS:MMANAGER}
USE_XORG+= x11
USE_WX= 2.8+
-USE_ICONV= yes
+USES+= iconv
WX_CONF_ARGS= absolute
LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify \
sqlite3:${PORTSDIR}/databases/sqlite3
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index f35939ced77b..c8d1b1e61a59 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9]\.[0-9])(\..*)/\1/}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_ICONV= yes
+USES= iconv
USE_OPENSSL= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/g2ipmsg/Makefile b/net/g2ipmsg/Makefile
index 61adbbd57b3c..ccf34aadd283 100644
--- a/net/g2ipmsg/Makefile
+++ b/net/g2ipmsg/Makefile
@@ -15,11 +15,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A popup style message communication tool for GNOME2
USE_GMAKE= yes
-USES= pathfix pkgconfig gettext
+USES= pathfix pkgconfig gettext iconv
USE_GNOME= gnomeprefix intlhack intltool \
libgnomeui libbonobo desktopfileutils gnomepanel
USE_GSTREAMER= vorbis
-USE_ICONV= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/gnetcat/Makefile b/net/gnetcat/Makefile
index 9b690d281c1a..ad609cf7785e 100644
--- a/net/gnetcat/Makefile
+++ b/net/gnetcat/Makefile
@@ -15,8 +15,7 @@ DISTNAME= netcat-0.7.1
MAINTAINER= ports@FreeBSD.org
COMMENT= GPL'ed re-write of the well known networking tool netcat
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/net/ldapdiff/Makefile b/net/ldapdiff/Makefile
index d30d60e54407..f71eac9e517e 100644
--- a/net/ldapdiff/Makefile
+++ b/net/ldapdiff/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sylvio@FreeBSD.org
COMMENT= A utility for patching LDAP directories using LDIF files
-USE_ICONV= yes
+USES= iconv
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${LOCALBASE} \
diff --git a/net/ldapscripts/Makefile b/net/ldapscripts/Makefile
index 2ddc3e8d57cb..4d12df03226e 100644
--- a/net/ldapscripts/Makefile
+++ b/net/ldapscripts/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ldapadd:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
ldappasswd:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client
USE_OPENLDAP= yes
-USE_ICONV= yes
+USES= iconv
LIBDIR= ${PREFIX}/lib/${PORTNAME}
MAKE_ENV+= MANDIR=${MANPREFIX}/man \
ETCDIR=${ETCDIR}
diff --git a/net/libmms/Makefile b/net/libmms/Makefile
index b7781e916cc6..8d4222537d13 100644
--- a/net/libmms/Makefile
+++ b/net/libmms/Makefile
@@ -13,9 +13,8 @@ MASTER_SITES= SF
MAINTAINER= kwm@FreeBSD.org
COMMENT= Library for parsing mms:// and mmsh:// type network streams
-USE_GNOME= gnomehack pkgconfig glib20
-USES= gettext
-USE_ICONV= yes
+USE_GNOME= pkgconfig glib20
+USES= pathfix gettext iconv
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/minisapserver/Makefile b/net/minisapserver/Makefile
index 5544daf84140..1c5b09eeff20 100644
--- a/net/minisapserver/Makefile
+++ b/net/minisapserver/Makefile
@@ -16,7 +16,7 @@ COMMENT= SAP and SLP announcement for the VLC Media Player
LICENSE= GPLv2
USE_XZ= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
MAN1= sapserver.1
PLIST_FILES= bin/sapserver etc/sap.cfg-dist
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
index 7c0868a973e8..ec73e3b72578 100644
--- a/net/miredo/Makefile
+++ b/net/miredo/Makefile
@@ -31,8 +31,7 @@ USE_RC_SUBR= miredo_server miredo
LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB= NLS=""
.else
diff --git a/net/nc6/Makefile b/net/nc6/Makefile
index 50ac0a063c46..427375c7750c 100644
--- a/net/nc6/Makefile
+++ b/net/nc6/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Netcat clone with IPv6 support
MAN1= nc6.1
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index e25140eb0725..a71dad7f96a9 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= libtool
USE_BDB= 46+
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 73d1a9c43201..308c98570f3e 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -22,7 +22,7 @@ LATEST_LINK= netatalk3
USE_AUTOTOOLS= libtool
USE_BDB= 46+
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index c3d11136ac67..b744709123f7 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -17,8 +17,7 @@ COMMENT= NETwork DUmp data Displayer and Editor for tcpdump tracefiles
LIB_DEPENDS= netdude.0:${PORTSDIR}/net/libnetdude
USE_AUTOTOOLS= libltdl libtool
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lltdl"
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 077bb1cc4cf3..992757f29acc 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --with-ipv6
.endif
.if defined(WITH_ICONV)
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
.endif
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 9ebf33761a2a..c34b96e4ee35 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -70,7 +70,7 @@ CFLAGS+= -I${LOCALBASE}/include
.endif
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CONFIGUREDCFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CONFIGUREDCFLAGS="${CONFIGUREDCFLAGS}"
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index 1753e7862ee4..2e1c7aa9605d 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -18,7 +18,7 @@ COMMENT= A Ruby extension that wraps around libGeoIP
BUILD_DEPENDS= GeoIP>=1.4.6:${PORTSDIR}/net/GeoIP
LIB_DEPENDS= GeoIP.5:${PORTSDIR}/net/GeoIP
-USE_ICONV= yes
+USES= iconv
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
diff --git a/net/samba34/Makefile b/net/samba34/Makefile
index 18dd1b9f9320..ba5d677d1440 100644
--- a/net/samba34/Makefile
+++ b/net/samba34/Makefile
@@ -29,7 +29,6 @@ AUTOHEADER_ARGS= ${IPATHS}
AUTOCONF_ARGS= ${IPATHS}
USE_GMAKE= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf autoheader
# directories
@@ -71,7 +70,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
-USES= pkgconfig
+USES= pkgconfig iconv
# Let process generate meaningful backtrace on a core dump
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
# Always use external libtalloc
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index ea830980653f..de5fa8c055a6 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -30,9 +30,8 @@ AUTOHEADER_ARGS= ${IPATHS}
AUTOCONF_ARGS= ${IPATHS}
USE_GMAKE= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= pkgconfig iconv
USE_AUTOTOOLS= autoconf autoheader
USE_LDCONFIG= ${SAMBA_LIBDIR}
# pkg-config is used to find talloc
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 0b96c48a3341..b52a5408976d 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -72,8 +72,7 @@ USE_PERL5_BUILD= yes
USE_GCC= 4.2+
USE_PYTHON= yes
-USE_ICONV= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
USE_LDCONFIG= ${SAMBA4_LIBDIR}
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index e7a69f982b5c..f5a145c30980 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -17,7 +17,7 @@ COMMENT= A full featured replicating WINS server for UNIX
CONFLICTS= ja-samba-2.* ja-samba-4.* samba-2.* samba-4.* sharity-light-1.*
-USE_ICONV= yes
+USES= iconv
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf autoheader
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 13c96be7943a..28ab24705e3f 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -88,7 +88,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS+= --with-iconv
.else
CONFIGURE_ARGS+= --without-iconv
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
index 74583d87f8f9..9f3526d3cf2f 100644
--- a/net/ssltunnel-client/Makefile
+++ b/net/ssltunnel-client/Makefile
@@ -19,7 +19,7 @@ LICENSE= BSD
CONFIGURE_ARGS= --disable-server --with-iconv=${LOCALBASE}
GNU_CONFIGURE= yes
-USE_ICONV= yes
+USES= iconv
MAN1= pppclient.1
MAN5= ssltunnelrc.5
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
index faa5304f480d..fd8bfe09bf51 100644
--- a/net/ulxmlrpcpp/Makefile
+++ b/net/ulxmlrpcpp/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
-USES= pathfix
-USE_ICONV= yes
+USES= pathfix iconv
USE_OPENSSL= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/net/whois/Makefile b/net/whois/Makefile
index dde738952271..1308dad91b9d 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net/wire/Makefile b/net/wire/Makefile
index bdde35a17e7d..29a20f6b66ca 100644
--- a/net/wire/Makefile
+++ b/net/wire/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --libdir="${LOCALBASE}/lib" --includedir="${LOCALBASE}/include"
USE_GMAKE= yes
USE_OPENSSL= yes
-USE_ICONV= yes
+USES= iconv
PLIST_FILES= bin/wire
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index e96f4e2d34d6..ddef89d0d722 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -22,7 +22,7 @@ DATADIR_NAME= wireshark
USE_PERL5_BUILD=yes
USE_PYTHON_BUILD=yes
USE_GETTEXT= yes
-USE_ICONV= yes
+USES= iconv
USE_BZIP2= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/net/wol/Makefile b/net/wol/Makefile
index 318d281c1c43..1d4de7c79266 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -21,8 +21,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-nls
PLIST_SUB= NLS="@comment "
.else
-USES+= gettext
-USE_ICONV= yes
+USES+= gettext iconv
PLIST_SUB= NLS=""
.endif
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index caddb89316f2..28b9cd78bba9 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -22,7 +22,7 @@ USE_XORG= x11 xdamage xfixes xrandr xinerama xext xtst xau xrender xdmcp recordp
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/xmlrpc-epi/Makefile b/net/xmlrpc-epi/Makefile
index 8ec3577efc58..2b61c886e428 100644
--- a/net/xmlrpc-epi/Makefile
+++ b/net/xmlrpc-epi/Makefile
@@ -16,7 +16,7 @@ COMMENT= A general purpose implementation of the xmlrpc specification in C
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index 3ca89360eb21..ece4926b26b7 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -11,11 +11,10 @@ COMMENT= Z39.50/SR client and API library
LIB_DEPENDS= icuuc:${PORTSDIR}/devel/icu
-USE_ICONV= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_GNOME= libxml2 libxslt gnomehack
+USES= pathfix pkgconfig iconv
+USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/net/zebra-server/Makefile b/net/zebra-server/Makefile
index 107551b2e12f..728ae106c2f4 100644
--- a/net/zebra-server/Makefile
+++ b/net/zebra-server/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ARGS= --with-yaz=${LOCALBASE}/bin \
--with-tclconfig=${TCL_LIBDIR} \
--with-iconv=${LOCALBASE} --with-expat=${LOCALBASE}
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= yes
USE_TCL= 84+