aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2005-03-02 05:51:48 +0800
committertrevor <trevor@FreeBSD.org>2005-03-02 05:51:48 +0800
commitc6535e2fa7f07178532cebeadf49e7309985ea88 (patch)
treea351c62f6273509c52176a55b38b9bb841d2c8e0 /net
parent45cc41b90123ddfb02c3ca701d32cc9e5f004e64 (diff)
downloadfreebsd-ports-gnome-c6535e2fa7f07178532cebeadf49e7309985ea88.tar.gz
freebsd-ports-gnome-c6535e2fa7f07178532cebeadf49e7309985ea88.tar.zst
freebsd-ports-gnome-c6535e2fa7f07178532cebeadf49e7309985ea88.zip
Respect the user's USE_LINUX setting.
Diffstat (limited to 'net')
-rw-r--r--net/aim/Makefile1
-rw-r--r--net/citrix_ica/Makefile1
-rw-r--r--net/citrix_xenapp/Makefile1
-rw-r--r--net/linux-agsatellite/Makefile1
-rw-r--r--net/linux-edonkey-core/Makefile2
-rw-r--r--net/linux-edonkey-gui-gtk/Makefile1
-rw-r--r--net/linux-edonkey-server/Makefile2
-rw-r--r--net/linux-jigdo/Makefile2
-rw-r--r--net/linux-nx-client/Makefile1
-rw-r--r--net/linux-overnet-core/Makefile2
-rw-r--r--net/peercast/Makefile2
-rw-r--r--net/skype-devel/Makefile1
-rw-r--r--net/skype/Makefile1
13 files changed, 5 insertions, 13 deletions
diff --git a/net/aim/Makefile b/net/aim/Makefile
index c4ef5a7d5bc3..f4c3788f8cbf 100644
--- a/net/aim/Makefile
+++ b/net/aim/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_LINUX= yes
PREFIX?= ${X11BASE}
INSTALLS_SHLIB= yes
# must not strip
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index a7885d00227f..1703390c944a 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -23,7 +23,6 @@ IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_LINUX= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
diff --git a/net/citrix_xenapp/Makefile b/net/citrix_xenapp/Makefile
index a7885d00227f..1703390c944a 100644
--- a/net/citrix_xenapp/Makefile
+++ b/net/citrix_xenapp/Makefile
@@ -23,7 +23,6 @@ IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_LINUX= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
diff --git a/net/linux-agsatellite/Makefile b/net/linux-agsatellite/Makefile
index a2df25e0e13d..54eee9d32d2e 100644
--- a/net/linux-agsatellite/Makefile
+++ b/net/linux-agsatellite/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XF
WRKSRC= ${WRKDIR}/${DISTNAME:C/-.*//}
-USE_LINUX= yes
NO_BUILD= yes
USE_REINPLACE= yes
STRIP=
diff --git a/net/linux-edonkey-core/Makefile b/net/linux-edonkey-core/Makefile
index 6fda23a509c9..d4b6c412bfeb 100644
--- a/net/linux-edonkey-core/Makefile
+++ b/net/linux-edonkey-core/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= eDonkey2000 'core' command line client
ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
+USE_LINUX?= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
STRIP=
diff --git a/net/linux-edonkey-gui-gtk/Makefile b/net/linux-edonkey-gui-gtk/Makefile
index 85dd0cbecf06..812e507bea04 100644
--- a/net/linux-edonkey-gui-gtk/Makefile
+++ b/net/linux-edonkey-gui-gtk/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= donkey:${PORTSDIR}/net/linux-edonkey-core \
${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
PREFIX?= ${X11BASE}
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/net/linux-edonkey-server/Makefile b/net/linux-edonkey-server/Makefile
index fffd87c540d3..50e4a36ce2b3 100644
--- a/net/linux-edonkey-server/Makefile
+++ b/net/linux-edonkey-server/Makefile
@@ -20,7 +20,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= A decentralized peer-to-peer file-sharing server (eDonkey2000 server)
ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
+USE_LINUX?= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
STRIP=
diff --git a/net/linux-jigdo/Makefile b/net/linux-jigdo/Makefile
index 7776c2c0d8a8..ca49a96551eb 100644
--- a/net/linux-jigdo/Makefile
+++ b/net/linux-jigdo/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
ONLY_FOR_ARCHS= i386
USE_BZIP2= YES
-USE_LINUX= yes
+USE_LINUX?= yes
NO_BUILD= yes
STRIP=
diff --git a/net/linux-nx-client/Makefile b/net/linux-nx-client/Makefile
index bd0d3ffc84be..a74e1c7c7c10 100644
--- a/net/linux-nx-client/Makefile
+++ b/net/linux-nx-client/Makefile
@@ -18,7 +18,6 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
NO_WRKSUBDIR= yes
USE_X_PREFIX= yes
-USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
diff --git a/net/linux-overnet-core/Makefile b/net/linux-overnet-core/Makefile
index 524b77326502..512dd38ea104 100644
--- a/net/linux-overnet-core/Makefile
+++ b/net/linux-overnet-core/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= arundel@h3c.de
COMMENT= Overnet 'core' command line client
ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
+USE_LINUX?= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
STRIP=
diff --git a/net/peercast/Makefile b/net/peercast/Makefile
index 7e2c7ef0cb94..64e0e931290a 100644
--- a/net/peercast/Makefile
+++ b/net/peercast/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@brutele.be
COMMENT= A peer-to-peer network for broadcasting and listening to streams
-USE_LINUX= yes
+USE_LINUX?= yes
NO_WRKSUBDIR= yes
do-build:
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
index 409c5117455d..af1f2f3c048e 100644
--- a/net/skype-devel/Makefile
+++ b/net/skype-devel/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux
USE_BZIP2= yes
PREFIX?= ${X11BASE}
-USE_LINUX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386
diff --git a/net/skype/Makefile b/net/skype/Makefile
index 409c5117455d..af1f2f3c048e 100644
--- a/net/skype/Makefile
+++ b/net/skype/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux
USE_BZIP2= yes
PREFIX?= ${X11BASE}
-USE_LINUX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386