aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-24 12:44:17 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-24 12:44:17 +0800
commitc763050df812af11e0607dd7d69b31ab067c093c (patch)
treeaa116af2ce179457b332c1e5de24e02d0c179cfa /net
parent06e61ce578bc86c82cd449bb52d230bb3d20e8cc (diff)
downloadfreebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.tar.gz
freebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.tar.zst
freebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39746 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/isc-dhcp3-server/Makefile10
-rw-r--r--net/isc-dhcp3/Makefile10
-rw-r--r--net/isc-dhcp30-server/Makefile10
-rw-r--r--net/isc-dhcp31-server/Makefile10
-rw-r--r--net/isc-dhcp40-server/Makefile10
5 files changed, 25 insertions, 25 deletions
diff --git a/net/isc-dhcp3-server/Makefile b/net/isc-dhcp3-server/Makefile
index ae4f7fb5f922..a5379c84356b 100644
--- a/net/isc-dhcp3-server/Makefile
+++ b/net/isc-dhcp3-server/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dhcp
PORTVERSION= 3.0.1.r9
-PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,6 +31,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAN1= omshell.1
@@ -124,22 +124,22 @@ post-patch: patch-scripts patch-makefile-conf \
patch-message
patch-scripts:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/client/scripts/freebsd
patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ \t]*=|# DEBUG ?=|g' \
+ @${REINPLACE_CMD} -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
${WRKSRC}/Makefile.conf
patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ \t]*=|CFLAGS +=|g' \
+ @${REINPLACE_CMD} -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
# temporary hack - no patch file needed for this typo.
patch-man-pages:
- @${PERL} -ni.fbsd -e '/^\.Fd$$/ or print;' ${WRKSRC}/dhcpctl/dhcpctl.3
+ @${REINPLACE_CMD} -e '/^\.Fd$$/d' ${WRKSRC}/dhcpctl/dhcpctl.3
patch-message:
@${SED} 's|%%PREFIX%%|${PREFIX}|g;s|%%MAN1PREFIX%%|${MAN1PREFIX}|g' \
diff --git a/net/isc-dhcp3/Makefile b/net/isc-dhcp3/Makefile
index ae4f7fb5f922..a5379c84356b 100644
--- a/net/isc-dhcp3/Makefile
+++ b/net/isc-dhcp3/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dhcp
PORTVERSION= 3.0.1.r9
-PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,6 +31,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAN1= omshell.1
@@ -124,22 +124,22 @@ post-patch: patch-scripts patch-makefile-conf \
patch-message
patch-scripts:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/client/scripts/freebsd
patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ \t]*=|# DEBUG ?=|g' \
+ @${REINPLACE_CMD} -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
${WRKSRC}/Makefile.conf
patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ \t]*=|CFLAGS +=|g' \
+ @${REINPLACE_CMD} -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
# temporary hack - no patch file needed for this typo.
patch-man-pages:
- @${PERL} -ni.fbsd -e '/^\.Fd$$/ or print;' ${WRKSRC}/dhcpctl/dhcpctl.3
+ @${REINPLACE_CMD} -e '/^\.Fd$$/d' ${WRKSRC}/dhcpctl/dhcpctl.3
patch-message:
@${SED} 's|%%PREFIX%%|${PREFIX}|g;s|%%MAN1PREFIX%%|${MAN1PREFIX}|g' \
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index ae4f7fb5f922..a5379c84356b 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dhcp
PORTVERSION= 3.0.1.r9
-PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,6 +31,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAN1= omshell.1
@@ -124,22 +124,22 @@ post-patch: patch-scripts patch-makefile-conf \
patch-message
patch-scripts:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/client/scripts/freebsd
patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ \t]*=|# DEBUG ?=|g' \
+ @${REINPLACE_CMD} -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
${WRKSRC}/Makefile.conf
patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ \t]*=|CFLAGS +=|g' \
+ @${REINPLACE_CMD} -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
# temporary hack - no patch file needed for this typo.
patch-man-pages:
- @${PERL} -ni.fbsd -e '/^\.Fd$$/ or print;' ${WRKSRC}/dhcpctl/dhcpctl.3
+ @${REINPLACE_CMD} -e '/^\.Fd$$/d' ${WRKSRC}/dhcpctl/dhcpctl.3
patch-message:
@${SED} 's|%%PREFIX%%|${PREFIX}|g;s|%%MAN1PREFIX%%|${MAN1PREFIX}|g' \
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index ae4f7fb5f922..a5379c84356b 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dhcp
PORTVERSION= 3.0.1.r9
-PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,6 +31,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAN1= omshell.1
@@ -124,22 +124,22 @@ post-patch: patch-scripts patch-makefile-conf \
patch-message
patch-scripts:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/client/scripts/freebsd
patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ \t]*=|# DEBUG ?=|g' \
+ @${REINPLACE_CMD} -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
${WRKSRC}/Makefile.conf
patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ \t]*=|CFLAGS +=|g' \
+ @${REINPLACE_CMD} -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
# temporary hack - no patch file needed for this typo.
patch-man-pages:
- @${PERL} -ni.fbsd -e '/^\.Fd$$/ or print;' ${WRKSRC}/dhcpctl/dhcpctl.3
+ @${REINPLACE_CMD} -e '/^\.Fd$$/d' ${WRKSRC}/dhcpctl/dhcpctl.3
patch-message:
@${SED} 's|%%PREFIX%%|${PREFIX}|g;s|%%MAN1PREFIX%%|${MAN1PREFIX}|g' \
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index ae4f7fb5f922..a5379c84356b 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dhcp
PORTVERSION= 3.0.1.r9
-PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,6 +31,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
MAN1= omshell.1
@@ -124,22 +124,22 @@ post-patch: patch-scripts patch-makefile-conf \
patch-message
patch-scripts:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/client/scripts/freebsd
patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ \t]*=|# DEBUG ?=|g' \
+ @${REINPLACE_CMD} -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
${WRKSRC}/Makefile.conf
patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ \t]*=|CFLAGS +=|g' \
+ @${REINPLACE_CMD} -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
# temporary hack - no patch file needed for this typo.
patch-man-pages:
- @${PERL} -ni.fbsd -e '/^\.Fd$$/ or print;' ${WRKSRC}/dhcpctl/dhcpctl.3
+ @${REINPLACE_CMD} -e '/^\.Fd$$/d' ${WRKSRC}/dhcpctl/dhcpctl.3
patch-message:
@${SED} 's|%%PREFIX%%|${PREFIX}|g;s|%%MAN1PREFIX%%|${MAN1PREFIX}|g' \