aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-03-24 23:05:45 +0800
committerswills <swills@FreeBSD.org>2013-03-24 23:05:45 +0800
commitc96c1fa4f795b6bd072c9eae58440f8ca1d89b36 (patch)
treeac16009e721bf66a4f813db86d272a6926de5a30 /net
parent6dcc5ba9678bc25c9268ffaf77c413fb2ad7b68e (diff)
downloadfreebsd-ports-gnome-c96c1fa4f795b6bd072c9eae58440f8ca1d89b36.tar.gz
freebsd-ports-gnome-c96c1fa4f795b6bd072c9eae58440f8ca1d89b36.tar.zst
freebsd-ports-gnome-c96c1fa4f795b6bd072c9eae58440f8ca1d89b36.zip
TigerVNC is a high-performance, platform-neutral implementation of VNC,
a client/server application that allows users to launch and interact with graphical applications on remote machines. WWW: http://tigervnc.org/ PR: ports/175801 Submitted by: Koichiro IWAO <meta+ports@vmeta.jp>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tigervnc/Makefile149
-rw-r--r--net/tigervnc/distinfo6
-rw-r--r--net/tigervnc/files/patch-CMakeLists.txt68
-rw-r--r--net/tigervnc/files/patch-cmake_BuildPackages.cmake10
-rw-r--r--net/tigervnc/files/patch-hw_vnc_Makefile.am11
-rw-r--r--net/tigervnc/files/patch-unix_vncserver20
-rw-r--r--net/tigervnc/pkg-descr5
-rw-r--r--net/tigervnc/pkg-plist21
9 files changed, 291 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 86017ff865ca..2ffafca39983 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1157,6 +1157,7 @@
SUBDIR += tftpgrab
SUBDIR += thcrut
SUBDIR += throttled
+ SUBDIR += tigervnc
SUBDIR += tightvnc
SUBDIR += tintin++
SUBDIR += tinyfugue
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
new file mode 100644
index 000000000000..1791f216eed1
--- /dev/null
+++ b/net/tigervnc/Makefile
@@ -0,0 +1,149 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= tigervnc
+PORTVERSION= 1.2.0
+CATEGORIES= net x11-servers
+MASTER_SITES= SF:tigervnc
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}/:tigervnc
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:tigervnc
+
+MAINTAINER= meta+ports@vmeta.jp
+COMMENT= TigerVNC is an advanced VNC implementation
+
+PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-servers/xorg-server:patch
+BUILD_DEPENDS+= ${LOCALBASE}/share/aclocal/xorg-macros.m4:${PORTSDIR}/devel/xorg-macros \
+ ${LOCALBASE}/libdata/pkgconfig/dri.pc:${PORTSDIR}/graphics/dri
+
+CONFLICTS= tridiavnc-[0-9]* \
+ tightvnc-[0-9]* \
+ vnc-[0-9]*
+
+MAKE_JOBS_UNSAFE= yes
+
+USE_CMAKE= yes
+USE_PKGCONFIG= build
+USE_GMAKE= yes
+USE_GL= gl
+USE_AUTOTOOLS+= autoconf:env automake:env libtool:env
+USE_PYTHON= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+USE_XORG+= bigreqsproto compositeproto damageproto fixesproto fontsproto glproto \
+ inputproto kbproto pixman randrproto renderproto resourceproto \
+ scrnsaverproto videoproto xau xdmcp xext xkbfile xcmiscproto xextproto \
+ xfont xproto xrandr xtrans xtst
+
+MAN1+= vncpasswd.1 \
+ x0vncserver.1 \
+ vncserver.1 \
+ vncconfig.1 \
+ Xvnc.1
+CFLAGS+= -fPIC
+
+OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER HPJPG
+OPTIONS_DEFAULT= GNUTLS NLS PAM VIEWER
+VIEWER_DESC= Build vncviewer
+HPJPG_DESC= Build with High-Performance JPEG support
+
+.include <bsd.port.options.mk>
+
+CMAKE_ARGS= -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+.if ${PORT_OPTIONS:MGNUTLS}
+LIB_DEPENDS+= tasn1:${PORTSDIR}/security/libtasn1 \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ gpg-error:${PORTSDIR}/security/libgpg-error \
+ gnutls:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --enable-glx-tls
+CMAKE_ARGS+= -DENABLE_GNUTLS=1
+.else
+CMAKE_ARGS+= -DENABLE_GNUTLS=0
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+CMAKE_ARGS+= -DENABLE_NLS=1
+PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DENABLE_NLS=0
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPAM}
+CMAKE_ARGS+= -DENABLE_PAM=1
+.else
+CMAKE_ARGS+= -DENABLE_PAM=0
+.endif
+
+.if ${PORT_OPTIONS:MVIEWER}
+CMAKE_ARGS+= -DENABLE_VIEWER=1
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
+ fltk:${PORTSDIR}/x11-toolkits/fltk
+USE_XORG+= xcursor xfixes xft xinerama
+MAN1+= vncviewer.1
+PLIST_SUB+= VIEWER=""
+.else
+PLIST_SUB+= VIEWER="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MHPJPG}
+LIB_DEPENDS+= turbojpeg:${PORTSDIR}/graphics/libjpeg-turbo
+.else
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+.endif
+
+MAKE_ARGS+= TIGERVNC_SRCDIR=${WRKSRC}
+CONFIGURE_ARGS+= \
+ --prefix=${PREFIX} --mandir=${PREFIX}/man/ \
+ --docdir=${PREFIX}/share/doc/${PORTNAME}/ --with-pic --without-dtrace \
+ --disable-static --disable-dri \
+ --disable-xinerama --disable-xvfb --disable-xnest --disable-xorg \
+ --disable-dmx --disable-xwin --disable-xephyr --disable-kdrive \
+ --disable-config-dbus --disable-config-hal \
+ --disable-dri2 --enable-install-libxf86config --enable-glx \
+ --with-default-font-path="catalogue:${PREFIX}/share/fonts,built-ins" \
+ --with-fontdir=${PREFIX}/share/fonts \
+ --with-xkb-path=${PREFIX}/share/X11/xkb \
+ --with-xkb-output=/var/lib/xkb \
+ --with-xkb-bin-directory=${PREFIX}/bin \
+ --with-serverconfig-path=${PREFIX}/lib/X11 \
+ --with-dri-driver-path=${PREFIX}/lib/dri \
+ --disable-selective-werror
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_NEW_XORG
+TIGERVNC_XORG_PATCH_VER= 110
+.else
+TIGERVNC_XORG_PATCH_VER= 17
+.endif
+
+# import from x11-server/xorg-server/Makefile
+.ifdef WITH_OPENSSL_BASE
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
+.endif
+
+XORG_WRKDIR= ${MAKE} -C ${PORTSDIR}/x11-servers/xorg-server -VWRKSRC
+
+pre-patch:
+ @${CP} -R `${XORG_WRKDIR}`/ ${WRKSRC}/unix/xserver/
+
+post-patch:
+ @cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver${TIGERVNC_XORG_PATCH_VER}.patch
+
+post-configure:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${AUTORECONF} -fiv
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+
+post-build:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS}
+
+post-install:
+ @cd ${WRKSRC}/unix/xserver/hw/vnc/ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install
+
+.include <bsd.port.post.mk>
diff --git a/net/tigervnc/distinfo b/net/tigervnc/distinfo
new file mode 100644
index 000000000000..f11edc6ccd8c
--- /dev/null
+++ b/net/tigervnc/distinfo
@@ -0,0 +1,6 @@
+SHA256 (tigervnc-1.2.0.tar.gz) = 6e0910f1ff1681bc8b52e7ea805e586b88b352c88f66e4c2cc31aa39c4a32f53
+SIZE (tigervnc-1.2.0.tar.gz) = 2487050
+SHA256 (xorg-server-1.10.6.tar.bz2) = c4da5a97b6986688efe74bc9bff6a38795977019ac032dd6d787abad32c50682
+SIZE (xorg-server-1.10.6.tar.bz2) = 5406712
+SHA256 (xorg-server-1.7.7.tar.bz2) = 54c4d32bfeb8852adbea3ddae6981f3bc2eadb330124d9b35226c617c01926ff
+SIZE (xorg-server-1.7.7.tar.bz2) = 4939257
diff --git a/net/tigervnc/files/patch-CMakeLists.txt b/net/tigervnc/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..3511e4cc4d38
--- /dev/null
+++ b/net/tigervnc/files/patch-CMakeLists.txt
@@ -0,0 +1,68 @@
+--- CMakeLists.txt.orig 2012-03-10 05:34:29.000000000 +0900
++++ CMakeLists.txt 2012-10-25 19:02:36.642061425 +0900
+@@ -237,6 +237,7 @@
+ endif()
+
+ # Check for FLTK
++if(ENABLE_VIEWER)
+ set(FLTK_SKIP_FLUID TRUE)
+ set(FLTK_SKIP_OPENGL TRUE)
+ set(FLTK_SKIP_IMAGES TRUE)
+@@ -282,44 +283,7 @@
+ set(CMAKE_REQUIRED_LIBRARIES)
+ endif()
+
+-option(USE_INCLUDED_FLTK
+- "Force the use of the FLTK library bundled with the TigerVNC source")
+-if(NOT FLTK_FOUND OR NOT HAVE_FLTK_DEAD_KEYS OR NOT HAVE_FLTK_CLIPBOARD
+- OR NOT HAVE_FLTK_MEDIAKEYS OR NOT HAVE_FLTK_FULLSCREEN
+- OR NOT HAVE_FLTK_CURSOR)
+- set(USE_INCLUDED_FLTK 1)
+-endif()
+-if(USE_INCLUDED_FLTK)
+- # Check that we have the proper dependencies
+- if(UNIX AND NOT APPLE)
+- if(NOT X11_Xft_FOUND)
+- message(FATAL_ERROR "Xft headers/libraries not found (needed by FLTK.)")
+- endif()
+- if(NOT X11_Xinerama_FOUND)
+- message(FATAL_ERROR "Xinerama headers/libraries not found (needed by FLTK.)")
+- endif()
+- if(NOT X11_Xfixes_FOUND)
+- message(FATAL_ERROR "Xfixes headers/libraries not found (needed by FLTK.)")
+- endif()
+- if(NOT X11_Xcursor_FOUND)
+- message(FATAL_ERROR "Xcursor headers/libraries not found (needed by FLTK.)")
+- endif()
+- endif()
+-
+- set(HAVE_FLTK_DEAD_KEYS 1)
+- set(HAVE_FLTK_CLIPBOARD 1)
+- set(HAVE_FLTK_MEDIAKEYS 1)
+- set(HAVE_FLTK_FULLSCREEN 1)
+- set(HAVE_FLTK_CURSOR 1)
+- set(FLTK_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/common/fltk)
+- set(FLTK_LIBRARIES)
+- if(APPLE)
+- set(FLTK_LIBRARIES "-framework Carbon -framework Cocoa -framework ApplicationServices")
+- elseif(NOT WIN32)
+- set(FLTK_LIBRARIES "-ldl")
+- endif()
+- message(STATUS "Using included FLTK library")
+-endif()
++endif() # ENABLE_VIEWER
+
+ # Check for GNUTLS library
+ option(ENABLE_GNUTLS "Enable protocol encryption and advanced authentication" ON)
+@@ -409,7 +373,10 @@
+ if(ENABLE_NLS)
+ add_subdirectory(po)
+ endif()
+-add_subdirectory(vncviewer)
++
++if(ENABLE_VIEWER)
++ add_subdirectory(vncviewer)
++endif()
+
+ include(cmake/BuildPackages.cmake)
+
diff --git a/net/tigervnc/files/patch-cmake_BuildPackages.cmake b/net/tigervnc/files/patch-cmake_BuildPackages.cmake
new file mode 100644
index 000000000000..5da0133daa7e
--- /dev/null
+++ b/net/tigervnc/files/patch-cmake_BuildPackages.cmake
@@ -0,0 +1,10 @@
+--- cmake/BuildPackages.cmake.orig 2012-05-28 00:21:51.000000000 +0900
++++ cmake/BuildPackages.cmake 2012-05-28 00:22:15.000000000 +0900
+@@ -86,5 +86,5 @@
+ # Common
+ #
+
+-install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION doc)
+-install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION doc)
++install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION share/doc/tigervnc)
++install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION share/doc/tigervnc)
diff --git a/net/tigervnc/files/patch-hw_vnc_Makefile.am b/net/tigervnc/files/patch-hw_vnc_Makefile.am
new file mode 100644
index 000000000000..2e86d6a9110b
--- /dev/null
+++ b/net/tigervnc/files/patch-hw_vnc_Makefile.am
@@ -0,0 +1,11 @@
+--- unix/xserver/hw/vnc/Makefile.am.orig 2012-04-26 00:10:38.000000000 +0900
++++ unix/xserver/hw/vnc/Makefile.am 2012-05-27 14:48:07.000000000 +0900
+@@ -67,7 +67,7 @@
+
+ pixman.h:
+ for i in ${XSERVERLIBS_CFLAGS}; do \
+- if [[ "$$i" =~ "pixman" ]]; then \
++ if [ "$$i" = "pixman" ]; then \
+ PIXMANINCDIR=`echo $$i | sed s/-I//g`; \
+ fi; \
+ done; \
diff --git a/net/tigervnc/files/patch-unix_vncserver b/net/tigervnc/files/patch-unix_vncserver
new file mode 100644
index 000000000000..045d688cd85e
--- /dev/null
+++ b/net/tigervnc/files/patch-unix_vncserver
@@ -0,0 +1,20 @@
+--- unix/vncserver.orig 2012-05-27 21:16:41.000000000 +0900
++++ unix/vncserver 2012-05-27 21:17:13.000000000 +0900
+@@ -422,7 +422,7 @@
+
+ socket(S, $AF_INET, $SOCK_STREAM, 0) || die "$prog: socket failed: $!\n";
+ eval 'setsockopt(S, &SOL_SOCKET, &SO_REUSEADDR, pack("l", 1))';
+- if (!bind(S, pack('S n x12', $AF_INET, 6000 + $n))) {
++ if (!bind(S, sockaddr_in(6000 + $n, &INADDR_ANY))) {
+ close(S);
+ return 0;
+ }
+@@ -430,7 +430,7 @@
+
+ socket(S, $AF_INET, $SOCK_STREAM, 0) || die "$prog: socket failed: $!\n";
+ eval 'setsockopt(S, &SOL_SOCKET, &SO_REUSEADDR, pack("l", 1))';
+- if (!bind(S, pack('S n x12', $AF_INET, 5900 + $n))) {
++ if (!bind(S, sockaddr_in(5900 + $n, &INADDR_ANY))) {
+ close(S);
+ return 0;
+ }
diff --git a/net/tigervnc/pkg-descr b/net/tigervnc/pkg-descr
new file mode 100644
index 000000000000..698856fa5bea
--- /dev/null
+++ b/net/tigervnc/pkg-descr
@@ -0,0 +1,5 @@
+TigerVNC is a high-performance, platform-neutral implementation of VNC,
+a client/server application that allows users to launch and interact with
+graphical applications on remote machines.
+
+WWW: http://tigervnc.org/
diff --git a/net/tigervnc/pkg-plist b/net/tigervnc/pkg-plist
new file mode 100644
index 000000000000..f7892c82a687
--- /dev/null
+++ b/net/tigervnc/pkg-plist
@@ -0,0 +1,21 @@
+bin/Xvnc
+bin/vncconfig
+bin/vncpasswd
+bin/vncserver
+%%VIEWER%%bin/vncviewer
+bin/x0vncserver
+lib/xorg/modules/extensions/libvnc.la
+lib/xorg/modules/extensions/libvnc.so
+%%NLS%%share/locale/de/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tigervnc.mo
+%%DOCSDIR%%/README.txt
+%%DOCSDIR%%/LICENCE.TXT
+@dirrm %%DOCSDIR%%
+@unexec %D/%%DOCSDIR%% 2>/dev/null || true
+@dirrmtry lib/xorg/modules/extensions
+@dirrmtry lib/xorg/modules
+@dirrmtry lib/xorg