aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-05-23 08:32:04 +0800
committerpat <pat@FreeBSD.org>2002-05-23 08:32:04 +0800
commitccf69d9370f1b396c50c57421c2d6633769fc944 (patch)
tree37fc7529631cbcd2c3a85c29acc1e32a3a3b58e7 /net
parentd4a41cc316fff92f393d9f66a4121809b2ecbb51 (diff)
downloadfreebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.tar.gz
freebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.tar.zst
freebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.zip
Fix ports for building with -current without perl
PR: 38359 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/py-adns/Makefile10
-rw-r--r--net/py-google/Makefile13
2 files changed, 20 insertions, 3 deletions
diff --git a/net/py-adns/Makefile b/net/py-adns/Makefile
index b741415a3123..83e40776422b 100644
--- a/net/py-adns/Makefile
+++ b/net/py-adns/Makefile
@@ -20,9 +20,17 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
@${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
+.else
+ @${SED} -i.orig -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
+ -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
+ ${WRKSRC}/setup.py
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/py-google/Makefile b/net/py-google/Makefile
index 5c2116e04df9..cf9e7a7be960 100644
--- a/net/py-google/Makefile
+++ b/net/py-google/Makefile
@@ -24,15 +24,24 @@ EXTRACT_BEFORE_ARGS= -q -aa
WRKSRC= ${WRKDIR}/pygoogle
EXAMPLESDIR= ${PREFIX}/share/examples/py-google
+.include <bsd.port.pre.mk>
+
post-patch:
# www/py-websvcs has an incompatible version of SOAP.py
@${MV} ${WRKSRC}/SOAP.py ${WRKSRC}/SOAPgoogle.py
+.if ${OSVERSION} < 500036
@cd ${WRKSRC}; for f in *.py; do \
${PERL} -pi -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
done
+ @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.else
+ @cd ${WRKSRC}; for f in *.py; do \
+ ${SED} -i "" -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
+ done
+ @${SED} -i.orig -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.endif
@${MKDIR} ${WRKSRC}/tests
@${MV} ${WRKSRC}/*test*.py ${WRKSRC}/tests
- @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
@@ -41,4 +50,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>