aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-22 00:34:07 +0800
committerarved <arved@FreeBSD.org>2004-08-22 00:34:07 +0800
commitd6ecf3c9e87e1d8f2ac8575cea86c4de1cfce987 (patch)
tree6e37c25f5a9ab27caa1b52666a4221e369df7f6b /net
parent48bac34a177f2f0ae3e3ec56d19615ed36ebdb8e (diff)
downloadfreebsd-ports-gnome-d6ecf3c9e87e1d8f2ac8575cea86c4de1cfce987.tar.gz
freebsd-ports-gnome-d6ecf3c9e87e1d8f2ac8575cea86c4de1cfce987.tar.zst
freebsd-ports-gnome-d6ecf3c9e87e1d8f2ac8575cea86c4de1cfce987.zip
fix build with gcc3.4
Diffstat (limited to 'net')
-rw-r--r--net/cap/Makefile4
-rw-r--r--net/cap/files/patch-papif.c20
2 files changed, 20 insertions, 4 deletions
diff --git a/net/cap/Makefile b/net/cap/Makefile
index 10b92cc9b816..4a25efe72aad 100644
--- a/net/cap/Makefile
+++ b/net/cap/Makefile
@@ -60,10 +60,6 @@ READMES= applications/papif applications/lwsrv applications/aufs \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
pre-patch:
@(cd ${WRKSRC}; \
for f in ../cap60.patch* ; do ${PATCH} -s -p < $$f ; done)
diff --git a/net/cap/files/patch-papif.c b/net/cap/files/patch-papif.c
new file mode 100644
index 000000000000..25f47e001577
--- /dev/null
+++ b/net/cap/files/patch-papif.c
@@ -0,0 +1,20 @@
+--- applications/papif/papif.c.orig Sat Aug 21 18:29:42 2004
++++ applications/papif/papif.c Sat Aug 21 18:31:17 2004
+@@ -244,6 +244,17 @@
+ #define lpd_REPRINT 1 /* forces a reprint */
+ #define lpd_ERRORS 2 /* printed with errors */
+
++#ifndef USEVPRINTF
++/* Bletch - gotta do it because pyramids don't work the other way */
++/* (using _doprnt and &args) and don't have vprintf */
++/* of course, there will be something that is just one arg larger :-) */
++/* VARARGS1 */
++dolog(fmt, a1,a2,a3,a4,a5,a6,a7,a8,a9,aa,ab,ac,ad,ae,af);
++char *fmt;
++#else
++dolog(register char *fmt, ...);
++#endif
++
+ #ifdef USESYSLOG
+ #ifdef __STDC__
+ log_i(fmt, a1,a2,a3,a4,a5,a6,a7,a8,a9,aa,ab,ac,ad,ae,af)