aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-03-11 08:01:31 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-03-11 08:01:31 +0800
commitdca9d8c23f492b92adca2ad2591a8c16f27efd28 (patch)
tree2e5892e0d10970f0a89a63a1ccfba185192dd44f /net
parent0e73fbac5c7ae0350d7daf315ff6927d0acc45c6 (diff)
downloadfreebsd-ports-gnome-dca9d8c23f492b92adca2ad2591a8c16f27efd28.tar.gz
freebsd-ports-gnome-dca9d8c23f492b92adca2ad2591a8c16f27efd28.tar.zst
freebsd-ports-gnome-dca9d8c23f492b92adca2ad2591a8c16f27efd28.zip
Add istgt 20090223, an iSCSI target for FreeBSD 7.x with ZFS.
PR: ports/132016 Submitted by: Daisuke Aoyama <aoyama at peach.ne.jp>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/istgt/Makefile24
-rw-r--r--net/istgt/distinfo3
-rw-r--r--net/istgt/files/pkg-message.in7
-rw-r--r--net/istgt/pkg-descr4
-rw-r--r--net/istgt/pkg-plist8
-rw-r--r--net/openistgt/Makefile24
-rw-r--r--net/openistgt/distinfo3
-rw-r--r--net/openistgt/files/pkg-message.in7
-rw-r--r--net/openistgt/pkg-descr4
-rw-r--r--net/openistgt/pkg-plist8
11 files changed, 93 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c381e29419f9..78bd787c63a4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -245,6 +245,7 @@
SUBDIR += isc-dhcp31-relay
SUBDIR += isc-dhcp31-server
SUBDIR += iscsi-target
+ SUBDIR += istgt
SUBDIR += iwi-firmware
SUBDIR += iwi-firmware-kmod
SUBDIR += jags
diff --git a/net/istgt/Makefile b/net/istgt/Makefile
new file mode 100644
index 000000000000..512352faa6ba
--- /dev/null
+++ b/net/istgt/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: istgt
+# Date created: 2009-02-23
+# Whom: Daisuke Aoyama <aoyama@peach.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= istgt
+PORTVERSION= 20090223
+CATEGORIES= net
+MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
+
+MAINTAINER= aoyama@peach.ne.jp
+COMMENT= An iSCSI target for FreeBSD 7.x with ZFS
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+GNU_CONFIGURE= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/istgt/distinfo b/net/istgt/distinfo
new file mode 100644
index 000000000000..6dbadd258e47
--- /dev/null
+++ b/net/istgt/distinfo
@@ -0,0 +1,3 @@
+MD5 (istgt-20090223.tar.gz) = 4db15625be7f80fb1d984703c1db59a5
+SHA256 (istgt-20090223.tar.gz) = a181f68097662a3c302d4ff721cb726ef41e940e2a7b65cea047394a5a1ea664
+SIZE (istgt-20090223.tar.gz) = 157643
diff --git a/net/istgt/files/pkg-message.in b/net/istgt/files/pkg-message.in
new file mode 100644
index 000000000000..5e2733cdaf73
--- /dev/null
+++ b/net/istgt/files/pkg-message.in
@@ -0,0 +1,7 @@
+*************************************************************************
+
+To run istgt at startup, add istgt_enable="YES" to /etc/rc.conf.
+Create configuration files manually.
+Sample configuration files can be found in %%PREFIX%%/etc/istgt.
+
+*************************************************************************
diff --git a/net/istgt/pkg-descr b/net/istgt/pkg-descr
new file mode 100644
index 000000000000..2dd62b807687
--- /dev/null
+++ b/net/istgt/pkg-descr
@@ -0,0 +1,4 @@
+This is an iSCSI target, it serves iSCSI protocol and provides
+SCSI devices to the initiator (client).
+
+WWW: http://shell.peach.ne.jp/aoyama/
diff --git a/net/istgt/pkg-plist b/net/istgt/pkg-plist
new file mode 100644
index 000000000000..0de3f116f1a7
--- /dev/null
+++ b/net/istgt/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/istgt
+bin/istgtcontrol
+etc/rc.d/istgt
+etc/istgt/istgt.conf.sample
+etc/istgt/auth.conf.sample
+etc/istgt/istgtcontrol.conf.sample
+@dirrm etc/istgt
diff --git a/net/openistgt/Makefile b/net/openistgt/Makefile
new file mode 100644
index 000000000000..512352faa6ba
--- /dev/null
+++ b/net/openistgt/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: istgt
+# Date created: 2009-02-23
+# Whom: Daisuke Aoyama <aoyama@peach.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= istgt
+PORTVERSION= 20090223
+CATEGORIES= net
+MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
+
+MAINTAINER= aoyama@peach.ne.jp
+COMMENT= An iSCSI target for FreeBSD 7.x with ZFS
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+GNU_CONFIGURE= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/openistgt/distinfo b/net/openistgt/distinfo
new file mode 100644
index 000000000000..6dbadd258e47
--- /dev/null
+++ b/net/openistgt/distinfo
@@ -0,0 +1,3 @@
+MD5 (istgt-20090223.tar.gz) = 4db15625be7f80fb1d984703c1db59a5
+SHA256 (istgt-20090223.tar.gz) = a181f68097662a3c302d4ff721cb726ef41e940e2a7b65cea047394a5a1ea664
+SIZE (istgt-20090223.tar.gz) = 157643
diff --git a/net/openistgt/files/pkg-message.in b/net/openistgt/files/pkg-message.in
new file mode 100644
index 000000000000..5e2733cdaf73
--- /dev/null
+++ b/net/openistgt/files/pkg-message.in
@@ -0,0 +1,7 @@
+*************************************************************************
+
+To run istgt at startup, add istgt_enable="YES" to /etc/rc.conf.
+Create configuration files manually.
+Sample configuration files can be found in %%PREFIX%%/etc/istgt.
+
+*************************************************************************
diff --git a/net/openistgt/pkg-descr b/net/openistgt/pkg-descr
new file mode 100644
index 000000000000..2dd62b807687
--- /dev/null
+++ b/net/openistgt/pkg-descr
@@ -0,0 +1,4 @@
+This is an iSCSI target, it serves iSCSI protocol and provides
+SCSI devices to the initiator (client).
+
+WWW: http://shell.peach.ne.jp/aoyama/
diff --git a/net/openistgt/pkg-plist b/net/openistgt/pkg-plist
new file mode 100644
index 000000000000..0de3f116f1a7
--- /dev/null
+++ b/net/openistgt/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/istgt
+bin/istgtcontrol
+etc/rc.d/istgt
+etc/istgt/istgt.conf.sample
+etc/istgt/auth.conf.sample
+etc/istgt/istgtcontrol.conf.sample
+@dirrm etc/istgt