aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-02-17 19:04:19 +0800
committerdinoex <dinoex@FreeBSD.org>2004-02-17 19:04:19 +0800
commiteae522c353cb87b7572b1bbf8d2a252e9b831155 (patch)
tree55dde2900dc703738fb300d8a14af695fdc72041 /net
parentaf4bb84d473bc460c8d1b4cc352ead89c7ba3f38 (diff)
downloadfreebsd-ports-gnome-eae522c353cb87b7572b1bbf8d2a252e9b831155.tar.gz
freebsd-ports-gnome-eae522c353cb87b7572b1bbf8d2a252e9b831155.tar.zst
freebsd-ports-gnome-eae522c353cb87b7572b1bbf8d2a252e9b831155.zip
- use PTHREAD_CFLAGS and PTHREAD_LIBS everywhere
- drop -lc
Diffstat (limited to 'net')
-rw-r--r--net/licq/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 2eaf32525253..1def0e68e878 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -7,7 +7,7 @@
PORTNAME= base
PORTVERSION= ${LICQ_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
.if defined(WITH_SOCKS)
PKGNAMESUFFIX= -socks
@@ -46,17 +46,15 @@ pre-configure:
${WRKSRC}/src/licq.conf.h
@${ECHO_MSG} Ignoring existing libgnugetopt
${REINPLACE_CMD} -e 's=getopt.h==' \
+ -e 's=FLAGS -D_THREAD_SAFE=FLAGS ${PTHREAD_CFLAGS}=' \
-e 's=FLAGS -pthread=FLAGS ${PTHREAD_CFLAGS}=' \
+ -e "s=-lc_r=${PTHREAD_LIBS}=" \
+ -e 's=-lc *$$LIBS=$$LIBS=' \
${WRKSRC}/configure
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
-.endif
-
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>