aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-04-09 03:20:28 +0800
committermnag <mnag@FreeBSD.org>2006-04-09 03:20:28 +0800
commitf355df73faeebc1c9c12e3cba2d88f64cd8e8f52 (patch)
tree5b5e9e19d95ee50fa7251ba4d6ebd055501b10c2 /net
parent9e4015bce6f94d33d42a4d64600d01ea481470db (diff)
downloadfreebsd-ports-gnome-f355df73faeebc1c9c12e3cba2d88f64cd8e8f52.tar.gz
freebsd-ports-gnome-f355df73faeebc1c9c12e3cba2d88f64cd8e8f52.tar.zst
freebsd-ports-gnome-f355df73faeebc1c9c12e3cba2d88f64cd8e8f52.zip
- Update to 3.8
- portlint(1) - Fix build on 4.x [mnag] PR: 95380 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/rp-pppoe/Makefile5
-rw-r--r--net/rp-pppoe/distinfo6
-rw-r--r--net/rp-pppoe/files/patch-if.c11
-rw-r--r--net/rp-pppoe/files/patch-libevent__event.c23
-rw-r--r--net/rp-pppoe/files/patch-pppoe.c18
5 files changed, 57 insertions, 6 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
index 00f1aefd6bb2..b4c88b7ed667 100644
--- a/net/rp-pppoe/Makefile
+++ b/net/rp-pppoe/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= rp-pppoe
-PORTVERSION= 3.7
+PORTVERSION= 3.8
CATEGORIES= net
MASTER_SITES= http://www.roaringpenguin.com/penguin/pppoe/
MAINTAINER= matthias.andree@gmx.de
-COMMENT= "The popular Roaring Penguin's PPPoE software"
+COMMENT= The popular Roaring Penguin's PPPoE software
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PATCH_WRKSRC= ${WRKSRC}/src
diff --git a/net/rp-pppoe/distinfo b/net/rp-pppoe/distinfo
index e46b859769ad..9016c5d8f686 100644
--- a/net/rp-pppoe/distinfo
+++ b/net/rp-pppoe/distinfo
@@ -1,3 +1,3 @@
-MD5 (rp-pppoe-3.7.tar.gz) = 32c34455ccdfd9610304479e1beac3ff
-SHA256 (rp-pppoe-3.7.tar.gz) = 6647e36d5164268ee469c771ee24f3f5fc84112396510d1f79be994b2d125de7
-SIZE (rp-pppoe-3.7.tar.gz) = 212326
+MD5 (rp-pppoe-3.8.tar.gz) = 0e32760f498f9cde44081ee6aafc823b
+SHA256 (rp-pppoe-3.8.tar.gz) = d916e9cfe1e62395f63a5361936fa855f6d0f0a37dc7227b394cdb725f553479
+SIZE (rp-pppoe-3.8.tar.gz) = 212931
diff --git a/net/rp-pppoe/files/patch-if.c b/net/rp-pppoe/files/patch-if.c
new file mode 100644
index 000000000000..7826214afa3b
--- /dev/null
+++ b/net/rp-pppoe/files/patch-if.c
@@ -0,0 +1,11 @@
+--- if.c.orig Thu Apr 6 01:14:48 2006
++++ if.c Thu Apr 6 01:14:58 2006
+@@ -99,7 +99,7 @@
+
+ static unsigned char *bpfBuffer; /* Packet filter buffer */
+ static int bpfLength = 0; /* Packet filter buffer length */
+-static int bpfSize = 0; /* Number of unread bytes in buffer */
++ int bpfSize = 0; /* Number of unread bytes in buffer */
+ static int bpfOffset = 0; /* Current offset in bpfBuffer */
+ #endif
+
diff --git a/net/rp-pppoe/files/patch-libevent__event.c b/net/rp-pppoe/files/patch-libevent__event.c
new file mode 100644
index 000000000000..5ca3b58e96e1
--- /dev/null
+++ b/net/rp-pppoe/files/patch-libevent__event.c
@@ -0,0 +1,23 @@
+--- libevent/event.c.orig Sat Apr 8 16:15:20 2006
++++ libevent/event.c Sat Apr 8 16:15:50 2006
+@@ -86,9 +86,6 @@
+
+ struct timeval abs_timeout, now;
+
+- /* Avoid compiler warning */
+- abs_timeout.tv_sec = 0;
+- abs_timeout.tv_usec = 0;
+ struct timeval timeout;
+ struct timeval *tm;
+ EventHandler *eh;
+@@ -100,6 +97,10 @@
+ int foundWriteEvent = 0;
+ int maxfd = -1;
+ int pastDue;
++
++ /* Avoid compiler warning */
++ abs_timeout.tv_sec = 0;
++ abs_timeout.tv_usec = 0;
+
+ EVENT_DEBUG(("Enter Event_HandleEvent(es=%p)\n", (void *) es));
+
diff --git a/net/rp-pppoe/files/patch-pppoe.c b/net/rp-pppoe/files/patch-pppoe.c
new file mode 100644
index 000000000000..c550e8a68129
--- /dev/null
+++ b/net/rp-pppoe/files/patch-pppoe.c
@@ -0,0 +1,18 @@
+--- pppoe.c.orig Sat Apr 8 16:11:14 2006
++++ pppoe.c Sat Apr 8 16:11:53 2006
+@@ -409,6 +409,7 @@
+ unsigned int s; /* Temporary to hold session */
+ FILE *pidfile;
+ unsigned int discoveryType, sessionType;
++ char const *options;
+
+ PPPoEConnection conn;
+
+@@ -434,7 +435,6 @@
+ /* Initialize syslog */
+ openlog("pppoe", LOG_PID, LOG_DAEMON);
+
+- char const *options;
+ #ifdef DEBUGGING_ENABLED
+ options = "I:VAT:D:hS:C:Usm:np:e:kdf:F:t:";
+ #else