aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-04-23 20:00:54 +0800
committernivit <nivit@FreeBSD.org>2011-04-23 20:00:54 +0800
commitf536b2ca84a9553478e4dcaf44b0101aa4909756 (patch)
treeadc67511562803048e26d92a501af6b4d2f02778 /net
parent95f9d28e37797eda2446090c865ae09b067efa3f (diff)
downloadfreebsd-ports-gnome-f536b2ca84a9553478e4dcaf44b0101aa4909756.tar.gz
freebsd-ports-gnome-f536b2ca84a9553478e4dcaf44b0101aa4909756.tar.zst
freebsd-ports-gnome-f536b2ca84a9553478e4dcaf44b0101aa4909756.zip
Heybuddy is a supposedly light, feature free identi.ca client,
licensed under GNU GPL v3. WWW: http://www.jezra.net/projects/heybuddy PR: ports/156402 Submitted by: Beni Keller <navigium at grindcore.ch>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/heybuddy/Makefile36
-rw-r--r--net/heybuddy/distinfo2
-rw-r--r--net/heybuddy/pkg-descr4
-rw-r--r--net/heybuddy/pkg-plist54
5 files changed, 97 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0fbfaf39b4b3..d15988cb6653 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -221,6 +221,7 @@
SUBDIR += hawknl
SUBDIR += hawknl-devel
SUBDIR += hexinject
+ SUBDIR += heybuddy
SUBDIR += hf6to4
SUBDIR += hidentd
SUBDIR += hinfo
diff --git a/net/heybuddy/Makefile b/net/heybuddy/Makefile
new file mode 100644
index 000000000000..ee8e8939131e
--- /dev/null
+++ b/net/heybuddy/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: heybuddy
+# Date created: 14 April 2011
+# Whom: Beni Keller <navigium@grindcore.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= heybuddy
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= http://launchpad.net/${PORTNAME}/0.2/${PORTVERSION}/+download/ \
+ http://freebsd.grindcore.ch/distfiles/
+
+MAINTAINER= navigium@grindcore.ch
+COMMENT= Heybuddy is a supposedly light, feature free identi.ca client
+
+FETCH_ARGS= -Fpr
+
+LICENSE= GPLv3
+
+USE_PYTHON= yes
+USE_GETTEXT= yes
+USE_GNOME= pygtk2
+
+do-build:
+ ${PYTHON_CMD} -mcompileall ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR}
+ ${LN} -s ${DATADIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+
+post-install:
+ ${RM} ${DATADIR}/*.txt ${DATADIR}/ChangeLog
+
+.include <bsd.port.mk>
diff --git a/net/heybuddy/distinfo b/net/heybuddy/distinfo
new file mode 100644
index 000000000000..1cc9e269b7ba
--- /dev/null
+++ b/net/heybuddy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (heybuddy-0.2.1.tar.gz) = 15a5bf1a09ba1e2c37c9ebc341563bac60d0d265a78b8995925ceab49b9e3ba5
+SIZE (heybuddy-0.2.1.tar.gz) = 65726
diff --git a/net/heybuddy/pkg-descr b/net/heybuddy/pkg-descr
new file mode 100644
index 000000000000..72de3c166e77
--- /dev/null
+++ b/net/heybuddy/pkg-descr
@@ -0,0 +1,4 @@
+Heybuddy is a supposedly light, feature free identi.ca client,
+licensed under GNU GPL v3.
+
+WWW: http://www.jezra.net/projects/heybuddy
diff --git a/net/heybuddy/pkg-plist b/net/heybuddy/pkg-plist
new file mode 100644
index 000000000000..5746ce4ac70d
--- /dev/null
+++ b/net/heybuddy/pkg-plist
@@ -0,0 +1,54 @@
+@comment $FreeBSD$
+bin/heybuddy
+%%DATADIR%%/assets/icon1.png
+%%DATADIR%%/assets/icon.png
+%%DATADIR%%/assets/throbber.gif
+%%DATADIR%%/assets/icon64.png
+%%DATADIR%%/assets/direct_icon.png
+%%DATADIR%%/assets/icon.svg
+%%DATADIR%%/assets/icon14.png
+%%DATADIR%%/ImageCache.pyc
+%%DATADIR%%/Configuration.py
+%%DATADIR%%/ImageCache.py
+%%DATADIR%%/DentScroller.py
+%%DATADIR%%/heybuddy.py
+%%DATADIR%%/heybuddy.pyc
+%%DATADIR%%/DentScroller.pyc
+%%DATADIR%%/Communicator.pyc
+%%DATADIR%%/PlatformSpecific.py
+%%DATADIR%%/Configuration.pyc
+%%DATADIR%%/ContextPage.py
+%%DATADIR%%/MainWindow.py
+%%DATADIR%%/XMLProcessor.pyc
+%%DATADIR%%/Notify.pyc
+%%DATADIR%%/Communicator.py
+%%DATADIR%%/ContextPage.pyc
+%%DATADIR%%/Dent.py
+%%DATADIR%%/StatusIcon.pyc
+%%DATADIR%%/About.pyc
+%%DATADIR%%/PlatformSpecific.pyc
+%%DATADIR%%/_dev/get_text
+%%DATADIR%%/_dev/heybuddy.pot
+%%DATADIR%%/UserPage.py
+%%DATADIR%%/ScrollPage.py
+%%DATADIR%%/SettingsPage.py
+%%DATADIR%%/GroupPage.pyc
+%%DATADIR%%/DentButton.py
+%%DATADIR%%/Notify.py
+%%DATADIR%%/FilterFrame.pyc
+%%DATADIR%%/ScrollPage.pyc
+%%DATADIR%%/GroupPage.py
+%%DATADIR%%/MainWindow.pyc
+%%DATADIR%%/SettingsPage.pyc
+%%DATADIR%%/DentButton.pyc
+%%DATADIR%%/StatusIcon.py
+%%DATADIR%%/FilterFrame.py
+%%DATADIR%%/UserPage.pyc
+%%DATADIR%%/Dent.pyc
+%%DATADIR%%/XMLProcessor.py
+%%DATADIR%%/About.py
+@dirrm %%DATADIR%%/_dev
+@dirrm %%DATADIR%%/assets
+@dirrm %%DATADIR%%/locales
+@dirrm %%DATADIR%%
+@exec mkdir -p %D%/%%DATADIR%%/locales