aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /net
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'net')
-rw-r--r--net/cflowd/Makefile12
-rw-r--r--net/click/Makefile12
-rw-r--r--net/dctc/Makefile12
-rw-r--r--net/irrtoolset/Makefile12
-rw-r--r--net/ns/Makefile12
-rw-r--r--net/ns2/Makefile12
-rw-r--r--net/ntop/Makefile11
-rw-r--r--net/oproute/Makefile4
-rw-r--r--net/sting/Makefile4
-rw-r--r--net/tcpview/Makefile12
-rw-r--r--net/tintin++/Makefile6
-rw-r--r--net/xicq/Makefile10
12 files changed, 59 insertions, 60 deletions
diff --git a/net/cflowd/Makefile b/net/cflowd/Makefile
index ec73c10bbc0f..c61b5a189359 100644
--- a/net/cflowd/Makefile
+++ b/net/cflowd/Makefile
@@ -22,12 +22,6 @@ COMMENT= Flow analysis tool used for analyzing Cisco's NetFlow switching
BUILD_DEPENDS= ${LOCALBASE}/lib/libArts.a:${PORTSDIR}/net/arts++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -37,6 +31,12 @@ CONFIGURE_ARGS+=--enable-shared --with-artspp=${PREFIX}
MANL= cfdases.l cfdifmatrix.l cfdnets.l cfdnexthops.l \
cfdportmatrix.l cfdprotos.l cfdtos.l flowdump.l flowwatch.l
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.if !defined(CFLOWD_FLOWSCAN_PATCH)
pre-everything::
@${ECHO} "you can compile cflowd with patches for FlowScan by typing:"
diff --git a/net/click/Makefile b/net/click/Makefile
index 07f2574782f4..b5b38aaeac9e 100644
--- a/net/click/Makefile
+++ b/net/click/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= http://www.pdos.lcs.mit.edu/click/
MAINTAINER= gnn@neville-neil.com
COMMENT= The Click Modular Router
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -67,6 +61,12 @@ MANN= FTPPortMapper.n ARPFaker.n ARPQuerier.n ARPResponder.n \
CONFDIR= ${PREFIX}/etc/click/conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-install:
@strip ${PREFIX}/bin/click
@strip ${PREFIX}/bin/click-align
diff --git a/net/dctc/Makefile b/net/dctc/Makefile
index 1138010f8bb8..80384b5411a0 100644
--- a/net/dctc/Makefile
+++ b/net/dctc/Makefile
@@ -18,12 +18,6 @@ COMMENT= A DirectConnect (www.neo-modus.com) text client for file sharing
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Configure fails"
-.endif
-
USE_GETOPT_LONG= yes
USE_GNOME= glib12
USE_PERL5_RUN= yes
@@ -62,6 +56,12 @@ DOC_FILES= COPYING ChangeLog INSTALL README \
Documentation/output.nl \
Documentation/output Documentation/programs
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Configure fails"
+.endif
+
post-extract:
@${CP} ${FILESDIR}/lp_mutex.c ${WRKSRC}/src
diff --git a/net/irrtoolset/Makefile b/net/irrtoolset/Makefile
index 7cfd192945d8..c98f7554f76d 100644
--- a/net/irrtoolset/Makefile
+++ b/net/irrtoolset/Makefile
@@ -16,12 +16,6 @@ COMMENT= A suite of routing policy tools to interact with the IRR
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BISON= yes
USE_GMAKE= yes
USE_GCC= 2.95
@@ -36,6 +30,12 @@ MAN1= CIDRAdvisor.1 aoe.1 prpath.1 RtConfig.1 peval.1 \
roe.1 rpslcheck.1 prtraceroute.1
MAN3= librpsl.3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${SED} -i.orig -e 's|#include <malloc.h>|/* #include <malloc.h> */|' \
${WRKSRC}/src/irr/birdwhoisc.cc
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 1b489bdd1339..048394a7da2a 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -17,12 +17,6 @@ COMMENT= The UCB/LBNL Network Simulator Version 2
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
RUN_DEPENDS= ${LOCALBASE}/bin/tclsh8.3:${PORTSDIR}/lang/tcl83
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
MAN1= ns.1
MANCOMPRESSED= no
@@ -33,6 +27,12 @@ CONFIGURE_ARGS= --with-tcl-ver=8.3 --with-tk-ver=8.3
ALL_TARGET=
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/net/ns2/Makefile b/net/ns2/Makefile
index 1b489bdd1339..048394a7da2a 100644
--- a/net/ns2/Makefile
+++ b/net/ns2/Makefile
@@ -17,12 +17,6 @@ COMMENT= The UCB/LBNL Network Simulator Version 2
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
RUN_DEPENDS= ${LOCALBASE}/bin/tclsh8.3:${PORTSDIR}/lang/tcl83
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
MAN1= ns.1
MANCOMPRESSED= no
@@ -33,6 +27,12 @@ CONFIGURE_ARGS= --with-tcl-ver=8.3 --with-tk-ver=8.3
ALL_TARGET=
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 2db96ba3903d..844d9aa5a426 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -24,12 +24,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
RUN_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
# ntop will store its runtime database files in ${DBDIR}/ntop/
DBDIR?= /var/db
@@ -52,6 +46,7 @@ CONFIGURE_ARGS= --localstatedir=${DBDIR} \
CONFIGURE_ARGS+= --enable-tcpwrap
.endif
+.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400014
LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
CONFIGURE_ARGS+= --with-ossl-root=${LOCALBASE}
@@ -60,6 +55,10 @@ CONFIGURE_ARGS+= --with-ossl-root=${LOCALBASE}
MAN1= intop.1
MAN8= ntop.8
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# Remove included dependencies as a precaution against polluting the
# configuration. Not strictly necessary.
pre-configure:
diff --git a/net/oproute/Makefile b/net/oproute/Makefile
index f30ad28ff1e0..59e03db1d3bd 100644
--- a/net/oproute/Makefile
+++ b/net/oproute/Makefile
@@ -15,14 +15,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for measuring general performance of the Internet
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_REINPLACE= yes
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
diff --git a/net/sting/Makefile b/net/sting/Makefile
index ac53a487d007..1a656033832c 100644
--- a/net/sting/Makefile
+++ b/net/sting/Makefile
@@ -14,14 +14,14 @@ DISTNAME= sting
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool that measures end-to-end TCP connection characteristics
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113 || defined(IPFW2)
BROKEN= "Does not work with ipfw2"
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sting ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index 632af7d9e037..804bb8985872 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -14,18 +14,18 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A Motif-based TCP/IP protocol analyzer
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_BISON= yes
USE_MOTIF= yes
USE_REINPLACE= yes
MAN1= tcpview.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-patch:
.for f in nametoaddr.c addrtoname.c print-nfs.c detail-tcp.c tv_addrtoname.c
@${REINPLACE_CMD} -e 's/NTOHL/ntohl/ ; s/NTOHS/ntohs/' ${WRKSRC}/${f}
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 4199ae80f92b..1ccb2a49efc6 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -15,13 +15,13 @@ DISTNAME= tintin++v1.5pl9
MAINTAINER= jhp@cocoja.holywar.net
COMMENT= A client program to help playing muds
+WRKSRC= ${WRKDIR}/tintin++/v1.5/src
+GNU_CONFIGURE= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-WRKSRC= ${WRKDIR}/tintin++/v1.5/src
-GNU_CONFIGURE= yes
-
.include <bsd.port.post.mk>
diff --git a/net/xicq/Makefile b/net/xicq/Makefile
index dbe8e7f38ffb..aa884f07f0a6 100644
--- a/net/xicq/Makefile
+++ b/net/xicq/Makefile
@@ -14,17 +14,17 @@ DISTNAME= xicq-071298-snapshot.src
MAINTAINER= scrappy@FreeBSD.org
COMMENT= Xtropy's ICQ Client
+WRKSRC= ${WRKDIR}/xicq-071298
+
+USE_GMAKE= yes
+MAKE_ENV= OPT="${CFLAGS}"
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-WRKSRC= ${WRKDIR}/xicq-071298
-
-USE_GMAKE= yes
-MAKE_ENV= OPT="${CFLAGS}"
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xicq/main ${PREFIX}/bin/xicq
${MKDIR} ${PREFIX}/share/examples/xicq