aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2007-03-25 03:23:00 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2007-03-25 03:23:00 +0800
commitf9e2ac72e908af9c4dfcd168609f3427dd55e435 (patch)
treeae28879001d309fcbd19d890145c607c0b632f97 /net
parent8b0b837061de138f58fde63ee52cbf7b1fb6c250 (diff)
downloadfreebsd-ports-gnome-f9e2ac72e908af9c4dfcd168609f3427dd55e435.tar.gz
freebsd-ports-gnome-f9e2ac72e908af9c4dfcd168609f3427dd55e435.tar.zst
freebsd-ports-gnome-f9e2ac72e908af9c4dfcd168609f3427dd55e435.zip
Remove non-standard patch to API.
- pcap.inject() can be found in net/pcs's pcs.pcap module. Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/py-pypcap/Makefile2
-rw-r--r--net/py-pypcap/files/patch-pcap.pyx36
2 files changed, 1 insertions, 37 deletions
diff --git a/net/py-pypcap/Makefile b/net/py-pypcap/Makefile
index 12abfdc62772..f84d84e784d4 100644
--- a/net/py-pypcap/Makefile
+++ b/net/py-pypcap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pypcap
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= http://pypcap.googlecode.com/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net/py-pypcap/files/patch-pcap.pyx b/net/py-pypcap/files/patch-pcap.pyx
deleted file mode 100644
index 369a5bc52249..000000000000
--- a/net/py-pypcap/files/patch-pcap.pyx
+++ /dev/null
@@ -1,36 +0,0 @@
-*** pcap.pyx Mon Oct 17 08:00:11 2005
---- /Users/gnn/src/pypcap-1.1.new/pcap.pyx Fri Jun 23 18:22:03 2006
-***************
-*** 61,66 ****
---- 64,70 ----
- int pcap_stats(pcap_t *p, pcap_stat *ps)
- char *pcap_geterr(pcap_t *p)
- void pcap_close(pcap_t *p)
-+ int pcap_inject(pcap_t *p, char *buf, int size)
- int bpf_filter(bpf_insn *insns, char *buf, int len, int caplen)
-
- cdef extern from "pcap_ex.h":
-***************
-*** 313,318 ****
---- 318,338 ----
- elif n == -2:
- break
-
-+ def inject(self, packet, len):
-+ """Inject a packet onto an interface.
-+ May or may not work depending on platform.
-+
-+ Arguments:
-+
-+ packet -- a pointer to the packet in memory
-+ """
-+ cdef int n
-+ n = pcap_inject(self.__pcap, packet, len)
-+ if (n < 0):
-+ raise OSError, pcap_geterr(self.__pcap)
-+
-+ return n
-+
- def geterr(self):
- """Return the last error message associated with this handle."""
- return pcap_geterr(self.__pcap)