aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-11-05 17:07:44 +0800
committerkris <kris@FreeBSD.org>2005-11-05 17:07:44 +0800
commitfd6ea44e7341e5eceafc62d7ff6eec0a45d23321 (patch)
tree839702695a2079fd711fd7410d5347d7c6f267e2 /net
parent1c5ecd19cefacc1ef8c4bf064d043bff0ffe99dc (diff)
downloadfreebsd-ports-gnome-fd6ea44e7341e5eceafc62d7ff6eec0a45d23321.tar.gz
freebsd-ports-gnome-fd6ea44e7341e5eceafc62d7ff6eec0a45d23321.tar.zst
freebsd-ports-gnome-fd6ea44e7341e5eceafc62d7ff6eec0a45d23321.zip
Remove expired ports
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/gnomba/Makefile38
-rw-r--r--net/gnomba/distinfo2
-rw-r--r--net/gnomba/files/patch-ab84
-rw-r--r--net/gnomba/files/patch-samba-Makefile21
-rw-r--r--net/gnomba/files/patch-samba-include-config.h51
-rw-r--r--net/gnomba/pkg-descr10
-rw-r--r--net/gnomba/pkg-plist9
-rw-r--r--net/jabber-xdb_ldap/Makefile41
-rw-r--r--net/jabber-xdb_ldap/distinfo2
-rw-r--r--net/jabber-xdb_ldap/files/patch-Makefile13
-rw-r--r--net/jabber-xdb_ldap/pkg-descr6
-rw-r--r--net/jabber-xdb_ldap/pkg-plist4
13 files changed, 0 insertions, 283 deletions
diff --git a/net/Makefile b/net/Makefile
index 986a3ddf862d..751db8770307 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -197,7 +197,6 @@
SUBDIR += gnetcat
SUBDIR += gnewtellium
SUBDIR += gnoemoe
- SUBDIR += gnomba
SUBDIR += gnome-btdownload
SUBDIR += gnome-jabber
SUBDIR += gnome-mud
@@ -277,7 +276,6 @@
SUBDIR += jabber-pyicq
SUBDIR += jabber-pymsn
SUBDIR += jabber-users-agent
- SUBDIR += jabber-xdb_ldap
SUBDIR += jabber-yahoo
SUBDIR += jabberd
SUBDIR += jags
diff --git a/net/gnomba/Makefile b/net/gnomba/Makefile
deleted file mode 100644
index d0531026314f..000000000000
--- a/net/gnomba/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# New ports collection makefile for: gnomba
-# Date created: 10 January 2000
-# Whom: Dmitry Sivachenko <dima@Chg.RU>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomba
-PORTVERSION= 0.6.2
-PORTREVISION= 2
-CATEGORIES= net gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gnomba
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GNOME compliant browser of SMB shares
-
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
-USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs gnomehier
-USE_PERL5_BUILD=yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-MAN1= gnomba.1
-
-post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
-pre-configure:
- ${RM} ${WRKSRC}/config.cache
-
-.include <bsd.port.mk>
diff --git a/net/gnomba/distinfo b/net/gnomba/distinfo
deleted file mode 100644
index 206d791e0d63..000000000000
--- a/net/gnomba/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gnomba-0.6.2.tar.gz) = 698c40d2755c5b0d467e4de2f2119c0c
-SIZE (gnomba-0.6.2.tar.gz) = 556655
diff --git a/net/gnomba/files/patch-ab b/net/gnomba/files/patch-ab
deleted file mode 100644
index 1f11707005a0..000000000000
--- a/net/gnomba/files/patch-ab
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/properties.c.orig Sat Mar 25 22:15:19 2000
-+++ src/properties.c Sat Mar 25 22:15:42 2000
-@@ -158,19 +158,19 @@
- /* set net font property */
- if (strcmp(TNetFont, NetFont)) {
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(tree)));
-- nodeStyle->font = gdk_font_load(NetFont);
-+ nodeStyle->font = gdk_fontset_load(NetFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(tree), GTK_CTREE_NODE(node), 0, nodeStyle);
- }
- /* set comment font property */
- if (strcmp(TCommentFont, CommentFont)) {
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(tree)));
-- nodeStyle->font = gdk_font_load(CommentFont);
-+ nodeStyle->font = gdk_fontset_load(CommentFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(tree), GTK_CTREE_NODE(node), 1, nodeStyle);
- }
- /* set mount font property */
- if (strcmp(TMountFont, MountFont)) {
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(tree)));
-- nodeStyle->font = gdk_font_load(MountFont);
-+ nodeStyle->font = gdk_fontset_load(MountFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(tree), GTK_CTREE_NODE(node), 2, nodeStyle);
- }
- }
---- src/smbwrap.c.orig Sun Jun 16 13:10:26 2002
-+++ src/smbwrap.c Sun Jun 16 13:12:44 2002
-@@ -246,17 +246,17 @@
-
- /* set net font */
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(workgrouplist)));
-- nodeStyle->font = gdk_font_load(NetFont);
-+ nodeStyle->font = gdk_fontset_load(NetFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(workgrouplist), GTK_CTREE_NODE(node), 0, nodeStyle);
-
- /* set comment font */
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(workgrouplist)));
-- nodeStyle->font = gdk_font_load(CommentFont);
-+ nodeStyle->font = gdk_fontset_load(CommentFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(workgrouplist), GTK_CTREE_NODE(node), 1, nodeStyle);
-
- /* set mount font */
- nodeStyle = gtk_style_copy(gtk_widget_get_style(GTK_WIDGET(workgrouplist)));
-- nodeStyle->font = gdk_font_load(MountFont);
-+ nodeStyle->font = gdk_fontset_load(MountFont);
- gtk_ctree_node_set_cell_style(GTK_CTREE(workgrouplist), GTK_CTREE_NODE(node), 2, nodeStyle);
-
- mn = copyMN(currnode);
-@@ -629,17 +629,17 @@
-
- /* set net font */
- nodeStyle1 = gtk_style_copy( gtk_widget_get_style( GTK_WIDGET(workgrouplist) ) );
-- nodeStyle1->font = gdk_font_load( NetFont );
-+ nodeStyle1->font = gdk_fontset_load( NetFont );
- gtk_ctree_node_set_cell_style( GTK_CTREE(workgrouplist), GTK_CTREE_NODE(rootnode), 0, nodeStyle1 );
-
- /* set comment font */
- nodeStyle2 = gtk_style_copy( gtk_widget_get_style( GTK_WIDGET(workgrouplist) ) );
-- nodeStyle2->font = gdk_font_load( CommentFont );
-+ nodeStyle2->font = gdk_fontset_load( CommentFont );
- gtk_ctree_node_set_cell_style( GTK_CTREE(workgrouplist), GTK_CTREE_NODE(rootnode), 1, nodeStyle2 );
-
- /* set mount font */
- nodeStyle3 = gtk_style_copy( gtk_widget_get_style( GTK_WIDGET(workgrouplist) ) );
-- nodeStyle3->font = gdk_font_load( MountFont );
-+ nodeStyle3->font = gdk_fontset_load( MountFont );
- gtk_ctree_node_set_cell_style( GTK_CTREE(workgrouplist), GTK_CTREE_NODE(rootnode), 2, nodeStyle3 );
-
-
---- src/gnomba.c.orig Sun Jun 16 13:09:45 2002
-+++ src/gnomba.c Sun Jun 16 13:10:08 2002
-@@ -133,9 +133,9 @@
- DefaultCommand = gnome_config_get_string("Options/DefaultCommand=gmc");
- SilentlyCreateMountPoint = gnome_config_get_int ("Options/SilentlyCreateMountPoint=0");
- DontRemoveCreatedMount = gnome_config_get_int ("Options/DontRemoveCreatedMount=0");
-- NetFont = gnome_config_get_string("Options/NetFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1");
-- CommentFont = gnome_config_get_string("Options/CommentFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1");
-- MountFont = gnome_config_get_string("Options/MountFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1");
-+ NetFont = gnome_config_get_string("Options/NetFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1,*");
-+ CommentFont = gnome_config_get_string("Options/CommentFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1,*");
-+ MountFont = gnome_config_get_string("Options/MountFont=-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1,*");
- gnome_config_pop_prefix();
-
- /*create the containers*/
diff --git a/net/gnomba/files/patch-samba-Makefile b/net/gnomba/files/patch-samba-Makefile
deleted file mode 100644
index abccde09040e..000000000000
--- a/net/gnomba/files/patch-samba-Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
---- samba/Makefile.orig Sun Jun 16 13:32:01 2002
-+++ samba/Makefile Sun Jun 16 13:34:56 2002
-@@ -1,13 +1,13 @@
- #this should default to something and then be set by configure switches
--prefix=/usr/local/samba
-+prefix=${LOCALBASE}
- exec_prefix=${prefix}
--LIBDIR = ${exec_prefix}/lib
-+LIBDIR = ${exec_prefix}/etc
- LMHOSTSFILE = $(LIBDIR)/lmhosts
- CODEPAGEDIR = $(LIBDIR)/codepages
--SMBRUN = $(BINDIR)/smbrun
-+SMBRUN = $(prefix)/bin/smbrun
- DRIVERFILE = $(LIBDIR)/printers.def
--SMB_PASSWD_FILE = $(PRIVATEDIR)/smbpasswd
--PASSWD_PROGRAM = /bin/passwd
-+SMB_PASSWD_FILE = $(prefix)/private/smbpasswd
-+PASSWD_PROGRAM = /usr/bin/passwd
-
-
- LIB_OBJ = lib/charcnv.o lib/charset.o lib/debug.o \
diff --git a/net/gnomba/files/patch-samba-include-config.h b/net/gnomba/files/patch-samba-include-config.h
deleted file mode 100644
index 51401efe1f14..000000000000
--- a/net/gnomba/files/patch-samba-include-config.h
+++ /dev/null
@@ -1,51 +0,0 @@
---- samba/include/config.h.orig Fri Jun 14 00:44:17 2002
-+++ samba/include/config.h Fri Jun 14 00:42:22 2002
-@@ -106,7 +106,7 @@
- /* #undef FTRUNCATE_NEEDS_ROOT */
- /* #undef HAVE_TRAPDOOR_UID */
- /* #undef HAVE_ROOT */
--/* #undef HAVE_UNION_SEMUN */
-+#define HAVE_UNION_SEMUN 1
- #define HAVE_GETTIMEOFDAY_TZ 1
- /* #undef HAVE_SOCK_SIN_LEN */
- /* #undef STAT_READ_FILSYS */
-@@ -745,7 +745,7 @@
- #define HAVE_SECURITY_PAM_APPL_H 1
-
- /* Define if you have the <shadow.h> header file. */
--#define HAVE_SHADOW_H 1
-+#undef HAVE_SHADOW_H
-
- /* Define if you have the <stdarg.h> header file. */
- #define HAVE_STDARG_H 1
-@@ -760,7 +760,7 @@
- #define HAVE_STRINGS_H 1
-
- /* Define if you have the <stropts.h> header file. */
--#define HAVE_STROPTS_H 1
-+#undef HAVE_STROPTS_H
-
- /* Define if you have the <sys/acl.h> header file. */
- /* #undef HAVE_SYS_ACL_H */
-@@ -829,10 +829,10 @@
- /* #undef HAVE_SYS_SOCKIO_H */
-
- /* Define if you have the <sys/statfs.h> header file. */
--#define HAVE_SYS_STATFS_H 1
-+#undef HAVE_SYS_STATFS_H
-
- /* Define if you have the <sys/statvfs.h> header file. */
--#define HAVE_SYS_STATVFS_H 1
-+#undef HAVE_SYS_STATVFS_H
-
- /* Define if you have the <sys/syscall.h> header file. */
- #define HAVE_SYS_SYSCALL_H 1
-@@ -847,7 +847,7 @@
- #define HAVE_SYS_UNISTD_H 1
-
- /* Define if you have the <sys/vfs.h> header file. */
--#define HAVE_SYS_VFS_H 1
-+#undef HAVE_SYS_VFS_H
-
- /* Define if you have the <sys/wait.h> header file. */
- #define HAVE_SYS_WAIT_H 1
diff --git a/net/gnomba/pkg-descr b/net/gnomba/pkg-descr
deleted file mode 100644
index 880063604d0c..000000000000
--- a/net/gnomba/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Gnomba is a stab at writing a GUI machine and share browser for the smb
-protocol. Gnomba allows you to scan any number of subnets for machines
-with smb. The workgroups, machines and share are shown in a tree-view.
-For each machine you can then view the list of shares, and mount, unmount
-or browse them.
-
-WWW: http://gnomba.sourceforge.net/
-
-Dmitry Sivachenko,
-dima@Chg.RU
diff --git a/net/gnomba/pkg-plist b/net/gnomba/pkg-plist
deleted file mode 100644
index 7a916d11d2ad..000000000000
--- a/net/gnomba/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/gnomba
-share/gnome/apps/Internet/gnomba.desktop
-share/gnome/pixmaps/gnome-gnomba.png
-share/locale/fr/LC_MESSAGES/gnomba.mo
-share/locale/ja/LC_MESSAGES/gnomba.mo
-share/locale/ko/LC_MESSAGES/gnomba.mo
-share/locale/pl/LC_MESSAGES/gnomba.mo
-share/locale/ru/LC_MESSAGES/gnomba.mo
-share/locale/wa/LC_MESSAGES/gnomba.mo
diff --git a/net/jabber-xdb_ldap/Makefile b/net/jabber-xdb_ldap/Makefile
deleted file mode 100644
index 3f479dbaec80..000000000000
--- a/net/jabber-xdb_ldap/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: jabber-xdb_ldap
-# Date created: 03 January 2004
-# Whom: Martijn Lina <martijn@pacno.net>
-#
-# $FreeBSD$
-
-PORTNAME= xdb_ldap
-PORTVERSION= 1.0
-PORTREVISION= 2
-CATEGORIES= net
-MASTER_SITES= http://www.jabberstudio.org/files/xdb_ldap/
-PKGNAMEPREFIX= jabber-
-DIST_SUBDIR= jabber
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Jabber xdb backend for an LDAP directory
-
-BUILD_DEPENDS= ${NON_EXISTENT}:${PORTSDIR}/net/jabber:configure
-
-USE_GMAKE= yes
-USE_OPENLDAP= yes
-
-FORBIDDEN= "Site is down after intrusion. Probably this project will never be revived"
-DEPRECATED= ${FORBIDDEN}
-EXPIRATION_DATE= 2005-09-28
-
-WRKSRC= ${WRKDIR}/${PORTNAME}/src
-
-.include <bsd.port.pre.mk>
-
-JABBER_SRC!= cd ${PORTSDIR}/net/jabber && make -V WRKSRC
-MAKE_ENV= JABBER_SRC=${JABBER_SRC}
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/jabber
- ${INSTALL_DATA} ${WRKSRC}/xdb_ldap.so ${PREFIX}/lib/jabber/
- ${INSTALL_DATA} ${WRKSRC}/../jabber-xdb.xml ${PREFIX}/etc/jabber-xdb.xml.sample
- ${MKDIR} ${PREFIX}/etc/openldap/schema
- ${INSTALL_DATA} ${WRKSRC}/../jabber.schema ${PREFIX}/etc/openldap/schema/jabber.schema.default
-
-.include <bsd.port.post.mk>
diff --git a/net/jabber-xdb_ldap/distinfo b/net/jabber-xdb_ldap/distinfo
deleted file mode 100644
index 95188635e052..000000000000
--- a/net/jabber-xdb_ldap/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (jabber/xdb_ldap-1.0.tar.gz) = 373f0f780c725cc06c824e322fc694ff
-SIZE (jabber/xdb_ldap-1.0.tar.gz) = 112204
diff --git a/net/jabber-xdb_ldap/files/patch-Makefile b/net/jabber-xdb_ldap/files/patch-Makefile
deleted file mode 100644
index e7a56d1a5505..000000000000
--- a/net/jabber-xdb_ldap/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Wed Jul 24 17:42:25 2002
-+++ Makefile Sat Nov 29 18:35:35 2003
-@@ -1,7 +1,7 @@
--include ../../platform-settings
-+include ${JABBER_SRC}/platform-settings
-
--CFLAGS:=$(CFLAGS) -I../../jabberd -I../include
--LIBS:=$(LIBS) -lresolv -lldap -llber
-+CFLAGS:=$(CFLAGS) -I${JABBER_SRC}/jabberd -I../include -I/usr/local/include
-+LIBS:=$(LIBS) -L/usr/local/lib -lldap -llber
- xdb_ldap_OBJECTS = xdb_ldap.o \
- xdb_ldap_common.o \
- xdb_ldap_auth.o \
diff --git a/net/jabber-xdb_ldap/pkg-descr b/net/jabber-xdb_ldap/pkg-descr
deleted file mode 100644
index 8a8bf540873f..000000000000
--- a/net/jabber-xdb_ldap/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-The Jabber server (jabberd) is a daemon for Jabber clients to connect
-and communicate with. xdb_ldap allows you to store the jabber data in
-an LDAP directory
-
-You can learn more about Jabber at:
-WWW: http://www.jabber.org/
diff --git a/net/jabber-xdb_ldap/pkg-plist b/net/jabber-xdb_ldap/pkg-plist
deleted file mode 100644
index a68b98f619f4..000000000000
--- a/net/jabber-xdb_ldap/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-lib/jabber/xdb_ldap.so
-etc/jabber-xdb.xml.sample
-etc/openldap/schema/jabber.schema.default
-@unexec rmdir %D/etc/openldap/schema 2> /dev/null || true