aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-10-10 04:57:26 +0800
committerpawel <pawel@FreeBSD.org>2015-10-10 04:57:26 +0800
commit50504a0171c339475a41f801d138927f71036f02 (patch)
tree7a7dca33428513d84b8fd890b258eb201a4379b5 /net
parentd5ffe9db2dcd111876489d8847c2941be9353edc (diff)
downloadfreebsd-ports-gnome-50504a0171c339475a41f801d138927f71036f02.tar.gz
freebsd-ports-gnome-50504a0171c339475a41f801d138927f71036f02.tar.zst
freebsd-ports-gnome-50504a0171c339475a41f801d138927f71036f02.zip
This module offers a simple interface to query NTP
servers from Python. It also provides utility functions to translate NTP fields values to text (mode, leap indicator...). Since it's pure Python, and only depends on core modules, it should work on any platform with a Python implementation. WWW: https://pypi.python.org/pypi/ntplib PR: 202525 Submitted by: uros@gruber.si
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-ntplib/Makefile19
-rw-r--r--net/py-ntplib/distinfo2
-rw-r--r--net/py-ntplib/pkg-descr9
4 files changed, 31 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2d3a923a5ee1..ffcbf252f539 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -945,6 +945,7 @@
SUBDIR += py-netlib
SUBDIR += py-netstring
SUBDIR += py-novaclient
+ SUBDIR += py-ntplib
SUBDIR += py-oauth
SUBDIR += py-oauth2
SUBDIR += py-paho-mqtt
diff --git a/net/py-ntplib/Makefile b/net/py-ntplib/Makefile
new file mode 100644
index 000000000000..924044294ae2
--- /dev/null
+++ b/net/py-ntplib/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= ntplib
+PORTVERSION= 0.3.3
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= uros@gruber.si
+COMMENT= Python NTP library
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-ntplib/distinfo b/net/py-ntplib/distinfo
new file mode 100644
index 000000000000..d081a6cf1c4b
--- /dev/null
+++ b/net/py-ntplib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ntplib-0.3.3.tar.gz) = c4621b64d50be9461d9bd9a71ba0b4af06fbbf818bbd483752d95c1a4e273ede
+SIZE (ntplib-0.3.3.tar.gz) = 6808
diff --git a/net/py-ntplib/pkg-descr b/net/py-ntplib/pkg-descr
new file mode 100644
index 000000000000..b3ddad8c9715
--- /dev/null
+++ b/net/py-ntplib/pkg-descr
@@ -0,0 +1,9 @@
+This module offers a simple interface to query NTP
+servers from Python.
+
+It also provides utility functions to translate NTP
+fields values to text (mode, leap indicator...). Since
+it's pure Python, and only depends on core modules,
+it should work on any platform with a Python implementation.
+
+WWW: https://pypi.python.org/pypi/ntplib