aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-10-19 19:06:50 +0800
committerkoobs <koobs@FreeBSD.org>2015-10-19 19:06:50 +0800
commit940c05de6ccb6435fe903e3250478ce988c5e029 (patch)
tree3301006c131e2fe33b5e5731f5859d50dd802cc2 /net
parent7a8fbdde566f97c469628ceabca8086b4e26c9aa (diff)
downloadfreebsd-ports-gnome-940c05de6ccb6435fe903e3250478ce988c5e029.tar.gz
freebsd-ports-gnome-940c05de6ccb6435fe903e3250478ce988c5e029.tar.zst
freebsd-ports-gnome-940c05de6ccb6435fe903e3250478ce988c5e029.zip
net/turnserver: Fix build with No-SSLv3
turnserver will not build if OpenSSL was built without SSLv3 (--no-ssl3). LibreSSL 2.3.0 has removed SSLv3 support completely. This change fixes the build when SSLv3 is not available While I'm here, add LICENSE_FILE PR: 203700 Submitted by: cpbsdmail gmail com Approved by: mom040267 gmail com (maintainer) MFH: 2014Q4
Diffstat (limited to 'net')
-rw-r--r--net/turnserver/Makefile2
-rw-r--r--net/turnserver/files/patch-src_apps_common_apputils.c21
-rw-r--r--net/turnserver/files/patch-src_apps_uclient_mainuclient.c14
3 files changed, 37 insertions, 0 deletions
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index 893356f474e8..ab4bc1f7bfbd 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= turnserver
PORTVERSION= 4.5.0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/:prog \
http://turnserver.open-sys.org/downloads/extradocs/:xdocs \
@@ -15,6 +16,7 @@ MAINTAINER= mom040267@gmail.com
COMMENT= STUN/TURN Server; IPv6, DTLS support; RFCs 5389, 5766, 6062, 6156
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
diff --git a/net/turnserver/files/patch-src_apps_common_apputils.c b/net/turnserver/files/patch-src_apps_common_apputils.c
new file mode 100644
index 000000000000..da72f8da02a5
--- /dev/null
+++ b/net/turnserver/files/patch-src_apps_common_apputils.c
@@ -0,0 +1,21 @@
+--- src/apps/common/apputils.c.orig 2015-09-30 07:05:14 UTC
++++ src/apps/common/apputils.c
+@@ -1037,13 +1037,15 @@ static const char* turn_get_method(const
+ if(!method)
+ return mdefault;
+ else {
+-
++#ifndef OPENSSL_NO_SSL3
+ if(method == SSLv3_server_method()) {
+ return "SSLv3";
+ } else if(method == SSLv3_client_method()) {
+ return "SSLv3";
+- } else if(method == SSLv23_server_method()) {
+- return "SSLv23";
++ } else
++#endif
++ if(method == SSLv23_server_method()) {
++ return "SSLv23";
+ } else if(method == SSLv23_client_method()) {
+ return "SSLv23";
+ } else if(method == TLSv1_server_method()) {
diff --git a/net/turnserver/files/patch-src_apps_uclient_mainuclient.c b/net/turnserver/files/patch-src_apps_uclient_mainuclient.c
new file mode 100644
index 000000000000..09b04d2e4c23
--- /dev/null
+++ b/net/turnserver/files/patch-src_apps_uclient_mainuclient.c
@@ -0,0 +1,14 @@
+--- src/apps/uclient/mainuclient.c.orig 2015-09-30 07:05:14 UTC
++++ src/apps/uclient/mainuclient.c
+@@ -483,9 +483,11 @@ int main(int argc, char **argv)
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(SSLv23_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;
++#ifndef OPENSSL_NO_SSL3
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(SSLv3_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;
++#endif
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(TLSv1_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;