aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-12-28 10:35:55 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-12-28 10:35:55 +0800
commit9f67528d5dd3b11d961e2d1ef2897bc747ab5a0a (patch)
tree1882565788e0552967cf102856b2c02887fc0920 /net
parentfc1286d1612baeab736787352447e07349eca8bc (diff)
downloadfreebsd-ports-gnome-9f67528d5dd3b11d961e2d1ef2897bc747ab5a0a.tar.gz
freebsd-ports-gnome-9f67528d5dd3b11d961e2d1ef2897bc747ab5a0a.tar.zst
freebsd-ports-gnome-9f67528d5dd3b11d961e2d1ef2897bc747ab5a0a.zip
net/openbsc: remove hard requirement on LibreSSL introduced in r402149
PR: 205399 Submitted by: Nikola Kolev <koue@chaosophia.net> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/openbsc/Makefile5
-rw-r--r--net/openbsc/files/patch-configure.ac14
2 files changed, 16 insertions, 3 deletions
diff --git a/net/openbsc/Makefile b/net/openbsc/Makefile
index 4c7f5e1f7dfe..dce55a29c711 100644
--- a/net/openbsc/Makefile
+++ b/net/openbsc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openbsc
PORTVERSION= 0.15.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://git.osmocom.org/${PORTNAME}/snapshot/ \
http://chaosophia.net/downloads/osmocom/${PORTNAME}/
@@ -21,9 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
USES= autoreconf compiler:c11 gmake pkgconfig
USE_OPENSSL= yes
-WITH_OPENSSL_PORT=yes
-OPENSSL_PORT= security/libressl
-GNU_CONFIGURE=yes
+GNU_CONFIGURE= yes
AUTOMAKE_ARGS= --gnu --add-missing --copy
CONFIGURE_ARGS+= CFLAGS="-I${LOCALBASE}/include"
diff --git a/net/openbsc/files/patch-configure.ac b/net/openbsc/files/patch-configure.ac
new file mode 100644
index 000000000000..a592fdeb5cee
--- /dev/null
+++ b/net/openbsc/files/patch-configure.ac
@@ -0,0 +1,14 @@
+--- configure.ac.orig 2015-12-18 14:09:38 UTC
++++ configure.ac
+@@ -27,7 +27,10 @@ PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm
+ PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.2.0)
+ PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 0.6.4)
+ PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 0.0.1)
+-PKG_CHECK_MODULES(LIBCRYPTO, libcrypto >= 0.9.5)
++#PKG_CHECK_MODULES(LIBCRYPTO, libcrypto >= 0.9.5)
++AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
++ [AC_MSG_FAILURE([can't find openssl crypto lib])]
++ [])
+
+ # Enabke/disable the NAT?
+ AC_ARG_ENABLE([nat], [AS_HELP_STRING([--enable-nat], [Build the BSC NAT. Requires SCCP])],