aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-02-16 00:59:19 +0800
committertz <tz@FreeBSD.org>2018-02-16 00:59:19 +0800
commita1eed484a5621dbfd4335902cec6e1fd6b367bf4 (patch)
treee3647963dc11c29bf9118c28d7995ff16782c4e5 /net
parentf58fb932b7f7839f16d87edc314fb0e542a99355 (diff)
downloadfreebsd-ports-gnome-a1eed484a5621dbfd4335902cec6e1fd6b367bf4.tar.gz
freebsd-ports-gnome-a1eed484a5621dbfd4335902cec6e1fd6b367bf4.tar.zst
freebsd-ports-gnome-a1eed484a5621dbfd4335902cec6e1fd6b367bf4.zip
Bring back dependencies needed to prepare the update of www/gitlab to 10.4
Submitted by: Matthias Fechner <idefix@fechner.net> Reviewed by: swills, tz
Diffstat (limited to 'net')
-rw-r--r--net/Makefile5
-rw-r--r--net/rubygem-asset_sync220/Makefile27
-rw-r--r--net/rubygem-asset_sync220/distinfo3
-rw-r--r--net/rubygem-asset_sync220/pkg-descr9
-rw-r--r--net/rubygem-fog-google0/Makefile25
-rw-r--r--net/rubygem-fog-google0/distinfo3
-rw-r--r--net/rubygem-fog-google0/pkg-descr4
-rw-r--r--net/rubygem-octokit46/Makefile23
-rw-r--r--net/rubygem-octokit46/distinfo3
-rw-r--r--net/rubygem-octokit46/pkg-descr3
-rw-r--r--net/rubygem-omniauth-auth014/Makefile22
-rw-r--r--net/rubygem-omniauth-auth014/distinfo3
-rw-r--r--net/rubygem-omniauth-auth014/pkg-descr8
-rw-r--r--net/rubygem-omniauth-twitter12/Makefile24
-rw-r--r--net/rubygem-omniauth-twitter12/distinfo3
-rw-r--r--net/rubygem-omniauth-twitter12/pkg-descr3
16 files changed, 168 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2c3507b73b91..4c7f336b2c60 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1160,6 +1160,7 @@
SUBDIR += rubygem-amqp
SUBDIR += rubygem-amqp-utils
SUBDIR += rubygem-asset_sync
+ SUBDIR += rubygem-asset_sync220
SUBDIR += rubygem-aws-s3
SUBDIR += rubygem-aws-ses
SUBDIR += rubygem-azure
@@ -1186,6 +1187,7 @@
SUBDIR += rubygem-fog-dynect
SUBDIR += rubygem-fog-ecloud
SUBDIR += rubygem-fog-google
+ SUBDIR += rubygem-fog-google0
SUBDIR += rubygem-fog-internet-archive
SUBDIR += rubygem-fog-joyent
SUBDIR += rubygem-fog-local
@@ -1226,8 +1228,10 @@
SUBDIR += rubygem-oauth
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-octokit
+ SUBDIR += rubygem-octokit46
SUBDIR += rubygem-octopress-deploy
SUBDIR += rubygem-omniauth-auth0
+ SUBDIR += rubygem-omniauth-auth014
SUBDIR += rubygem-omniauth-authentiq
SUBDIR += rubygem-omniauth-azure-oauth2
SUBDIR += rubygem-omniauth-facebook
@@ -1240,6 +1244,7 @@
SUBDIR += rubygem-omniauth-oauth2
SUBDIR += rubygem-omniauth-openid
SUBDIR += rubygem-omniauth-twitter
+ SUBDIR += rubygem-omniauth-twitter12
SUBDIR += rubygem-open-uri-cached
SUBDIR += rubygem-opennebula
SUBDIR += rubygem-packetfu
diff --git a/net/rubygem-asset_sync220/Makefile b/net/rubygem-asset_sync220/Makefile
new file mode 100644
index 000000000000..461cb6c10c0a
--- /dev/null
+++ b/net/rubygem-asset_sync220/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= asset_sync
+PORTVERSION= 2.2.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 220
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Synchronizes Assets between Rails and S3
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-activemodel4>=4.1.0:databases/rubygem-activemodel4 \
+ rubygem-fog-core>=0:devel/rubygem-fog-core \
+ rubygem-mime-types>=2.99:misc/rubygem-mime-types \
+ rubygem-unf>=0:textproc/rubygem-unf
+
+CONFLICT_INSTALL= asset_sync
+
+PORTSCOUT= limit:^2\.2\.
+
+USES= gem
+NO_ARCH= yes
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-asset_sync220/distinfo b/net/rubygem-asset_sync220/distinfo
new file mode 100644
index 000000000000..ebede1c6d453
--- /dev/null
+++ b/net/rubygem-asset_sync220/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516800458
+SHA256 (rubygem/asset_sync-2.2.0.gem) = e026505a070dff642a8508c3fa4d76a6194031ebb2c8311abd2bacb82cc69610
+SIZE (rubygem/asset_sync-2.2.0.gem) = 34816
diff --git a/net/rubygem-asset_sync220/pkg-descr b/net/rubygem-asset_sync220/pkg-descr
new file mode 100644
index 000000000000..e45398c2742a
--- /dev/null
+++ b/net/rubygem-asset_sync220/pkg-descr
@@ -0,0 +1,9 @@
+Asset Sync is built to run with the new Rails Asset Pipeline feature introduced
+in Rails 3.1. After you run bundle exec rake assets:precompile your assets will
+be synchronised to your S3 bucket, optionally deleting unused files and only
+uploading the files it needs to.
+
+This was initially built and is intended to work on Heroku but can work on any
+platform.
+
+WWW: https://github.com/AssetSync/asset_sync
diff --git a/net/rubygem-fog-google0/Makefile b/net/rubygem-fog-google0/Makefile
new file mode 100644
index 000000000000..b09b5a030d8b
--- /dev/null
+++ b/net/rubygem-fog-google0/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= fog-google
+PORTVERSION= 0.6.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 0
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Module for the 'fog' gem to support Google Cloud
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-fog-core>=0:devel/rubygem-fog-core \
+ rubygem-fog-json>=0:devel/rubygem-fog-json \
+ rubygem-fog-xml>=0:textproc/rubygem-fog-xml
+
+PORTSCOUT= limit:^0\.
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-fog-google0/distinfo b/net/rubygem-fog-google0/distinfo
new file mode 100644
index 000000000000..cef861287a89
--- /dev/null
+++ b/net/rubygem-fog-google0/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517652626
+SHA256 (rubygem/fog-google-0.6.0.gem) = 6cd753ae642f17f631597b5ed6732b5d72c5f27b670ceddf1b70c15a368e4652
+SIZE (rubygem/fog-google-0.6.0.gem) = 141312
diff --git a/net/rubygem-fog-google0/pkg-descr b/net/rubygem-fog-google0/pkg-descr
new file mode 100644
index 000000000000..963d8ec6cc87
--- /dev/null
+++ b/net/rubygem-fog-google0/pkg-descr
@@ -0,0 +1,4 @@
+Fog currently supports two Google Cloud services (Google Compute Engine and
+Google Cloud Storage) via Fog::Google.
+
+WWW: https://github.com/fog/fog-google
diff --git a/net/rubygem-octokit46/Makefile b/net/rubygem-octokit46/Makefile
new file mode 100644
index 000000000000..09af8839caf3
--- /dev/null
+++ b/net/rubygem-octokit46/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= octokit
+PORTVERSION= 4.6.2
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 46
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Simple wrapper for the GitHub API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-sawyer>=0.8.0:www/rubygem-sawyer
+
+PORTSCOUT= limit=^4\.6
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-octokit46/distinfo b/net/rubygem-octokit46/distinfo
new file mode 100644
index 000000000000..540be64a2e13
--- /dev/null
+++ b/net/rubygem-octokit46/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518180561
+SHA256 (rubygem/octokit-4.6.2.gem) = edcacd3102497dd2f99f0e60309ada82f4a987a7cd98a51b5bd455840173f7ae
+SIZE (rubygem/octokit-4.6.2.gem) = 72192
diff --git a/net/rubygem-octokit46/pkg-descr b/net/rubygem-octokit46/pkg-descr
new file mode 100644
index 000000000000..817a5aa879e3
--- /dev/null
+++ b/net/rubygem-octokit46/pkg-descr
@@ -0,0 +1,3 @@
+Simple wrapper for the GitHub API
+
+WWW: https://github.com/octokit/octokit.rb
diff --git a/net/rubygem-omniauth-auth014/Makefile b/net/rubygem-omniauth-auth014/Makefile
new file mode 100644
index 000000000000..b4fa5a1c3d75
--- /dev/null
+++ b/net/rubygem-omniauth-auth014/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-auth0
+PORTVERSION= 1.4.2
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 14
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Authentication broker supporting different identity providers
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.1:net/rubygem-omniauth-oauth2
+
+PORTSCOUNT= limit:1\.4
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-auth014/distinfo b/net/rubygem-omniauth-auth014/distinfo
new file mode 100644
index 000000000000..eb664162f3a3
--- /dev/null
+++ b/net/rubygem-omniauth-auth014/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517650472
+SHA256 (rubygem/omniauth-auth0-1.4.2.gem) = 83641503d1733f2bdd74a97347f542233bc282639f32fc3c2be097338ac2861d
+SIZE (rubygem/omniauth-auth0-1.4.2.gem) = 168960
diff --git a/net/rubygem-omniauth-auth014/pkg-descr b/net/rubygem-omniauth-auth014/pkg-descr
new file mode 100644
index 000000000000..abf028980c28
--- /dev/null
+++ b/net/rubygem-omniauth-auth014/pkg-descr
@@ -0,0 +1,8 @@
+Auth0 is an authentication broker that supports social identity
+providers as well as enterprise identity providers such as Active
+Directory, LDAP, Google Apps, Salesforce. OmniAuth is a library
+that standardizes multi-provider authentication for web applications.
+It was created to be powerful, flexible, and do as little as possible.
+omniauth-auth0 is the omniauth strategy for Auth0.
+
+WWW: https://github.com/auth0/omniauth-auth0
diff --git a/net/rubygem-omniauth-twitter12/Makefile b/net/rubygem-omniauth-twitter12/Makefile
new file mode 100644
index 000000000000..5d4589e78510
--- /dev/null
+++ b/net/rubygem-omniauth-twitter12/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-twitter
+PORTVERSION= 1.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 12
+
+MAINTAINER= idefix@fechner.net
+COMMENT= OmniAuth strategy for Twitter
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-json1>=1.3:devel/rubygem-json1 \
+ rubygem-omniauth-oauth>=1.1:net/rubygem-omniauth-oauth \
+ rubygem-rack>=0:www/rubygem-rack
+
+PORTSCOUT= limit:1\.2
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-twitter12/distinfo b/net/rubygem-omniauth-twitter12/distinfo
new file mode 100644
index 000000000000..2b0d9e973a72
--- /dev/null
+++ b/net/rubygem-omniauth-twitter12/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517651530
+SHA256 (rubygem/omniauth-twitter-1.2.1.gem) = 63a04601a57c40f031b285c900800ba4cf49e69d772026821ef782fec3ba12c3
+SIZE (rubygem/omniauth-twitter-1.2.1.gem) = 11264
diff --git a/net/rubygem-omniauth-twitter12/pkg-descr b/net/rubygem-omniauth-twitter12/pkg-descr
new file mode 100644
index 000000000000..e50ae1c50112
--- /dev/null
+++ b/net/rubygem-omniauth-twitter12/pkg-descr
@@ -0,0 +1,3 @@
+OmniAuth strategy for Twitter
+
+WWW: https://github.com/arunagw/omniauth-twitter