aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-03 23:05:37 +0800
committerkrion <krion@FreeBSD.org>2004-01-03 23:05:37 +0800
commitb46f02687bc20dbecf3444b55f993992dffb0f13 (patch)
tree60685b050cd734a6fc1264ff71f33d6f284bd250 /net
parentfc46ce4a6d6bb70f8edecf8b94901dfe6647abca (diff)
downloadfreebsd-ports-gnome-b46f02687bc20dbecf3444b55f993992dffb0f13.tar.gz
freebsd-ports-gnome-b46f02687bc20dbecf3444b55f993992dffb0f13.tar.zst
freebsd-ports-gnome-b46f02687bc20dbecf3444b55f993992dffb0f13.zip
Add silky 0.4.2, a simple and easy to use graphical,
os-independent SILC client. Silky is intended to contain all necessary features of a SILC client, while keeping the UI as simple and clean as possible. PR: 60849 Submitted by: Evgueni V. Gavrilov <aquatique@rusunix.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/silky/Makefile40
-rw-r--r--net/silky/distinfo1
-rw-r--r--net/silky/pkg-descr6
-rw-r--r--net/silky/pkg-plist23
5 files changed, 71 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b3840f79f3c4..e0b2293f3a75 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -656,6 +656,7 @@
SUBDIR += sharity-light
SUBDIR += silc-client
SUBDIR += silc-server
+ SUBDIR += silky
SUBDIR += simicq
SUBDIR += sing
SUBDIR += sipcalc
diff --git a/net/silky/Makefile b/net/silky/Makefile
new file mode 100644
index 000000000000..54f9aca59863
--- /dev/null
+++ b/net/silky/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: silky
+# Date created: 2003.12.16
+# Whom: Evgueni V. Gavrilov <aquatique@rusunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silky
+PORTVERSION= 0.4.2
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://rusunix.org/pub/FreeBSD/distfiles/
+MASTER_SITE_SUBDIR= silky
+
+MAINTAINER= aquatique@rusunix.org
+COMMENT= A simple and easy to use graphical, os-independent SILC client
+
+LIB_DEPENDS= silcclient-1.0.2:${PORTSDIR}/devel/silc-toolkit
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-silc-includes=${LOCALBASE}/include/silc \
+ --with-silc-libs=${LOCALBASE}/lib \
+ --with-docdir=${DOCSDIR}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_X_PREFIX= yes
+
+post-patch:
+ @${PERL} -pi -e 's/ include / /' ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's|/etc/|${LOCALBASE}/etc/|' ${WRKSRC}/src/main.c
+ @${PERL} -pi -e 's|share/pixmaps/\$${\w+}|share/pixmaps/|; \
+ s|(PACKAGE_PIXMAPS_DIR \")\$${packageprefix}/|\1${X11BASE}/|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/net/silky/distinfo b/net/silky/distinfo
new file mode 100644
index 000000000000..4260052e5bb5
--- /dev/null
+++ b/net/silky/distinfo
@@ -0,0 +1 @@
+MD5 (silky-0.4.2.tar.gz) = 71de654fdbb73e01ffb39aaf30ac0cce
diff --git a/net/silky/pkg-descr b/net/silky/pkg-descr
new file mode 100644
index 000000000000..358691653deb
--- /dev/null
+++ b/net/silky/pkg-descr
@@ -0,0 +1,6 @@
+Silky is a simple and easy to use graphical, os-independent SILC client.
+
+Silky is intended to contain all necessary features of a SILC client,
+while keeping the UI as simple and clean as possible.
+
+WWW: http://silky.sourceforge.net
diff --git a/net/silky/pkg-plist b/net/silky/pkg-plist
new file mode 100644
index 000000000000..07f404261e31
--- /dev/null
+++ b/net/silky/pkg-plist
@@ -0,0 +1,23 @@
+bin/silky
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/pixmaps/silky_icon.png
+share/silky/silky.glade
+share/silky/silky-channel.glade
+share/silky/silky-channel-label.glade
+share/silky/silky-query.glade
+share/silky/silky-query-label.glade
+share/locale/de/LC_MESSAGES/silky.mo
+share/locale/fi/LC_MESSAGES/silky.mo
+share/locale/it/LC_MESSAGES/silky.mo
+share/locale/sk/LC_MESSAGES/silky.mo
+share/locale/ru/LC_MESSAGES/silky.mo
+share/gnome/apps/Applications/silky.desktop
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+@dirrm share/silky