aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-04-08 00:32:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-04-08 00:32:07 +0800
commitb98eb5791615ca54398088abc2c5fbd35c81bd8f (patch)
treea248b3f65fbf1d6e620501a60bea6fd261fa4ea9 /net
parente328ffee3a312589301c8e536a43cfb0b4bd05bd (diff)
downloadfreebsd-ports-gnome-b98eb5791615ca54398088abc2c5fbd35c81bd8f.tar.gz
freebsd-ports-gnome-b98eb5791615ca54398088abc2c5fbd35c81bd8f.tar.zst
freebsd-ports-gnome-b98eb5791615ca54398088abc2c5fbd35c81bd8f.zip
Add py-softlayer 5.4.3
This library provides a simple Python client to interact with SoftLayer's XML-RPC API. A command-line interface is also included and can be used to manage various SoftLayer products and services. WWW: https://github.com/softlayer/softlayer-python
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-softlayer/Makefile29
-rw-r--r--net/py-softlayer/distinfo3
-rw-r--r--net/py-softlayer/pkg-descr7
4 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4a7e76cbe52d..d31a5d1a8a60 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1082,6 +1082,7 @@
SUBDIR += py-soap2py
SUBDIR += py-soappy
SUBDIR += py-socketio-client
+ SUBDIR += py-softlayer
SUBDIR += py-speedtest-cli
SUBDIR += py-sshuttle
SUBDIR += py-stomp.py
diff --git a/net/py-softlayer/Makefile b/net/py-softlayer/Makefile
new file mode 100644
index 000000000000..bf1e04c5c1b1
--- /dev/null
+++ b/net/py-softlayer/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= softlayer
+PORTVERSION= 5.4.3
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= SoftLayer-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= SoftLayer API Python Client
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=5:devel/py-click@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0.7.0:devel/py-prettytable@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prompt_toolkit>=0.53:devel/py-prompt_toolkit@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.0.0:textproc/py-pygments@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.18.4:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.7.0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.22:net/py-urllib3@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/net/py-softlayer/distinfo b/net/py-softlayer/distinfo
new file mode 100644
index 000000000000..8ccadf556112
--- /dev/null
+++ b/net/py-softlayer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523016550
+SHA256 (SoftLayer-5.4.3.tar.gz) = 7c4fdfb30ca22ae8096b1b3f03c34cac9e02082d28816a3fd55047a82ed7eb09
+SIZE (SoftLayer-5.4.3.tar.gz) = 253279
diff --git a/net/py-softlayer/pkg-descr b/net/py-softlayer/pkg-descr
new file mode 100644
index 000000000000..7c5e17425bf5
--- /dev/null
+++ b/net/py-softlayer/pkg-descr
@@ -0,0 +1,7 @@
+This library provides a simple Python client to interact with SoftLayer's
+XML-RPC API.
+
+A command-line interface is also included and can be used to manage various
+SoftLayer products and services.
+
+WWW: https://github.com/softlayer/softlayer-python