aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-05-04 02:56:21 +0800
committerlioux <lioux@FreeBSD.org>2002-05-04 02:56:21 +0800
commitfd4cc4d1028102bd07d51cff28c6b41bd8c85872 (patch)
tree38f67e8d82fbefb8cad14d90eff4adf81830942d /net
parentcdbb6b953561e86d2aa773fb4ec8ebe1bfb91fe8 (diff)
downloadfreebsd-ports-gnome-fd4cc4d1028102bd07d51cff28c6b41bd8c85872.tar.gz
freebsd-ports-gnome-fd4cc4d1028102bd07d51cff28c6b41bd8c85872.tar.zst
freebsd-ports-gnome-fd4cc4d1028102bd07d51cff28c6b41bd8c85872.zip
Update to 0.8.6
Diffstat (limited to 'net')
-rw-r--r--net/silc-client/Makefile17
-rw-r--r--net/silc-client/distinfo2
-rw-r--r--net/silc-client/files/patch-Makefile.in12
-rw-r--r--net/silc-client/pkg-plist17
4 files changed, 38 insertions, 10 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index d61b471fe271..e834440fa5a7 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= silc
-PORTVERSION= 0.7.6.1
+PORTVERSION= 0.8.6
CATEGORIES= net ipv6 security
MASTER_SITES= http://www.silcnet.org/download/client/sources/ \
ftp://ftp.silcnet.org/silc/client/sources/ \
@@ -26,6 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/doc/silc/CREDITS:${.CURDIR}/../silc-doc
.endif
USE_BZIP2= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GLIB= yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc/${PORTNAME} \
@@ -42,6 +43,9 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
.endif
pre-everything::
+.ifndef(WITHOUT_IPV6)
+ @${ECHO_MSG} '===> Define WITHOUT_IPV6 to disable IPv6 support'
+.endif
.ifndef(WITHOUT_OPTIMIZED_ASM)
@${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
.endif
@@ -58,6 +62,15 @@ post-patch:
.ifndef(WITH_OPTIMIZED_CFLAGS)
@${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+ @${PERL} -pi -e 's/-D_THREAD_SAFE//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${PERL} -pi -e 's/example_silcd.conf \\\n//' ${WRKSRC}/doc/Makefile.in
+ @${PERL} -pi -e 's/^(install-data-am:) install-docDATA$$/\1/' \
+ ${WRKSRC}/irssi/docs/Makefile.in
+ @${PERL} -pi -e 's/^(install-data-am:) install-moduleLTLIBRARIES$$/\1/' \
+ ${WRKSRC}/irssi/src/perl/Makefile.in
+ @${PERL} -pi -e 's/^(install-data-am: )install-confDATA /\1/' \
+ ${WRKSRC}/irssi/Makefile.in
+ @${PERL} -pi -e 's/silcsim//' ${WRKSRC}/lib/Makefile.in
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
@@ -69,7 +82,7 @@ post-install:
WITHOUT_OPTIMIZED_ASM= yes
.endif
-.if ${OSVERSION} >= 400014
+.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
diff --git a/net/silc-client/distinfo b/net/silc-client/distinfo
index 517e7d7b18e1..1bff3643d562 100644
--- a/net/silc-client/distinfo
+++ b/net/silc-client/distinfo
@@ -1 +1 @@
-MD5 (silc-client-0.7.6.1.tar.bz2) = 9ebf39f6b7196c7b6b1167d2ababbe2e
+MD5 (silc-client-0.8.6.tar.bz2) = fc0e5a60ace77459e7eb812dd93692f9
diff --git a/net/silc-client/files/patch-Makefile.in b/net/silc-client/files/patch-Makefile.in
index 7feb96cacdea..9ae04876ea45 100644
--- a/net/silc-client/files/patch-Makefile.in
+++ b/net/silc-client/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun Feb 3 17:33:38 2002
-+++ Makefile.in Sun Feb 3 17:35:12 2002
+--- Makefile.in.orig Fri May 3 13:05:28 2002
++++ Makefile.in Fri May 3 13:06:35 2002
@@ -151,9 +151,9 @@
AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
@@ -24,17 +24,19 @@
generate-server-key:
-@if test '!' -f $(etcdir)/silcd.pub ; then \
-@@ -565,17 +562,12 @@
+@@ -565,19 +562,12 @@
$(INSTALL_DATA) $(srcdir)/doc/examples/cell* $(docdir)/examples/
etc-install:
- -@if test '!' -f $(etcdir)/silcd.conf ; then \
- $(INSTALL_DATA) $(srcdir)/doc/example_silcd.conf \
-- $(etcdir)/silcd.conf; \
+- $(etcdir)/silcd.conf; \
+- $(INSTALL_DATA) $(srcdir)/doc/silcalgs.conf \
+- $(etcdir)/silcalgs.conf; \
- chmod go= $(etcdir)/silcd.conf; \
- fi
-@if test '!' -f $(etcdir)/silc.conf ; then \
- $(INSTALL_DATA) $(srcdir)/doc/example_silc.conf \
+ $(INSTALL_DATA) $(srcdir)/irssi/silc.conf \
- $(etcdir)/silc.conf; \
+ $(etcdir)/silc.conf.sample; \
fi
diff --git a/net/silc-client/pkg-plist b/net/silc-client/pkg-plist
index 5665206582ae..681dd2dce593 100644
--- a/net/silc-client/pkg-plist
+++ b/net/silc-client/pkg-plist
@@ -1,6 +1,4 @@
bin/silc
-etc/silc/config
-etc/silc/default.theme
etc/silc/silc.conf.sample
share/silc/help/action
share/silc/help/admin
@@ -32,6 +30,7 @@ share/silc/help/hilight
share/silc/help/ignore
share/silc/help/info
share/silc/help/invite
+share/silc/help/invitelist
share/silc/help/join
share/silc/help/key
share/silc/help/kick
@@ -52,6 +51,7 @@ share/silc/help/nick
share/silc/help/notice
share/silc/help/oper
share/silc/help/part
+share/silc/help/perlflush
share/silc/help/ping
share/silc/help/query
share/silc/help/quit
@@ -61,11 +61,13 @@ share/silc/help/rmreconns
share/silc/help/rmrejoins
share/silc/help/save
share/silc/help/sconnect
+share/silc/help/script
share/silc/help/scrollback
share/silc/help/server
share/silc/help/set
share/silc/help/shutdown
share/silc/help/silcoper
+share/silc/help/statusbar
share/silc/help/toggle
share/silc/help/topic
share/silc/help/umode
@@ -73,11 +75,22 @@ share/silc/help/unalias
share/silc/help/unignore
share/silc/help/unload
share/silc/help/unquery
+share/silc/help/upgrade
share/silc/help/users
share/silc/help/version
share/silc/help/whois
share/silc/help/whowas
share/silc/help/window
+share/silc/scripts/autoop.pl
+share/silc/scripts/beep.pl
+share/silc/scripts/clones.pl
+share/silc/scripts/dns.pl
+share/silc/scripts/hello.pl
+share/silc/scripts/mail-maildir.pl
+share/silc/scripts/mail.pl
+share/silc/themes/default.theme
+@dirrm share/silc/themes
+@dirrm share/silc/scripts
@dirrm share/silc/help
@dirrm share/silc
@unexec rmdir %D/etc/silc 2>/dev/null || true