aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-08-12 03:32:37 +0800
committerobrien <obrien@FreeBSD.org>2004-08-12 03:32:37 +0800
commit052847baad15a6326926be13053a51ed55a903f0 (patch)
tree7e0d41384929250cb31569e344b463a169632acc /net
parente74499f77d7c09eba5f3ad56d9f0f8370d68a33f (diff)
downloadfreebsd-ports-gnome-052847baad15a6326926be13053a51ed55a903f0.tar.gz
freebsd-ports-gnome-052847baad15a6326926be13053a51ed55a903f0.tar.zst
freebsd-ports-gnome-052847baad15a6326926be13053a51ed55a903f0.zip
Require GCC 3.3 or earlier; and don't use perl.
Diffstat (limited to 'net')
-rw-r--r--net/mopd/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/mopd/Makefile b/net/mopd/Makefile
index 34a72a428f0d..ae7f73f66278 100644
--- a/net/mopd/Makefile
+++ b/net/mopd/Makefile
@@ -24,15 +24,19 @@ COMMENT= MOP Loader Daemon for netbooting DEC machines
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
# MANDIR is concetenated to DESTDIR which all forms the man install dir...
-USE_PERL5_BUILD= yes
+.include <bsd.port.pre.mk>
MAKE_ENV= DESTDIR=${PREFIX} MANDIR=/man/man NOMANCOMPRESS=true
+USE_REINPLACE= yes
+.if ${OSVERSION} >= 502126
+USE_GCC= 3.3
+.endif
MAN1= mopprobe.1 moptrace.1 mopchk.1 mopa.out.1
MAN8= mopd.8
do-configure:
- @${PERL} -pi.orig -e 's:/usr/sbin:/sbin:' ${WRKSRC}/Makefile.inc
- @${PERL} -pi.orig -e 's/MAN=/MAN8=/' ${WRKSRC}/mopd/Makefile
+ @${REINPLACE_CMD} -e 's:/usr/sbin:/sbin:' ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's/MAN=/MAN8=/' ${WRKSRC}/mopd/Makefile
post-install:
.if !defined(NOPORTDOCS)
@@ -41,4 +45,4 @@ post-install:
${DISTDIR}/VS3100-console-cmds.txt ${PREFIX}/share/doc/mopd
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>