aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2015-01-06 14:33:52 +0800
committercy <cy@FreeBSD.org>2015-01-06 14:33:52 +0800
commit1bd8ec8c30f8b9ef44cabc8e399e5fd27a327604 (patch)
tree9b47717168fd12590b52aa1a7feaf6a11068520d /net
parent95af52eb30e882d538fd5629e2f30d68469c172e (diff)
downloadfreebsd-ports-gnome-1bd8ec8c30f8b9ef44cabc8e399e5fd27a327604.tar.gz
freebsd-ports-gnome-1bd8ec8c30f8b9ef44cabc8e399e5fd27a327604.tar.zst
freebsd-ports-gnome-1bd8ec8c30f8b9ef44cabc8e399e5fd27a327604.zip
Ntp devel port now tracks ntp-4.2.8p1 betas as our upline works to
iron out bugs. We start with beta4.
Diffstat (limited to 'net')
-rw-r--r--net/ntp-devel/Makefile15
-rw-r--r--net/ntp-devel/Makefile.inc2
-rw-r--r--net/ntp-devel/distinfo4
-rw-r--r--net/ntp-devel/files/patch-ntpd__refclock__mx4200.c25
4 files changed, 33 insertions, 13 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index cf547f8de0e9..62d2b0245323 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -2,18 +2,17 @@
# $FreeBSD$
PORTNAME= ntp
-PORTVERSION= 4.2.7p486
+PORTVERSION= 4.2.8p1b4
CATEGORIES= net ipv6
-MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
- http://archive.ntp.org/ntp4/ntp-dev/
+MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
+ http://archive.ntp.org/ntp4/ntp-4.2/ \
+ ftp://ftp.netlab.is.tsukuba.ac.jp/pub/network/ntp/ntp4/
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-dev-${PORTVERSION}-RC
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/:S/b/-beta/}
MAINTAINER= cy@FreeBSD.org
COMMENT= The Network Time Protocol Distribution
-FORBIDDEN= http://www.kb.cert.org/vuls/id/852879
-
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
USES= pathfix shebangfix libtool
@@ -48,10 +47,6 @@ CONFIGURE_ARGS+= --enable-${D}
.endif
.endfor
-.if ${PORT_OPTIONS:MMX4200}
-BROKEN= Fails to compile when MX4200 is enabled.
-.endif
-
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}4
# XXX Temporary hack. Remember to remove this next commit.
diff --git a/net/ntp-devel/Makefile.inc b/net/ntp-devel/Makefile.inc
index 1791578e83ee..147e8e5aceb5 100644
--- a/net/ntp-devel/Makefile.inc
+++ b/net/ntp-devel/Makefile.inc
@@ -1,4 +1,4 @@
-# $FreeBSD: /tmp/pcvs/ports/net/ntp-devel/Makefile.inc,v 1.1 2011-11-27 23:02:28 cy Exp $
+# $FreeBSD: head/net/ntp/Makefile.inc 374987 2014-12-20 00:41:16Z cy $
OPTIONS_DEFINE= NTPSNMPD \
SSL \
diff --git a/net/ntp-devel/distinfo b/net/ntp-devel/distinfo
index fca4ae018dda..8113c61d2d68 100644
--- a/net/ntp-devel/distinfo
+++ b/net/ntp-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ntp-dev-4.2.7p486-RC.tar.gz) = 16efe6adcf401fb8c29dc90f518e0a07f0ae8f0ed7f16a3cc6408d43159310de
-SIZE (ntp-dev-4.2.7p486-RC.tar.gz) = 6551782
+SHA256 (ntp-4.2.8p1-beta4.tar.gz) = 18a1b009635e4d193006fb84d230b2f35997141abd3cb0079a34a40a0dd9d598
+SIZE (ntp-4.2.8p1-beta4.tar.gz) = 6758029
diff --git a/net/ntp-devel/files/patch-ntpd__refclock__mx4200.c b/net/ntp-devel/files/patch-ntpd__refclock__mx4200.c
new file mode 100644
index 000000000000..f0181520b7c3
--- /dev/null
+++ b/net/ntp-devel/files/patch-ntpd__refclock__mx4200.c
@@ -0,0 +1,25 @@
+--- ntpd/refclock_mx4200.c.orig 2014-12-19 11:56:52 UTC
++++ ntpd/refclock_mx4200.c
+@@ -1572,7 +1572,7 @@ mx4200_debug(struct peer *peer, char *fm
+ * Print debug message to stdout
+ * In the future, we may want to get get more creative...
+ */
+- mvprintf(fmt, ap);
++ vprintf(fmt, ap);
+
+ va_end(ap);
+ }
+@@ -1613,11 +1613,11 @@ mx4200_send(peer, fmt, va_alist)
+
+ cp = buf;
+ *cp++ = '$';
+- n = VSNPRINTF((cp, sizeof(buf) - 1, fmt, ap));
++ n = vsnprintf(cp, sizeof(buf) - 1, fmt, ap);
+ ck = mx4200_cksum(cp, n);
+ cp += n;
+ ++n;
+- n += SNPRINTF((cp, sizeof(buf) - n - 5, "*%02X\r\n", ck));
++ n += snprintf(cp, sizeof(buf) - n - 5, "*%02X\r\n", ck);
+
+ m = write(pp->io.fd, buf, (unsigned)n);
+ if (m < 0)